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Foreword
Thank you for purchasing the Light Measurement Data Management Software (Model

329831).  This user’s manual contains useful information about the operating procedures

of the software as well as precautions that should be observed during use.  The

examples used in the manual are based on the Windows 2000 operating system.  To

ensure proper use of the software, please read this manual thoroughly before beginning

operation.

After reading the manual, keep it in a convenient location for quick reference in the event

a question arises.

Please consult the manuals for the Multimedia Display Tester Model 3298 (hereafter

referred to as the MDT 3298) and Windows for the cautions, functions, and operating

procedures of those products.

Notes
• The contents of this manual are subject to change without prior notice as a result of

improvements in the instrument’s performance and functions.  Display contents

illustrated in this manual may differ slightly from what actually appears on your screen.

• Every effort has been made in the preparation of this manual to ensure the accuracy

of its contents.  However, should you have any questions or find any errors, please

contact your nearest YOKOGAWA representative as listed on the back cover of this

manual.

• Copying or reproduction of all or any part of the contents of this manual without the

permission of Yokogawa Electric Corporation is strictly prohibited.

Trademarks
• Microsoft, Windows, and Windows NT are trademarks or registered trademarks of

Microsoft Corporation in the United States and/or other countries.

• Adobe and Acrobat are trademarks or registered trademarks of Adobe Systems

Incorporated.

• The company and product names used in this manual are not accompanied by the

trademark or registered trademark symbols (TM and ®).

• Other company and product names are trademarks or registered trademarks of their

respective holders.

Revisions
1st Edition: February, 2002

Disk No. BA43

1st Edition : February 2002 (YK)

All Rights Reserved, Copyright © 2002 Yokogawa Electric Corporation
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Terms and Conditions of the Software License

NOTICE - PLEASE READ CAREFULLY BEFORE USE
Thank you very much for purchasing this medium containing a software program and related documentation provided by Yokogawa Electric
Corporation (hereinafter called “Yokogawa”), and the program contained, embedded, inserted or used in the medium (hereinafter called the
“Yokogawa Software Program”).

By opening this package or plastic wrapping (hereinafter called “Package”) enclosing  the Yokogawa Software Program, you acknowledge that you
understand and agree to the “Terms and Conditions of the Software License” (hereinafter called “Terms and Conditions”) which is written in the
documentation and separately attached.  Accordingly, the Terms and Conditions bind you.

The Yokogawa Software Program and its related documentation including ownership of copyright shall remain the exclusive property of Yokogawa
or those third parties from whom sublicensed software in the Yokogawa Software Program is licensed.

Yokogawa hereby grants you permission to use the Yokogawa Software Program on the conditions that you agree to the Terms and Conditions
before you open the Package and/or install it in or onto a computer.

IF YOU DO NOT AGREE TO THE TERMS AND CONDITIONS, YOU CANNOT OPEN THE PACKAGE, AND MUST IMMEDIATELY RETURN IT
TO YOKOGAWA OR ITS DESIGNATED PARTY.

Terms and Conditions of the Software License
Yokogawa Electric Corporation, a Japanese corporation (hereinafter called “Yokogawa”), grants permission to use this Yokogawa Software
Program (hereinafter called the “Licensed Software”) to the Licensee  on the conditions that the Licensee agrees to the terms and conditions
stipulated in Article 1 hereof.
You, as the Licensee (hereinafter called “Licensee”), shall agree to the following terms and conditions for the software license (hereinafter called
the “Agreement”) based on the use intended for the Licensed Software.
Please note that Yokogawa grants the Licensee permission to use the Licensed Software under the terms and conditions herein and in no event
shall Yokogawa intend to sell or transfer the Licensed Software to the Licensee.
Licensed Software Name: Light Measurement Data Management Software Model 329831
Number of License: 1

Article 1 (Scope Covered by these Terms and Conditions)
1.1 The terms and conditions stipulated herein shall be applied to any Licensee who purchases the Licensed Software on the condition that the

Licensee consents to agree to the terms and conditions stipulated herein.
1.2 The “Licensed Software” herein shall mean and include all applicable programs and documentation, without limitation, all proprietary

technology, algorithms, and know-how such as a factor, invariant or process contained therein.

Article 2 (Grant of License)
2.1 Yokogawa grants the Licensee, for the purpose of single use, non-exclusive and non-transferable license of the Licensed Software with the

license fee separately agreed upon by both parties.
2.2 The Licensee is, unless otherwise agreed in writing by Yokogawa, not entitled to copy, change, sell, distribute, transfer, or sublicense the

Licensed Software.
2.3 The Licensed Software shall not be copied in whole or in part except for keeping one (1) copy for back-up purposes.  The Licensee shall

secure or supervise the copy of the Licensed Software by the Licensee itself with great, strict, and due care.
2.4 In no event shall the Licensee dump, reverse assemble, reverse compile, or reverse engineer the Licensed Software so that the Licensee

may translate the Licensed Software into other programs or change it into a man-readable form from the source code of the Licensed
Software.  Unless otherwise separately agreed by Yokogawa, Yokogawa shall not provide the Licensee the source code for the Licensed
Software.

2.5 The Licensed Software and its related documentation shall be the proprietary property or trade secret of Yokogawa or a third party which
grants Yokogawa the rights.  In no event shall the Licensee be transferred, leased, sublicensed, or assigned any rights relating to the
Licensed Software.

2.6 Yokogawa may use or add copy protection in or onto the Licensed Software.  In no event shall the Licensee remove or attempt to remove
such copy protection.

2.7 The Licensed Software may include a software program licensed for re-use by a third party (hereinafter called “Third Party Software”, which
may include any software program from affiliates of Yokogawa made or coded by themselves.)  In the case that Yokogawa is granted
permission to sublicense to third parties by any licensors (sub-licensor) of the Third Party Software pursuant to different terms and conditions
than those stipulated in this Agreement, the Licensee shall observe such terms and conditions of which Yokogawa notifies the Licensee in
writing separately.

2.8 In no event shall the Licensee modify, remove or delete a copyright notice of Yokogawa and its licenser contained in the Licensed Software,
including any copy thereof.

Article 3 (Restriction of Specific Use)
3.1 The Licensed Software shall not be intended specifically to be designed, developed, constructed, manufactured, distributed or maintained for

the purpose of the following events:
a) Operation of any aviation, vessel, or support of those operations from the ground;,
b) Operation of nuclear products and/or facilities;,
c) Operation of nuclear weapons and/or chemical weapons and/or biological weapons; or
d) Operation of medical instrumentation directly utilized for humankind or the human body.

3.2 Even if the Licensee uses the Licensed Software for the purposes in the preceding Paragraph 3.1, Yokogawa has no liability to or
responsibility for any demand or damage arising out of the use or operations of the Licensed Software, and the Licensee agrees, on its own
responsibility, to solve and settle the claims and damages and to defend, indemnify or hold Yokogawa totally harmless, from or against any
liabilities, losses, damages and expenses (including fees for recalling the Products and reasonable attorney’s fees and court costs), or claims
arising out of and related to the above-said claims and damages.

Article 4 (Warranty)
4.1 The Licensee shall agree that the Licensed Software shall be provided to the Licensee on an “as is” basis when delivered.  If defect(s), such

as damage to the medium of the Licensed Software, attributable to Yokogawa is found, Yokogawa agrees to replace, free of charge, any
Licensed Software on condition that the defective Licensed Software shall be returned to Yokogawa’s specified authorized service facility
within seven (7) days after opening the Package at the Licensee’s expense.  As the Licensed Software is provided to the Licensee on an “as
is” basis when delivered, in no event shall Yokogawa warrant that any information on or in the Licensed Software, including without limitation,
data on computer programs and program listings, be completely accurate, correct, reliable, or the most updated.

4.2 Notwithstanding the preceding Paragraph 4.1, when third party software is included in the Licensed Software, the warranty period and terms
and conditions that apply shall be those established by the provider of the third party software.
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4.3 When Yokogawa decides in its own judgement that it is necessary, Yokogawa may from time to time provide the Licensee with Revision
upgrades and Version upgrades separately specified by Yokogawa (hereinafter called “Updates”).

4.4 Notwithstanding the preceding Paragraph 4.3, in no event shall Yokogawa provide Updates where the Licensee or any third party conducted
renovation or improvement of the Licensed Software.

4.5 THE FOREGOING WARRANTIES ARE EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES OF QUALITY AND PERFORMANCE,
WRITTEN, ORAL, OR IMPLIED, AND ALL OTHER WARRANTIES INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE ARE HEREBY DISCLAIMED BY YOKOGAWA AND ALL THIRD PARTIES LICENSING THIRD
PARTY SOFTWARE TO YOKOGAWA.

4.6 Correction of nonconformity in the manner and for the period of time provided above shall be the Licensee’s sole and exclusive remedy for
any failure of Yokogawa to comply with its obligations and shall constitute fulfillment of all liabilities of Yokogawa and any third party licensing
the Third Party Software to Yokogawa (including any liability for direct, indirect, special, incidental or consequential damages) whether in
warranty, contract, tort (including negligence but excluding willful conduct or gross negligence by Yokogawa) or otherwise with respect to or
arising out of the use of the Licensed Software.

Article 5 (Infringement)
5.1 If and when any third party should demand injunction, initiate a law suit, or demand compensation for damages against the Licensee under

patent right (including utility model right, design patent, and trade mark), copy right, and any other rights relating to any of the Licensed
Software, the Licensee shall notify Yokogawa in writing to that effect without delay.

5.2 In the case of the preceding Paragraph 5.1, the Licensee shall assign to Yokogawa all of the rights to defend the Licensee and to negotiate
with the claiming party.  Furthermore, the Licensee shall provide Yokogawa with necessary information or any other assistance for
Yokogawa’s defense and negotiation.  If and when such a claim should be attributable to Yokogawa, subject to the written notice to
Yokogawa stated in the preceding Paragraph 5.1, Yokogawa shall defend the Licensee and negotiate with the claiming party at Yokogawa’s
cost and expense and be responsible for the final settlement or judgment granted to the claiming party in the preceding Paragraph 5.1.

5.3 When any assertion or allegation of the infringement of the third party’s rights defined in Paragraph 5.1 is made, or when at Yokogawa’s
judgment there is possibility of such assertion or allegation, Yokogawa will, at its own discretion, take any of the following countermeasures at
Yokogawa’s cost and expense.
a) To acquire the necessary right from a third party which has lawful ownership of the right so that the Licensee will be able to continue to use

the Licensed Software;
b) To replace the Licensed Software with an alternative one which avoids the infringement; or
c) To remodel the Licensed Software so that the Licensed Software can avoid the infringement of such third party’s right.

5.4 If and when Yokogawa fails to take either of the countermeasures as set forth in the preceding subparagraphs of Paragraph 5.3, Yokogawa
shall indemnify the Licensee only by paying back the price amount of the Licensed Software which Yokogawa has received from the
Licensee.  THE FOREGOING PARAGRAPHS STATE THE ENTIRE LIABILITY OF YOKOGAWA AND ANY THIRD PARTY LICENSING
THIRD PARTY SOFTWARE TO YOKOGAWA WITH RESPECT TO INFRINGEMENT OF THE INTELLECTUAL PROPERTY RIGHTS
INCLUDING BUT NOT LIMITED TO, PATENT AND COPYRIGHT.

Article 6 (Liabilities)
6.1 If and when the Licensee should incur any damage relating to or arising out of the Licensed Software or service that Yokogawa has provided

to the Licensee under the conditions herein due to a reason attributable to Yokogawa, Yokogawa shall take actions in accordance with this
Agreement.  However, in no event shall Yokogawa be liable or responsible for any special, incidental, consequential and/or indirect damage,
whether in contract, warranty, tort, negligence, strict liability, or otherwise, including, without limitation, loss of operational profit or revenue,
loss of use of the Licensed Software, or any associated products or equipment, cost of capital, loss or cost of interruption of the Licensee’s
business, substitute equipment, facilities or services, downtime costs, delays, and loss of business information, or claims of customers of
Licensee or other third parties for such or other damages. Even if Yokogawa is liable or responsible for the damages attributable to Yokogawa
and to the extent of this Article 6, Yokogawa’s liability for the Licensee’s damage shall not exceed the price amount of the Licensed Software
or service fee which Yokogawa has received.  Please note that Yokogawa shall be released or discharged from part or all of the liability under
this Agreement if the Licensee modifies, remodels, combines with other software or products, or causes any deviation from the basic
specifications or functional specifications, without Yokogawa’s prior written consent.

6.2 All causes of action against Yokogawa arising out of or relating to this Agreement or the performance or breach hereof shall expire unless
Yokogawa is notified of the claim within one (1) year of its occurrence.

6.3 In no event, regardless of cause, shall Yokogawa assume responsibility for or be liable for penalties or penalty clauses in any contracts
between the Licensee and its customers.

Article 7 (Limit of Export)
Unless otherwise agreed by Yokogawa, the Licensee shall not directly or indirectly export or transfer the Licensed Software to any countries other
than those where Yokogawa permits export in advance.

Article 8 (Term)
This Agreement shall become effective on the date when the Licensee receives the Licensed Software and continues in effect unless or until
terminated as provided herein, or the Licensee ceases using the Licensed Software by itself or with Yokogawa’s thirty (30) days prior written notice
to the Licensee.

Article 9 (Injunction for Use)
During the term of this Agreement, Yokogawa may, at its own discretion, demand injunction against the Licensee in case that Yokogawa deems
that the Licensed Software is used improperly or under severer environments other than those where Yokogawa has first approved, or any other
condition which Yokogawa may not permit.

Article 10 (Termination)
Yokogawa, at its sole discretion, may terminate this Agreement without any notice or reminder to the Licensee if the Licensee violates or fails to
perform this Agreement.  However, Articles 5, 6, and 11 shall survive even after the termination.

Article 11 (Jurisdiction)
Any dispute, controversies, or differences between the parties hereto as to interpretation or execution of this Agreement shall be resolved
amicably through negotiation between the parties upon the basis of mutual trust.  Should the parties fail to agree within ninety (90) days after
notice from one of the parties to the other, both parties hereby irrevocably submit to the exclusive jurisdiction of the Tokyo District Court (main
office) in Japan for settlement of the dispute.

Article 12 (Governing Law)
This Agreement shall be governed by and construed in accordance with the laws of Japan. The Licensee expressly agrees to waive absolutely
and irrevocably and to the fullest extent permissible under applicable law any rights against the laws of Japan which it may have pursuant to the
Licensee’s local law.

Article 13 (Severability)
In the event that any provision hereof is declared or found to be illegal by any court or tribunal of competent jurisdiction, such provision shall be
null and void with respect to the jurisdiction of that court or tribunal and all the remaining provisions hereof shall remain in full force and effect.

Terms and Conditions of the Software License



iv IM 329831-01E

Product Overview

This software can display measurement data from the MDT 3298 in various kinds of

graphs and diagrams, and save and load that data to and from files.

Setting Measurement and Display Conditions

• Color System

Select xyL or u’v’L.

• Measurement and Display Order

Select the measurement and display order for luminance, contrast, flicker, and

chromaticity.

• Default Window

Select Measurement data table (always active), Trend graph, Chroma diagram,

Deviation diagram, or Surface distribution.

• Light Source

Select Type A, FL3, or CRT.

• Chroma Reference

• Reference Coordinates: Enter reference coordinates for the chromaticity diagrams

of each reference color (R(red), G(green), B(blue), W(white), User1, and User2).

• Display Range for the Deviation Diagram: Enter the display range for the deviation

diagram that shows how measurement data differs from the reference color’s

reference coordinates.

• Chromaticity Correction Coefficient:  The software calculates the chromaticity

correction coefficient from the chromaticity and luminance reference values and the

chromaticity and luminance of a typical or representative measurement data value.

The MDT 3298 calculates chromaticity and luminance by applying this chromaticity

correction coefficient to the measured tristimulus values.

• Measurement Mode

Select continuous or single measurement.  For continuous measurement, you can

also select an interval.

• Surface Distribution Settings

• Number of Measurement Points: Select 4, 5, 9, or 13.  You can also change the

measurement location.

• Measurement Order: Specify an order.

• Device Settings

Enter backlight, averaging, and measuring range settings for the MDT 3298.

•  Saving and Loading Setup Data

• Save settings to or load settings from the PC’s storage medium.

• Transmit a light source correction coefficient, chromaticity reference values, and

MDT 3298 settings to and from the MDT 3298.

Saving and Loading Measurement Data

• Read in measurement data while it is being acquired by the MDT 3298.

• Load data stored in the MDT 3298’s memory.

• Save, send, or load data to and from the PC’s storage medium or the MDT 3298.
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Editing and Displaying Measurement Data

• Measurement Data Table

Copy or delete measurement data to and from the clipboard.

• Chromaticity Diagram

• Zoom in or zoom out.

• Plot measurement data on a chromaticity diagram.

• Plotting modes

Select Refresh mode, Scatter mode, or Locus mode.  Only Refresh mode is

available for surface distributions.

• Bar graph

Display a bar graph of the luminance of reference colors.

• Bar graph scale

Select 400, 4000, or 40000 cd/m2.

• Deviation Diagram

• Display statistical values and the determination for chromaticity.

• Plotting modes

Select Refresh mode, Scatter mode, or Locus mode.  Only Refresh mode is

available for surface distributions.

• Trend Graph

• Display the measurement data for luminance, flicker, and chromaticity in a line

graph broken down by measurement order.

• Luminance scale

Select 400, 4000, or 40000 cd/m2.

• Flicker scale

Select 5, 10, 15, or 20%.

Print

• Print the measurement data table, chromaticity diagram, deviation diagram, trend

graph, or surface distribution diagram.

• You can also specify a header and footer, and select whether to print the

measurement conditions, measurement numbers, measurement locations, and

determinations.

Product Overview
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11.1 System Requirements

Hardware
CPU

A personal computer with a Pentium 133 MHz or faster CPU.

Memory

32 MB or more.

Hard Disk

A hard disk with 5 MB or more of available space.

Serial Communications Port

A serial port complying with the EIA-574 (for 9–pin RS-232 connectors) or EIA-232 (RS-

232) standard.

Disk Drive

A CD-ROM drive.  This drive is used to install the software.

Display

A display compatible with your operating system.  An analog RGB monitor capable of

displaying 65,536 colors or more recommended.

Mouse or Pointing Device

A mouse or pointing device compatible with your operating system.

Printer

A printer and printer driver compatible with your operating system.

OS
Microsoft Windows 98, Windows NT 4.0 Workstation, or Windows 2000 Professional.

Multimedia Display Tester (Model 3298)
A device operating under firmware (ROM) version 1.05 or later.

Chapter 1 Before Use
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1.2 Connecting the MDT 3298 to the PC

Connect the MDT 3298 to the PC using a dedicated RS-232 cable.  A D-Sub 9–pin and

25–pin connector is available.   Purchase a cable that matches your PC.

For the part number of the RS-232 cables, refer to the MDT 3298’s user’s manual (IM

329801-01E).

To the sensor

RS-232 cableMultimedia Display 
Tester 
(Model 3298)

PC
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11.3 Installation

Procedure
The following is the installation procedure when using Windows 2000.  The screens

displayed on your monitor may differ depending on your operating system.

1. Turn ON the PC and start Windows.

If you are using Windows NT 4.0 or Windows 2000, log on as the Administrator.

2. Place the CD for this software in the CD-ROM drive.

3. Double-click Disk1 to open the Disk1 folder.

4. Double-click Setup.exe.  The InstallShield Wizard starts.

InstallShield Wizard Start Up Screen
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5. Click Next.

6. Click Yes to agree to the terms of the license agreement, or No to reject the terms.

Go to step 7.

Back to the license agreement screen.

Back to the license agreement screen.Cancel installation.

Yes No

1.3 Installation
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17. To accept the current installation destination click Next.  Installation begins.
* To change the installation destination, click Browse.

The Installation Progress Bar

8. If installation is successful, the Installation Complete dialog box appears.  Click

Finish.

1.3 Installation
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1.4 Running/Exiting the Software

Procedure
Running the Software

Choose Start > Programs > Light Measurement Data Management > Light

Measurement Data Management Software.  The program starts.

Exiting the Software

Choose File > Exit, or click the Close button  in the upper right corner of the Light

Measurement Data Management Software window.  The program closes.

Further Details
A shortcut is created in the Programs section of the Start menu.  You can start this

software using that shortcut.  The software is installed in the folder (installation

destination) specified in the procedure above.
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11.5 Entering Serial Communications Settings

Procedure
1. Choose Settings > Communications.  The Communications Settings dialog box

is displayed.

2. Enter the Port, Bits per second, Data bits, Parity, and Stop bits.

Further Details
Enter settings that correspond to the communications settings on the MDT 3298.

• Communications Port

Use the port number set on the PC for this setting.  To determine the PC’s

communications port number, open the Control Panel then choose System >

Hardware > Device Manager > Ports (COM & LPT).  Click the plus sign (+) next to

Ports to display the installed ports and their numbers.  Note the number of the

communications port (for example, COM1). The available port numbers may differ

depending on your operating system.

• Bits per second, Data bits, Parity, and Stop bits

Enter the same values for these settings as are set on the MDT 3298.

Note
For more information on the communications settings for the PC and MDT 3298, refer to the

respective user’s manuals for those devices.
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2.1 Entering New Measurement and Display
Conditions

Procedure
1. Select File > New, or click the New button  on the toolbar.  The Create New File

dialog box is displayed.

Create New File

2. Follow the procedures in sections 2.2 through 2.8 to enter the measurement and

display conditions.

3. Click OK.  Graphs and diagrams are displayed according to the settings entered.

Further Details
• For information about the measurement and display settings, see sections 2.2 to 2.8.

• You can save or send the settings entered in steps 2.2–2.8 to the MDT 3298 (see

section 2.9).

• While measurements are being taken by the MDT 3298 (see section 3.1), graphs of

the acquired data can be displayed on the PC (see chapter 4) according to the

settings entered in steps 2.2–2.8.

Chapter 2 Working with Measurement and Display Conditions
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2.2 Entering a Header

Procedure
Follow the procedure in section 2.1 to open the Create New File dialog box, then

continue on with the following procedure.

1. Click the Header tab.

2. Type a header in the Header field, then enter the appropriate information in the

Created by, Created on, and Comments fields.
* When printing graphs or diagrams, you can specify whether or not to include the

information entered here (see section 5.2).

Further Details
You can enter the desired header, author, date, and comments to be printed out along

with the graphs or diagrams.  A maximum of 255 characters can be entered in each field.
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2.3 Entering Display Related Settings

Procedure
Follow the procedure in section 2.1 to open the Create New File dialog box, then

continue on with the following procedure.

1. Click the View tab.

2. Select a Color System, the Measurement Order (also used as the display order),

and the Default Windows to be displayed.

Further Details
You can specify the items to be measured and displayed.

Color System

Select the type of chromaticity coordinates from the following:

• xy: xyL color system

• u’v’: u’v’L color system

Measurement Order (and Display Order)

• Specify the order in which various phenomena are measured.  The item specified in

list 1 is measured first, and the item list 4 is measured last.  The phenomena that can

be ordered are luminance, contrast, flicker, and chromaticity.  The order specified

here is also used as the display order.

• List 1 cannot be set to None.

• If list 2, 3, or 4 is set to None, all lists after that one are disabled.

• Only the items that are specified are measured or displayed.

• The same item cannot be selected in more than one list.

Default Windows

• Measurement data table, Trend graph, Chroma diagram, Deviation diagram, or

Surface distribution can be selected for the graphs or diagrams to be displayed.  The

measurement data table is always displayed.

• If you select Surface distribution, Measurement data table and Chromaticity diagram

are automatically selected.  Select whether or not to display the chromaticity diagram.

Note
• If you select only one measurement item in the view tab, the following graphs or diagrams will

be displayed regardless of that setting.  If only Luminance is selected, the measurement data
and trend graph are displayed.  If only Contrast is selected, the measurement data table is
displayed.  For Flicker only, the measurement data table and trend graph.  For Chromaticity
only, the measurement data table, trend graph, chromaticity diagram, and deviation diagram.

• If you select Surface distribution, all measurement items except for chromaticity are disabled.
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2.4 Selecting the Light Source

Procedure
Follow the procedure in section 2.1 to open the Create New File dialog box, then

continue on with the following procedure.

1. Click the Light Source tab.

2. Select a light source from the three available options.  The corresponding light

source correction coefficient will be applied to measurements.

Further Details
Select one of the following light sources.

Type A

A type A light source.  Select this for light bulbs, light bulb/color filter combinations

(automobile taillights), sunlight, sunlight/color filter combinations, and any other light

source that is not included in the categories below.

FL3

A three-wavelength fluorescent lamp.  Select this for fluorescent lights, fluorescent light/

color filter combinations, liquid crystal displays for cold-cathode tubes used on

backlights, and other such lamps.

CRT

Select this for such sources as CRTs and plasma displays.

Note
When measurement is started by this software, the correction coefficient for the selected light

source is sent to the MDT 3298 (see section 3.1).
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2.5 Entering Chromaticity Reference Settings

Procedure
Follow the procedure in section 2.1 to open the Create New File dialog box, then

continue on with the following procedure.

1. Click the Chroma Reference tab.

2. Click a tab from 1 to 10 into which you wish to enter chromaticity reference

settings.

3. Type a name in the Name box.
* The default name in each tab’s Name field is PANEL[tab number] (for example,

PANEL03).   If desired, use the keyboard to change the name.

4. Select a reference color from the choices under the Name box (R–User2).

5. If the Apply check box is cleared, select it.
* (Measurements are taken only for those reference colors whose Apply check boxes  are

selected.)

6. Enter the Reference Coordinates and Display Range for the selected reference

colors.  Click Measurement Settings to use measurement data from the MDT

3298 as the reference coordinates.

7. Click the Chroma Correction Coefficient button.  The Chromaticity Correction

Coefficient dialog box is displayed.
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8. To calculate the chromaticity correction coefficient, enter the Reference Value for

the chromaticity (x, y) and luminosity (L) to be measured, and the chromaticity and

luminosity actually measured on the MDT 3298.

Further Details
Chroma Reference

You can name and enter settings for 10 sets of reference values.  This allows you to

select previously entered chromaticity reference values to match the object being

measured and the measurement environment.  A maximum of eight characters can be

used for the name of the reference value set.

Reference Coordinates for the Reference Color and the Display Range

• For each reference color (R(red), G(green), B(blue), W(white), User1, and User2), you

can enter the reference coordinates and the display range of the deviation diagram

within the range used for the chromaticity diagram.

• You can download the MDT 3298’s measurement data for the reference coordinates.

To do this, make sure the serial communications cable is correctly connected from the

MDT 3298 to the PC (see section 1.5).

• The chromaticity diagram will differ depending on the color system.  See section 2.3

for the color system settings.
Chromaticity Diagram Based 
on the xyL Color System

Chromaticity Diagram Based 
on the u’v’L Color System

2.5 Entering Chromaticity Reference Settings
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2.5 Entering Chromaticity Reference Settings

• You can specify reference colors as User1 and User2 that are neither R, G, B, or W,

and are within the range used for the chromaticity diagram.
* For all reference colors including R, G, B, and W, you can specify arbitrary reference

coordinates, the display range, and the chromaticity correction coefficient.  However to avoid
confusion, it is recommended that you enter a value for R, G, B, and W that is close to their
respective reference colors.

• You can select whether or not the specified reference colors are to be used for

measurement.

Chromaticity Correction Coefficient

Using the chromaticity correction coefficient, data measured on the MDT 3298 can be

adjusted to a standard or to measured data from an instrument you are already using.

The chromaticity correction coefficient is obtained through the following procedure.

1. The reference values for the tristimulus values (X0, Y0, L0) are calculated from a

standard, and previously measured data (x0, y0, L0).

X0=x0L0/y0, Y0=L, Z0=(1–x0–y0)L/y0

2. The measurement data (Xm, Ym, Zm) of the tristimulus values are calculated from the

chromaticity and luminosity of the measurement data from the MDT 3298.

Xm=xmLm/ym, Ym=L, Zm=(1–xm–ym)L/ym

3. The chromaticity correction coefficient is calculated from the reference values of

the tristimulus values (X0, Y0, Z0) and the measurement data (Xm, Ym, Zm).

The chromaticity correction coefficient of the stimulus value X = X0/Xm

The chromaticity correction coefficient of the stimulus value Y = Y0/Ym

The chromaticity correction coefficient of the stimulus value Z = Z0/Zm

Note
When measurement is started by this software, the chromaticity reference for the selected light

source is sent to the MDT 3298 (see section 3.1).
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2.6 Selecting the Measurement Mode

Procedure
Follow the procedure in section 2.1 to open the Create New File dialog box, then

continue on with the following procedure.

1. Click the Measurement Mode tab.

2. Select Continuous or Single.

3. If you select Continuous , enter the Interval for reading in measurement data.

Further Details
You can select one of the following modes to control how data measured on the MDT

3298 is read in by the PC.

Continuous

Measurement begins when you press the Measurement Start button (see section 3.1),

and ends when you press the Measurement Stop button.  Measurement data is

uploaded to the PC repeatedly at the specified interval.  Measurement data read in by

the PC can be displayed in a table (see section 4.1), and opened in a chromaticity

diagram, trend graph, or deviation diagram.

• Interval

• Range: 1 to 3600 seconds

• If you selected chromaticity measurement (see section 2.3) and set the interval to 1

second, the interval setting is ignored and measurement repeats at the minimum

possible interval of 2 seconds.

Single

When the trigger button on the toolbar is pressed, a single measurement is taken and

the resultant data is loaded on the PC.  This corresponds to Single mode on the MDT

3298.  Measurement data read in by the PC can be displayed in a table, and opened in a

chromaticity diagram, trend graph, or deviation diagram.

Note
After measurement starts, it stops again once the Measurement Stop button is pressed, or when

the measurement number reaches 32000 (see section 3.1).
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2.7 Entering the Number of Measurement Points
for the Surface Distribution, and the
Measurement Order

Procedure
Follow the procedure in section 2.1 to open the Create New File dialog box, then

continue on with the following procedure.

1. Click the Surface Distribution tab.

2. Select a number of measurement points from 4 to 13.

3. Specify the order of the measurement locations (A–M).

Further Details
You can specify multiple measurement locations for the distribution of luminance and

chromaticity over a wide area.  This function interpolates between the points so that the

waveform appears to be connected.

• The measurement locations are labeled using English letters.

• The order is indicated by the numerals in the lettered squares.

• By changing the numbers you can change the measurement order.  Enter integers

in numerical order (1, 2, 3, etc.).

• The same number cannot be entered for more than one location.

4 Points 5 Points
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9 Points 13 Points

Note
• When in Continuous measurement mode (see section 2.6), measurement is performed

continuously per the specified interval.  In this mode, if you select Surface distribution for the

view window (see section 2.3), the first measurement is assigned to the first measurement

location, the second measurement is assigned to the second measurement location, and so

on.

• As explained above (in section 3.1), when in Single measurement mode, a single

measurement only is taken when the Trigger button is pressed.  If you select Surface

distribution for the view window (see section 2.3), while in Single mode, the first time the

Trigger button is pressed the measurement is assigned to the first measurement location, the

second time it is pressed measurement is assigned to the second measurement location, and

so on.

2.7 Entering the Number of Measurement Points for the Surface Distribution, and the Measurement Order
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2.8 Entering Settings for the Backlight, Averaging,
and the Measuring Range

Procedure
Follow the procedure in section 2.1 to open the Create New File dialog box, then

continue on with the following procedure.

1. Click the Device Settings tab.

2. Select Backlight, Averaging (number of items to be averaged), and measuring

Range settings for the MDT 3298.

Further Details
The following settings can be entered.

Backlight

Turn the back light on the MDT 3298 ON or OFF.

Averaging

• The linear average based on the specified number of averaging items can be taken

for luminance, contrast, flicker, and chromaticity.  The averages are calculated

according to the following equation.

D=
M1+M2+ . . . Mm–1+Mm

m

D: the linear average of m individual data, m number of times

M1: the first measurement data

M2: the second measurement data

. . . . . . . . . . . . . . . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Mm–1: the m-1th measurement data

Mm: the mth measurement data

m: the number of items to be averaged (from 2 to 20)

• After measuring the specified number of averaging items, the average value is

displayed.

• If you select None, averaging will not be performed.

Measuring Range

Select the measuring range for luminance, contrast, flicker, and chromaticity.

Note
When measurement is started by this software, the device settings are sent to the MDT 3298
(see section 3.1).
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2.9 Saving the Settings

Procedure
Follow the procedure in section 2.1 to open the Create New File dialog box, then

continue on with the following procedure.

Saving a Settings File

1. Under the File group, click Save.  The Save dialog box is displayed.

2. Type or select the save destination and file name, then click OK.

Sending Settings to the MDT 3298

1. Under the MDT 3298 group, click Send.  The Send Settings dialog box is

displayed.

2. Click OK.

Further Details
Saving Settings to a File

• All settings entered in sections 2.2–2.8 can be saved to a file.

• Up to 8 characters may be used for the file name (excluding the extension).

• The file name extension is .dat.

• If a file with the same name already exists, it is overwritten.

Sending Settings to the MDT 3298

• A light source correction coefficient (section 2.4), the chromaticity reference values

(section 2.5), and device settings are sent to the MDT 3298.

• The new settings overwrite the current settings on the MDT 3298 to which they sent

are sent.
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2.10 Loading the Settings

Procedure
Follow the procedure in section 2.1 to open the Create New File dialog box, then

continue on with the following procedure.

Loading a Settings File

1. Under the File group, click Load.  The File Open dialog box is displayed.

2. Select a file, then click OK.

Loading Settings from the MDT 3298

1. Under the MDT 3298 group, click Load.  The Load MDT 3298 Settings dialog box

is displayed.

2. Click OK.

Further Details
Loading a Settings File

• The selected previously saved settings are loaded, and any existing settings are

overwritten.

• The file name extension is .dat.

Loading Setup Parameters from the MDT 3298

A light source correction coefficient (section 2.4), the chromaticity reference values

(section 2.5), and device settings are loaded from the MDT 3298, overwriting the current

settings.



3-1IM 329831-01E

S
avin

g
 an

d
 L

o
ad

in
g

 M
easu

rem
en

t D
ata

3

3.1 Reading In Measurement Data Being Acquired
by the MDT 3298

Procedure
The procedure for reading in measurement data differs depending on the measurement

mode.  There are two measurement modes: Continuous, and Single (see the next page).

Choose the appropriate mode for your measurement application.  Refer to section 2.6 for

information on measurement mode settings.

When in Continuous Measurement Mode

• Starting Measurement

1. Select Measurement > Start, or click the Measurement Start button  on the

toolbar.  The Message dialog box is displayed.

2. Click Yes.  Measurement begins.

Before measurement begins, if you entered new settings or changed any settings

in the Create New File window or the Setting Information dialog box under the

Settings menu, when you close the setting window a dialog box appears prompting

you to confirm whether or not those settings should be sent the MDT 3298.
* During measurement, the item being measured or about to be measured appears in the

status bar of the Light Measurement Data Management Software window.

Confirmation Dialog Box

• Stopping Measurement

3. Select Measurement > Stop, or click the Measurement Stop button  on the

toolbar.

Chapter 3 Saving and Loading Measurement Data
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When in Single Measurement Mode

• Starting Measurement

1. Select Measurement > Start, or click the Measurement Start button  on the

toolbar.  The Message dialog box is displayed.

2. Click Yes.

Before measurement begins, if you entered new settings or changed any settings

in the Create New File window or the Setting Information dialog box under the

Settings menu, when you close the window a dialog box appears prompting you to

confirm whether or not those settings should be sent the MDT 3298.
* During measurement, the item being measured or about to be measured appears in the

status bar of the Light Measurement Data Management Software window.

Confirmation Dialog Box

3. Click the Trigger button  on the toolbar when it becomes active.  A single

measurement is performed.

4. Repeat step 3 as many times as necessary.

• Stopping Measurement

5. Select Measurement > Stop, or click the Measurement Stop button  on the

toolbar.

3.1 Reading In Measurement Data Being Acquired by the MDT 3298
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Further Details
There are two measurement modes: Continuous and Single.  The procedure for loading

measurement data differs depending on the mode used.  Refer to section 2.6 for

information on how to select the measurement mode.

• Each item is measured according to the order specified using the procedure in section

2.3.

For example, measurement repeats in the following manner.  Luminance -> Contrast -

>Flicker -> Chromaticity (measured at each reference color) -> Luminance… (and so

on).

• Each item of the loaded measurement data is automatically displayed in the

measurement data table, and then in a chromaticity diagram, deviation diagram, or

trend graph (see chapter 4) per the default window settings.

• A measurement number (see the table below) from 1 to 32000 is added to each data

in the order in which they are measured.  Measurement numbers cannot be changed.

• If you open a saved measurement data file and then start additional measurements,

the new data is assigned measurement numbers starting from where the original

numbers left off.  The first item to be measured is the first item you specified using the

procedure in section 2.3.  This is true even if the previous data ends before the last

measurement item.

Continuous Measurement

• When the Measurement Start button is pressed, measurement repeats continuously

at the specified interval (see section 2.6) until the Measurement Stop button is

pressed, or measurement number 32000 is reached.

• If measurement is stopped part way through, the item being measured when

measurement stopped is not included in the final measurement data.  For example, if

measurement is stopped while the white contrast is being measured, the last white

contrast measurement item will not be displayed.

• If you restart measurement after stopping measurement part way through,

measurement continues on from the item being measured when the stop occurred.

Measurement Data Table during Continuous Measurement

Status Bar
The currently measured item or the item to be measured next is displayed.

3.1 Reading In Measurement Data Being Acquired by the MDT 3298
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Single Measurement

• When the Trigger button on the toolbar is pressed, measurement is performed one

time.  This corresponds to Single mode on the MDT 3298.

• In the example below when you press the Trigger button, at first only Luminance is

measured.  The second time the Trigger button is pressed, white contrast is

measured.  In this manner, the next item in sequence is measured each time the

button is pressed.

• Once measurement number 32000 has been reached, measurement will not continue

even if you press the Trigger button.

Measurement Data Table during Single Measurement 
(after Single Measurement of Luminance and Contrast)

Status Bar
The currently measured item or the item to be measured next is displayed.

For Surface Distribution

• You can perform surface distribution measurements by selecting Surface distribution

in the View tab (see section 2.3).

• For details on the measurement data table for surface distribution, see section 4.5.

• When in Continuous measurement mode (see section 2.6), measurement is

performed continuously per the specified interval.  The first measurement is taken at

the first measurement location, the second measurement is taken at the second

measurement location, and so on.

• When in Single measurement mode, a single measurement is taken each time the

Trigger button is pressed.  The first time the Trigger button is pressed, measurement

is taken at the first measurement location, the second time the button is pressed,

measurement is taken at the second measurement location, and so on.

Note
• Measurement stops when the measurement number reaches 32000.  After that,

measurement cannot be restarted.  If you want to take additional measurements, save the

current measurement data (see section 3.3), then follow the procedure in section 2.1 to

create a new file.  Measurement can then be started.

• Do not perform operating procedures on the MDT 3298 during measurement (other than

measurement itself).  This may hinder accurate measurement.

• During continuous measurement, no procedures can be performed other than stopping

measurement.  During single measurement, no procedures can be performed other than

pressing the Trigger button or stopping measurement.

3.1 Reading In Measurement Data Being Acquired by the MDT 3298
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3.2 Downloading All Data from the MDT 3298

Procedure
1. Choose File > Download Data.  The Message dialog box is displayed.

2. Click Yes.

All data in the MDT 3298’s memory numbers 001–200 will be downloaded to the

PC.

Further Details
You can download all data (all measurement items) in the MDT 3298’s memory to the

PC.  All data in memory numbers 001–200 will be downloaded to the PC at once.

• Memory No. 001 corresponds to measurement number 1 of the measurement data,

No. 002 corresponds to measurement number 2, and so on, up to No. 200.

• If no data were saved to a certain memory number, the corresponding row in the

measurement data table will be blank.
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3.3 Saving Measurement Data and Closing Files

Procedure
Four file operations are discussed in this section: saving to a file name, saving

(overwriting), saving to a text file, and closing.

Saving to a Specified File Name

1. Choose File > Save As.  The Save As dialog box is displayed.

2. Type or select the save destination and file name, then click OK.  The

measurement data is saved.

Saving (Overwriting)

Select File > Save, or click the Save button  on the toolbar.

If the data being saved is new, the Save As dialog box mentioned above appears.

If you open a preexisting measurement data file and make changes to it, when you close

the window a dialog box appears prompting you to confirm whether or not to save the

file.

Confirmation Dialog Box
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Saving As a Text File

1. Choose File > Save As Text.  The Save As Text dialog box is displayed.

2. Choose whether to save settings by selecting the corresponding check boxes.

Select a delimiter and quote character from the lists.

3. Select the check boxes next to Measurement no., Luminance, Contrast, Flicker,

and Chromaticity check boxes for the items you wish to save.

4. Click Save.  The Save As dialog box is displayed.

5. Type or select the save destination and file name, then click OK.  The

measurement data is saved.

3.3 Saving Measurement Data and Closing Files
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Closing

Choose File > Close.  The measurement data file closes.

If you open a new or preexisting measurement data file and make changes to it, when

you close the window a dialog box appears prompting you to confirm whether or not to

save the file.

Confirmation Dialog Box

(For new measurement data files)

(For preexisting measurement data files)

or 

3.3 Saving Measurement Data and Closing Files
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Further Details
There are two available file formats for measurement data saving: a dedicated format for

this software, and text format.

Saving to the Dedicated Format Used by This Software

• You can choose either the Save or Save As command when saving to this format.

• Up to 8 English letters may be used for the file name (excluding the extension).

• The file name extension is .dat.

• If a file with the same name already exists, it is overwritten.

Saving in Text Format

• You can select whether or not to save settings, and enter such settings as the

delimiter and the quote character.

• You can select the Measurement no., Luminance, Contrast, Flicker, and Chromaticity

check boxes for the items to be saved.

• Up to 8 English letters may be used for the file name (excluding the extension).

• You can select a file name extension of .txt or .csv.  Note that both TXT and CSV are

text formats, so the data will be saved as a text file regardless of which extension you

choose.

• If a file with the same name already exists, it is overwritten.

An Example of Data Saved As Text

(Given that the settings is to be saved, tab is to be used as the delimiter for the

measurement data, and [“] is to be used as the quote character.)

3.3 Saving Measurement Data and Closing Files
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3.4 Opening Saved Measurement Data Files

Procedure
1. Select File > Open, or click the Open button  on the toolbar.  The File Open

dialog box is displayed.

2. Select a file to open, then click OK. The measurement data file is loaded.  If you

open a new or preexisting measurement data file and make changes to it, when

you close the file a dialog box appears prompting you to confirm whether or not to

save the changes.

Confirmation Dialog Box

(For new measurement data files)

(For changed, preexisting measurement data files)

or 

Further Details
You can open measurement data files saved in this software’s dedicated file format.

• The file name extension is .dat.

• This software only allows you to edit, view, or add measurements to one

measurement data file at a time.  Multiple files cannot be processed at the same time.
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4.1 Editing the Measurement Data Table

Procedure
Read in measurement data from the MDT 3298, or open a previously saved

measurement data file.  With at least the measurement data table displayed, you can

perform the following procedures to edit the data.  If you selected surface distribution as

a default window using the procedure in section 2.3, refer to section 4.5.

• Copy the data in the measurement data table to the clipboard: see below.

• Delete all data: see page 4-2.

• Delete the last data: see page 4-3.

• Display details: see page 4-4.

• Plot data: see sections 4.2–4.4.

Copying Data from the Measurement Data Table to the Clipboard
Copying a Portion of the Data

1. Drag the mouse to select the range of cells to be copied.

or

2. Choose Edit > Copy.  The selected range is copied to the clipboard.
* You can also right click on the selected area and select Copy from the shortcut menu.

3. Paste the contents of the clipboard onto a new file in a text editor.

Pasting the Contents of the Clipboard into Notepad

Chapter 4 Editing and Displaying Measurement Data
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Copying All Data

1. Choose Edit > Select All.  All measurement data in the measurement data table is

selected.
* You can also right click on the selected area to display the shortcut menu.  Choose Select

All.

The Measurement Data Table with All Data Selected

2. Perform steps 2 and 3 in “Copying a Portion of the Data” above.

Deleting All Data
Note

Deleted measurement data cannot be restored.  It is recommended that you save measurement

data to a file (see section 3.3) before deleting it.

Choose Edit > Delete All.  All measurement data is deleted.  Before the deletion is

carried out, a dialog box appears prompting you to confirm deletion.
* You can also right click on the selected area to display the shortcut menu.  Choose Delete All

from the menu.

Confirmation Dialog Box

4.1 Editing the Measurement Data Table
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Deleting the Last data
Note

Deleted measurement data cannot be restored.  It is recommended that you save measurement

data to a file (see section 3.3) before deleting it.

Choose Edit > Delete Last.  The last data in the measurement data table is deleted.

Before the deletion is carried out, a dialog box appears prompting you to confirm

deletion.
* You can also right click on the selected area to display the shortcut menu.  Choose Delete Last

from the menu.

Confirmation Dialog Box

Deletion of the Last data

Delete

4.1 Editing the Measurement Data Table
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 Displaying and Copying Details
Displaying Details

1. Click any cell in the row corresponding to the measurement number of the data

whose details you wish to view.

2. Right click the selected cell.  A shortcut menu appears.

3. Select Details.  The details table appears.

If you select Details while the details table is open, it will close.

Details Table

Copying a Portion of the Details

4. Drag the mouse to select the range of cells to be copied.

 or 

5. Using the mouse, right click in the details table.  A shortcut menu appears.

6. Select Copy.  The selected range is copied to the clipboard.

4.1 Editing the Measurement Data Table



4-5IM 329831-01E

E
d

itin
g

 an
d

 D
isp

layin
g

 M
easu

rem
en

t D
ata

4

 7. Paste the contents of the clipboard onto a new file in a text editor.

Pasting the Contents of the Clipboard into Notepad

Copying All Details

4. Using the mouse, right click in the details table.  A shortcut menu appears.

5. Choose Select All.  All data in the details table is selected.

The Details Table with All Data Selected

6. Perform steps 5–7 in “Copying a Portion of the Details” above.

Plotting Data
You can click (or drag a selection) measurement data in the measurement data table,

and then plot that data in a chromaticity diagram, deviation diagram, or trend graph.  For

the operating procedure, see sections 4.2–4.4.

4.1 Editing the Measurement Data Table
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Further Details
Read in measurement data from the MDT 3298, or open a previously saved

measurement data file.  With at least the measurement data table displayed, you can

perform edits on the data.  If you selected surface distribution as a default window using

the procedure in section 2.3, refer to section 4.5.

Measurement Data Table

Data measured by the MDT 3298 is read into the measurement data table.  The items

below are displayed in the order specified using the procedure in section 2.3.

• Measurement Number

The number from 1 to 32000 that is assigned to each data in order as they are

measured.  The number cannot be changed.

• Luminance

The brightness of the light source as detected from a certain direction.  The units of

luminance are cd/m2.

• Contrast

The ratio of the luminance when white is displayed to that when black is displayed.

• Flicker Ratio

The ratio of the variation in the brightness. Flicker occurs when the brightness of the

screen changes at an interval longer than that for the decay of the afterimage in the

human eye.  Flicker is expressed as a percentage.

• x, y, and L, or u’, v’, and L

Either x, y, and L, or u’, v’, and L columns are displayed per the color system you

chose in section 2.3.

The chromaticity and luminance of the measurement data for each reference color (R,

G, B, W, User1, and User2) as expressed by the xyL or u’v’L color system.  x, y or u’,

v’ have no units, but the units of L are cd/m2.

Measurement Data Table

Details Table

The following items are displayed in each row of the Details table for the data in the R,

G, B, W, User1, and User2 column groups.

• Measurement Time

The time the data was measured on the MDT 3298.  This time reflects the time on the

PC’s internal clock during measurement.

• X, Y, and Z

The tristimulus values.  The symbols X, Y, and Z, indicate the three primary colors as

perceived by the human eye.  They are assigned values that are measured on the

MDT 3298.

• x, y or u’, v’

Same as those in “Measurement Data Table” above.

4.1 Editing the Measurement Data Table
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• Tc

The color temperature as calculated from the measurement data.  The color

temperature is the absolute temperature of a blackbody radiator having a chromaticity

equal to that of the light source.  The units of Tc are K (Kelvin).

• duv

The divergence between the position of the color temperature calculated from the

measurement data, and the same color temperature position on the blackbody locus

(locus of the color temperature of the blackbody).

• Delta Tc

The difference between Tc (color temperature of the measurement data) and the color

temperature of the reference color.

• Delta duv

The difference between the duv of the measurement data and the duv of the

reference color.

Details Table

Measurement 
number

* When the color temperature can not be calculated from the measurement data or the
chromaticity coordinates of the reference color, ERROR appears in the Tc, duv, Delta Tc, and
Delta duv rows.

Copying to the Clipboard

You can copy the data from the measurement data table and the details table to the PC’s

clipboard.  You can paste the data from the clipboard to a text editor and create a new

document.

• Partial Copy

Copy only the selection made by dragging the cursor with the mouse.

• Copy All Data

You can copy all the data from the measurement data table and the details table.

Deleting All Data

• All the data from the measurement data table and the details table is deleted.

• If all data is deleted, it can not be restored.  It is recommended that you save

measurement data to a file (see section 3.3) before deleting it.

Deleting the Last data

• All the last data from the measurement data table and the details table are deleted.

• Deleted measurement data cannot be restored.  It is recommended that you save

measurement data to a file (see section 3.3) before deleting it.

• The data measured by the MDT 3298 is deleted one item at a time.  For example, if

the final measurement data is in column R of measurement number 4, then the row 4

cells in column group R are deleted when you perform the last data deletion

procedure.

4.1 Editing the Measurement Data Table
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Plotting Data

You can click (or drag to select) measurement data in the measurement data table, and

then plot that data in a chromaticity diagram, deviation diagram, or trend diagram.  See

sections 4.2–4.4.

Note
During measurement, all menu commands (other than measurement stop), as well as the select

measurement data, copy, and delete functions are disabled.

4.1 Editing the Measurement Data Table
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4.2 Displaying the Chromaticity Diagram

Procedure
Read in measurement data from the MDT 3298, or open a previously saved

measurement data file.  With at least the measurement data table and chromaticity

diagram displayed, you can perform the following procedures.  If you selected surface

distribution as a default window using the procedure in section 2.3, refer to section 4.6.

• Display, and zoom in and out on the chromaticity diagram: see below.  If the

chromaticity diagram is not displayed, perform the procedure below to display it.

• Plot in Refresh mode: see page 4-10.

• Plot in Scatter mode: see page 4-11.

• Plot in Locus mode: see page 4-13.

• Select the bar graph scale: see page 4-15.

• Delete plotted points and locus lines: see page 4-15.

Displaying and Zooming In and Out on the Chromaticity Diagram
Note

Perform step one if the chromaticity diagram is not displayed.  Note that if you perform this step

when the diagram is already open, it will close.

1. Choose View > Chromaticity Diagram, or click the Chromaticity Diagram button

 on the toolbar.  The chromaticity diagram is displayed.

2. Click the Form Size button  in the diagram to zoom in and out.

Chromaticity Diagram
Reduced Form (Default Display) Expanded Form
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Plotting in Refresh Mode
1. Click the Refresh Mode button  in the chromaticity diagram.  The diagram enters

Refresh mode (in which a single point is plotted at a time).

Plot Measurement Data as It Is Being Read In

2. Follow the steps in section 3.1 to start measurement.  The data from the R, G, B,

W, User1, and User2 column groups is plotted in the chromaticity diagram.
The plotted points from the previous data are erased.

Use the Current Data (Stop Reading In Data), or Open and Plot Data from a

Measurement Data File

2. Click the mouse on a cell in the R, G, B, W, User1, or User2 column group of the

measurement data table.  Data from each column within the group you click is

plotted in the chromaticity diagram.
The plotted points from the previous data are erased.

Plotting the Data in the R Column Group

Plotted points

4.2 Displaying the Chromaticity Diagram
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Plotting in Scatter Mode
1. Click the Scatter Mode button  in the chromaticity diagram.  The diagram enters

Scatter mode (in which multiple points can be plotted).

Plot Measurement Data as It Is Being Read In

2. Follow the steps in section 3.1 to start measurement.  The data from the R, G, B,

W, User1, and User2 column groups is plotted in the chromaticity diagram.
The plotted points from previous data are not erased.

Use the Current Data (Stop Reading In Data), or Open and Plot the Data from a

Measurement Data File

• Plotting Data One at a Time

2. Click the mouse on a cell in the R, G, B, W, User1, or User2 column group of the

measurement data table.  Data from each column within the group you click is

plotted in the chromaticity diagram.
The plotted points from previous data are not erased.

Plotting the Data in the R, G, and B Column Groups

Plotted points

• Plotting by Measurement Number

2. Click a cell in the row corresponding to the measurement number whose data you

wish to plot.  The data from the R, G, B, W, User1, and User2 column groups of the

selected measurement number is selected to be plotted in the chromaticity diagram.

3. Right click the selected cell.  A shortcut menu appears.

4. Select Plot.  The data is plotted in the order in which it was measured.
The plotted points of any previous data are erased, and the data for the selected
measurement number is plotted.

4.2 Displaying the Chromaticity Diagram
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Plotting the Data from Measurement Number 1

Plotted points

• Plotting a Selection

2. Drag the mouse to select a range of rows to be plotted.  Data in the R, G, B, W,

User1, and User2 column groups for the measurement numbers in the selected

range are selected for plotting.

3. Right click the selection.  A shortcut menu appears.

4. Select Plot.  The data is plotted in the order in which it was measured.
The plotted points of any previous data are erased, and the selected data is plotted.

• Plotting All Data at Once

2. Right click any cell.  A shortcut menu appears.

3. Choose Select All.  All the data from the R, G, B, W, User1, and User2 column

groups in the measurement data table are selected for plotting.

4. Perform steps 3 and 4 in “Plotting a Selection” above.

Plotting All or the Selected Data

Plotted points 
(multiple plotted points are displayed 
in almost the same spot)

4.2 Displaying the Chromaticity Diagram
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Plotting in Locus Mode
1. Click the Locus Mode button  in the chromaticity diagram.  The diagram enters

Locus mode (in which locus lines are drawn between plotted points).

Plot Measurement Data as It Is Being Read In

2. Follow the steps in section 3.1 to start measurement.  The data from the R, G, B,

W, User1, and User2 column groups is plotted in the chromaticity diagram.
A locus line is drawn between this data and the plotted points from the previous data.

Use the Current Data (Stop Reading In Data), or Open and Plot Data from a

Measurement Data File

• Plotting One Data at a Time

2. Click the mouse on a cell in the R, G, B, W, User1, or User2 column group of the

measurement data table.  Data from each column within the group you click is

plotted in the chromaticity diagram.
Locus lines are plotted between this data and the plotted points from any previous data.

Plotting the Data in the R, G, and B Column Groups

Plotted points

Locus lines

• Plotting By Measurement Number

2. Click a cell in the row corresponding to the measurement number whose data you

wish to plot.  The data from the R, G, B, W, User1, and User2 column groups of the

corresponding measurement number is selected for plotting.

3. Right click the selected cell.  A shortcut menu appears.

4. Select Plot.  The data is plotted in the order in which it was measured.
The plotted points and locus lines of any previous data are erased, and points and locus lines
for the data of the selected measurement numbers are plotted and drawn.

4.2 Displaying the Chromaticity Diagram
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Plotting the Data from Measurement Number 1

Plotted points

Locus lines

• Plotting a Selection

2. Drag the mouse to select a range of rows to be plotted.  Data in the R, G, B, W,

User1, and User2 column groups for the measurement numbers in the selected

range are selected for plotting.

3. Right click the selection.  A shortcut menu appears.

4. Select Plot.  The data is plotted in the order in which it was measured.
The plotted points and locus lines of any previous data are erased, and points and locus lines
for the data of the selected range are plotted and drawn.

• Plotting All Data at Once

2. Right click any cell.  A shortcut menu appears.

3. Choose Select All.  All the data from the R, G, B, W, User1, and User2 column

groups in the measurement data table are selected for plotting.

4.2 Displaying the Chromaticity Diagram
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4. Perform steps 3 and 4 in “Plotting a Selection” above.

Plotting All or the Selected Data

Plotted points 
(multiple plotted points are displayed 
in almost the same spot)

Locus lines 
(several locus lines are displayed overlapping)

Selecting Bar Graph Scale
Select a bar graph scale from the Max Luminance list in the chromaticity diagram.

When the scale is 400 cd/m2 When the scale is 4000 cd/m2

Deleting Plotted Points and Locus Lines
Click the Clear button  in the chromaticity diagram.  All plotted points and locus lines

in the chromaticity diagram are deleted.

Deleting Plotted Points and Locus Lines

4.2 Displaying the Chromaticity Diagram
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Further Details
If you selected Chromaticity diagram as one of the default windows (see section 2.3),

when you read in data from the MDT 3298 or open a saved measurement data file, a

chromaticity diagram of the loaded data is displayed on the screen.

• If the chromaticity diagram is not displayed, you can display it using the View menu.

• If you selected Surface distribution as a default window using the procedure in section

2.3, refer to section 4.6.

Chromaticity Diagram

The data from the R, G, B, W, User1, and User2 column groups in the measurement

data table can be selected for the chromaticity diagram.

• Chromaticity Coordinates

Chromaticity coordinates are displayed per the color system selected in section 2.3.

• Bar graph

You can display the luminance from the R, G, B, W, User1, and User2 column groups

in a bar graph.  You can change the scale for the bar graph (see below).

Zooming In and Out on the Chromaticity Diagram

• Reduced form (size) is the default zoom level.

• To more easily view the data plotted in the chromaticity diagram, you can zoom the

diagram.

The Chromaticity Diagram’s Plotting Modes

There are three modes for plotting the data from the R, G, B, W, User1, and User2

column groups in the chromaticity diagram.

• Refresh Mode

• Plot only a single selected data point (after, not during measurement) in the

chromaticity diagram.

• If you select all data for plotting while in this mode, only the last data in the

measurement data table is plotted.

• Scatter Mode

• Plot multiple points from the selected data (after, not during measurement) in the

chromaticity diagram.

• If you select all data for plotting, all data in the measurement data table is plotted in

the order in which it was measured.

• Locus Mode

• If you plot the selected data (after, not during measurement) in the chromaticity

diagram, locus lines are drawn between the current data and the previous data.

• If you select all data for plotting, all data in the measurement data table and locus

lines for that data are plotted and drawn in the order in which the data was

measured.

Selecting Bar Graph Scale

• The default value for the scale is 400 cd/m2.

• Select a scale from the following choices.  The units of luminance are cd/m2.

400, 4000, 40000

Deleting Plotted Points and Locus Lines

All plotted points and locus lines in the chromaticity diagram are deleted at once.

Note
During measurement all menu commands (other than Measurement stop), as well as the

functions that allow you to zoom the chromaticity diagram in/out, change the plotting mode,

select the bar graph scale, and delete plotted points and locus lines are disabled.

4.2 Displaying the Chromaticity Diagram
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4.3 Displaying the Deviation Diagram

Procedure
Read in measurement data from the MDT 3298, or open a previously saved

measurement data file.  With at least the measurement data table and deviation diagram

displayed, you can perform the following procedures.

• Display the deviation diagram: see below.  If the deviation diagram is not displayed,

perform this procedure to display it.

• Plot in Refresh mode: see page 4-18.

• Plot in Scatter mode: see page 4-19.

• Plot in Locus mode: see page 4-21.

• Delete plotted points and locus lines: see page 4-23.

• Display statistical values: see page 4-23.

Displaying the Deviation Diagram
Note

Perform this procedure if the deviation diagram is not displayed.  Note that if you perform this

step when the diagram is already open, it will close.

Choose View > Deviation Diagram, or click the Deviation Diagram button  on the

toolbar.  The deviation diagram is displayed.

Deviation Diagram
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Plotting in Refresh Mode (Displaying Reference and Measurement Values, and the
Deviation)

Regardless of the plotting mode, statistical values may be displayed

simultaneously.  For information on displaying statistical values, see page 4-23.

1. Click the Refresh Mode button  in the deviation diagram.  The diagram enters

Refresh mode (in which a single point is plotted at a time).

Plot Measurement Data as It Is Being Read In

2. Follow the steps in section 3.1 to start measurement.  The data from the R, G, B,

W, User1, and User2 column groups is plotted in the deviation diagram.  Values

are displayed in the Reference Value, Measurement Value, and Deviation rows of

the deviation diagram.
The plotted points of any previous data are erased, and the data in the Reference Value,
Measurement Value, and Deviation rows is updated.  If the value in the Measurement Values
row lies within the display range on the deviation diagram, PASS is displayed in the
Determination row, and if it falls outside the range, FAIL is displayed.

Use the Current Data (Stop Reading In Data), or Open and Plot the Data from a

Measurement Data File

2. Click the mouse on a cell in the R, G, B, W, User1, or User2 column group of the

measurement data table.  Data from each column within the group you click is

plotted in the deviation diagram.  Values are displayed in the Reference Value,

Measurement Value, and Deviation rows of the deviation diagram.
The plotted points of any previous data are erased, and the data in the Reference Value,
Measurement Value, and Deviation rows is updated.  If the value in the Measurement Values
row lies within the display range on the deviation diagram, PASS is displayed in the
Determination row, and if it falls outside the range, FAIL is displayed.

Plotting the Data from Measurement Number 1
Plotted points (data in the G column group is not plotted in the 
deviation diagram, because the G data falls outside of the display range. )

Statistical value rows (the statistical values are displayed simultaneously).  
For information on displaying statistical values, see page 4-23.

4.3 Displaying the Deviation Diagram
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Plotting in Scatter Mode (Displaying Reference and Measurement Values, and the
Deviation)

Regardless of the plotting mode, statistical values may be displayed

simultaneously.  For information on displaying statistical values, see page 4-23.

1. Click the Scatter Mode button  in the deviation diagram.  The diagram enters

Scatter mode (in which multiple points can be plotted).

Plot Measurement Data as It Is Being Read In

2. Follow the steps in section 3.1 to start measurement.  The data from the R, G, B,

W, User1, and User2 column groups is plotted in the deviation diagram.  Values

are displayed in the Reference Value, Measurement Value, and Deviation rows of

the deviation diagram.
The plotted points of any previous data are not erased, and the data in the Reference Value,
Measurement Value, and Deviation rows is updated.  If the value in the Measurement Values
row lies within the display range on the deviation diagram, PASS is displayed in the
Determination row, and if it falls outside the range, FAIL is displayed.

Use the Current Data (Stop Reading In Data), or Open and Plot a Measurement

Data File

• Plotting Data One at a Time

2. Click the mouse on a cell in the R, G, B, W, User1, or User2 column group of the

measurement data table.  Data from each column within the group you click is

plotted in the deviation diagram.  Values are displayed in the Reference Value,

Measurement Value, and Deviation rows of the deviation diagram.
The plotted points of any previous data are not erased, and the data in the Reference Value,
Measurement Value, and Deviation rows is updated.  If the value in the Measurement Values
row lies within the display range on the deviation diagram, PASS is displayed in the
Determination row, and if it falls outside the range, FAIL is displayed.

Plotting the Data from the R Column Group in 3, 2, 1 Order by Measurement Number

Plotted points

4.3 Displaying the Deviation Diagram
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• Plotting By Measurement Number

2. Click a cell in the row corresponding to the measurement number whose data you

wish to plot.  The data from the R, G, B, W, User1, and User2 column groups of the

selected measurement number is selected to be plotted in the deviation diagram.

3. Right click the selected cell.  A shortcut menu appears.

4. Select Plot.  The data is plotted in the order in which it was measured.  Values are

displayed in the Reference Value, Measurement Value, and Deviation rows of the

deviation diagram.
The plotted points of any previous data are erased, and the data for the selected
measurement number is plotted.  The Reference Values, Measurement Values, and
Deviation rows are updated.  If the value in the Measurement Values row lies within the
display range on the deviation diagram, PASS is displayed in the Determination row, and if it
falls outside the range, FAIL is displayed.

• Plotting a Selection

2. Drag the mouse to select a range of rows to be plotted.  Data in the R, G, B, W,

User1, and User2 column groups for the measurement numbers in the selected

range are selected for plotting.

3. Right click the selection.  A shortcut menu appears.

4. Select Plot.  The data is plotted in the order in which it was measured.  Values are

displayed in the Reference Value, Measurement Value, and Deviation rows of the

deviation diagram.
The plotted points of any previous data are erased, and the selected data is plotted.  The
Reference Values, Measurement Values, and Deviation rows are updated.  If the value in the
Measurement Values row lies within the display range on the deviation diagram, PASS is
displayed in the Determination row, and if it falls outside the range, FAIL is displayed.

• Plotting All Data at Once

2. Right click any cell.  A shortcut menu appears.

3. Choose Select All.  All the data from the R, G, B, W, User1, and User2 column

groups in the measurement data table are selected for plotting.

4. Perform steps 3 and 4 in “Plotting a Selection” above.

4.3 Displaying the Deviation Diagram
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Plotting in Locus Mode (Displaying Reference and Measurement Values, and the
Deviation)

Regardless of the plotting mode, statistical values may be displayed

simultaneously.  For information on displaying statistical values, see page 4-23.

1. Click the Locus Mode button  in the deviation diagram.  The diagram enters

Locus mode (in which locus lines are drawn between plotted points).

Plot Measurement Data as It Is Being Read In

2. Follow the steps in section 3.1 to start measurement.  The data from the R, G, B,

W, User1, and User2 column groups is plotted in the deviation diagram.  Values

are displayed in the Reference Value, Measurement Value, and Deviation rows of

the deviation diagram.
Locus lines are drawn between the current and previous data, and the data in the Reference
Value, Measurement Value, and Deviation rows is updated.  If the value in the Measurement
Values row lies within the display range on the deviation diagram, PASS is displayed in the
Determination row, and if it falls outside the range, FAIL is displayed.

Use the Current Data (Stop Reading In Data), or Open and Plot a Measurement

Data File

• Plotting Data One at a Time

2. Click the mouse on a cell in the R, G, B, W, User1, or User2 column group of the

measurement data table.  Data from each column within the group you click is

plotted in the deviation diagram.  Values are displayed in the reference value,

measurement value, and deviation rows of the deviation diagram.
Locus lines are drawn between the current and previous data, and the data in the Reference
Value, Measurement Value, and Deviation rows is updated.  If the value in the Measurement
Values row lies within the display range on the deviation diagram, PASS is displayed in the
Determination row, and if it falls outside the range, FAIL is displayed.

Plotting the Data from the R Column Group in 3, 2, 1 Order by Measurement Number

Plotted points

Locus lines

4.3 Displaying the Deviation Diagram
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• Plotting By Measurement Number

2. Click a cell in the row corresponding to the measurement number whose data you

wish to plot.  The data from the R, G, B, W, User1, and User2 column groups of the

selected measurement number is selected to be plotted in the deviation diagram.

3. Right click the selection.  A shortcut menu appears.

4. Select Plot.  The data is plotted in the order in which it was measured.  Values are

displayed in the Reference Value, Measurement Value, and Deviation rows of the

deviation diagram.
The plotted points and locus lines of any previous data are erased, and points and locus lines
for the data of the selected measurement numbers are plotted and drawn.  The Reference
Values, Measurement Values, and Deviation rows are updated.  If the value in the
Measurement Values row lies within the display range on the deviation diagram, PASS is
displayed in the Determination row, and if it falls outside the range, FAIL is displayed.

• Plotting a Selection

2. Drag the mouse to select a range of rows to be plotted.  Data in the R, G, B, W,

User1, and User2 column groups for the measurement numbers in the selected

range are selected for plotting.

3. Right click the selection.  A shortcut menu appears.

4. Select Plot.  The data is plotted in the order in which it was measured.  Values are

displayed in the Reference Value, Measurement Value, and Deviation rows of the

deviation diagram.
The plotted points and locus lines of any previous data are erased, and points and locus lines
for the data of the selected range are plotted and drawn.  The Reference Values,
Measurement Values, and Deviation rows are updated.  If the value in the Measurement
Values row lies within the display range on the deviation diagram, PASS is displayed in the
Determination row, and if it falls outside the range, FAIL is displayed.

• Plotting All Data at Once

2. Right click any cell.  A shortcut menu appears.

3. Choose Select All.  All the data from the R, G, B, W, User1, and User2 column

groups in the measurement data table are selected for plotting.

4. Perform steps 3 and 4 in “Plotting a Selection” above.

4.3 Displaying the Deviation Diagram
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Deleting Plotted Points and Locus Lines (Deleting Measurement Values, Deviation,
and Determination)

Click the Clear button  in the deviation diagram.  All plotted points and locus lines in

the deviation diagram are deleted.  The Measurement Values, Deviation, and

Determination rows become blank.  Statistics are not erased.

Deleting Plotted Points and Locus Lines 
(Deleting Measurement Values, Deviation, and Determination)

Displaying the Statistical Values
Displaying Statistics as Measurement Data Is Being Read In

1. Follow the steps in section 3.1 to start measurement.  Statistical values are

calculated from the data in the R, G, B, W, User1, and User2 column groups, and

then displayed.  Since statistical values are calculated every time measurements

are taken, the amount of sampling data increases.
If the values in the Measurement Values row fall outside of the deviation diagram display
range, FAIL is displayed in the Determination field and statistical values are not displayed.

Statistical value rows (plotting in the deviation diagram and 
displaying of the statistical values occurs simultaneously)

4.3 Displaying the Deviation Diagram
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Stop Reading In Data, or Open a Measurement Data File and Display Statistical

Values

• Opening a Measurement Data File

Follow the steps in section 3.4 to open a measurement data file.  Statistical values are

calculated from the data in the R, G, B, W, User1, and User2 column groups in the

measurement data table, and then displayed.

• Calculating and Displaying Statistical Values for the Selected Range

1. Drag the mouse to select a range of rows to be plotted.  The R, G, B, W, User1,

and User2 column groups of the measurement numbers in the selected range are

selected for calculation.

2. Right click the selection.  A shortcut menu appears.

3. Select Plot.  The statistical values in the Max Value, Min Value, Average Value,

Std. Deviation, and Max-Min rows of the deviation diagram are displayed.
If the values in the Measurement Values row fall outside of the deviation diagram display
range, FAIL is displayed in the Determination field and statistical values are not displayed.

 • Calculating and Displaying Statistical Values for All Data

1. Right click any cell.  A shortcut menu appears.

2. Choose Select All.  All the data from the R, G, B, W, User1, and User2 column

groups in the measurement data table are selected for calculation.

3. Perform steps 2 and 3 in “Calculating and Displaying Statistical Values for the

Selected Range” above.

4.3 Displaying the Deviation Diagram
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Further Details
If you selected Deviation diagram as one of the default windows (see section 2.3), when

you read in data from the MDT 3298 or open a saved measurement data file, a deviation

diagram of the loaded data is displayed on the screen.  If the deviation diagram is not

displayed, you can display it using the View menu.

Deviation Diagram and Statistical Values

• Measurement Number

The measurement number of the last measurement data selected is displayed.  The

measurement data for the current measurement number is displayed in the deviation

diagram and the Measurement Value row in each R, G, B, W, User1, and User2

column.

• Deviation Diagram

• The reference coordinates specified in section 2.5 are set as the origin (zero) of the

deviation diagram, and the display range specified in section 2.5 becomes the

display range for the deviation diagram.

• The colors in the deviation diagram reflect the colors corresponding to the

reference coordinates specified in section 2.5.

• The measurement data containing the chromaticity of the display range (x, y or

u’v’) is plotted in the deviation diagram.

• Name

The name of the chromaticity standard specified in section 2.5 is displayed.

• Reference Values

The reference coordinates for each of the R, G, B, W, User1, and User2 column

groups are displayed.

• Measurement Values

The last measurement data selected is displayed.

• Deviation

The value, measurement value - reference value is calculated and displayed.

• Statistical Values

The following statistical values are calculated using the currently selected

measurement data (sampling data).  In the following equations, n is the number of

sampling data, and Xi is the value of each sampling data.

• Maximum Value

The largest values from the sampling data are displayed.  Maximum Value=[Xi]max

• Minimum Value

The smallest values from the sampling data are displayed.  Minimum Value=[Xi]min

• Average Value

The average value of the sampling data is displayed.  Average Value=           Xi
1

n i=1

n

• Standard Deviation

The standard deviation of the sampling data is displayed.

Standard Deviation=                (Xi–Average Value)21

n-1 i=1

n

• Max-Min

The value calculated as the Maximum Value - Minimum Value is displayed.

• Determination

If the value in the Measurement Values row lies within the display range on the

deviation diagram, PASS is displayed in the Determination row, and if it falls outside

the range, FAIL is displayed.

4.3 Displaying the Deviation Diagram



4-26 IM 329831-01E

Deviation Diagram
During measurement, or for the last selected data for viewing from the 
R, G, B, W, User1, and User2 column groups, the background color is yellow.

The Deviation Diagram’s Plotting Modes

There are three modes for plotting the data from the R, G, B, W, User1, and User2

column groups in the deviation diagram.

• Refresh Mode

• Plot only a single selected data point (after, not during measurement) in the

deviation diagram.

• If you select all data for plotting while in this mode, only the last data in the

measurement data table is plotted.

• Scatter Mode

• Plot multiple selected data points (after, not during measurement) in the deviation

diagram.

• When plotting by measurement number or by dragging a selection, the R, G, B, W,

User1, and User2 column groups of the measurement numbers in the selected

range will be plotted. The values from the final measurement numbers of the

specified range are displayed in the Reference Value, Measurement Value, and

Deviation rows of the deviation diagram.

• If there is no data in a particular column group for the specified range, the

measurement data from the previous measurement number is displayed in the

Measurement Values and Deviation rows of the deviation diagram.  For example, if

there is no data in the User2 column group, the data in the User2 column group of

the previous measurement number is displayed instead.

• If you select all data for plotting, all data in the measurement data table is plotted in

the order in which it was measured.

• Locus Mode

The procedure for plotting, and displaying data in the Reference Value, Measurement

Value, and Deviation rows of the deviation diagram is the same as in Scatter mode.

The only difference is that locus lines are drawn between the current data and the

previous data.

Deleting Plotted Points and Locus Lines

All plotted points and locus lines in the deviation diagram are deleted at once.  Data in

the Measurement Values, Deviation, and Determination rows are also deleted.

Note
During measurement, all menu commands (other than Measurement stop) as well as the

functions that allow you to change the plotting mode, display statistical values, and delete plotted

points and locus lines in the deviation diagram are disabled.

4.3 Displaying the Deviation Diagram
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4.4 Displaying a Trend Graph

Procedure
Read in measurement data from the MDT 3298, or open a previously saved

measurement data file.  With at least the measurement data table and trend graph

displayed, you can perform the following procedures.

• Display the trend graph: see below.  If the trend graph is not displayed, perform this

procedure to display it.

• Plot the trends: see page 4-28.

• Select the horizontal scale: see page 4-29.

• Select the vertical scale: see page 4-29.

Displaying a Trend Graph
Note

Perform this procedure if the trend graph is not displayed.  Note that if you perform this step

when the graph is already open, it will close.

Choose View > Trend Graph, or click the Trend Graph button  on the toolbar.  The

trend graph is displayed.

Trend Graph
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Plotting Trends
Plot Measurement Data as It Is Being Read In

Follow the steps in section 3.1 to start measurement.  The data from the Luminance,

Flicker, R, G, B, W, User1, and User2 column groups is plotted.

Use the Current Data (Stop Reading In Data), or Open and Plot Data from a

Measurement Data File

• Plotting By Measurement Number

1. Click a cell in the row corresponding to the measurement number whose data you

wish to plot.  The data from the R, G, B, W, User1, and User2 column groups of the

selected measurement numbers are selected for plotting.

2. Right click the selection.  A shortcut menu appears.

3. Select Plot.  The data is plotted in the order in which it was measured.  The trends

from the previous data are erased.

Plotting the Data from Measurement Number 3
The trend begins from measurement number 3

Plotted points

Magnification

• Plotting a Selection

1. Drag the mouse to select a range of rows to be plotted.  All data from the

Luminance, Flicker, R, G, B, W, User1, and User2 column groups of the selected

measurement numbers are selected for plotting.

2. Right click the selected cell.  A shortcut menu appears.

3. Select Plot.  The data is plotted in the order in which it was measured.  The trends

from the previous data are erased.

• Plotting All Data at Once

1. Right click any cell.  A shortcut menu appears.

2. Choose Select All.  All the data from the Luminance, Flicker, R, G, B, W, User1,

and User2 column groups in the measurement data table are selected for plotting.

3. Perform steps 2 and 3 in “Plotting a Selection” above.

4.4 Displaying a Trend Graph
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Selecting the Horizontal Scale
1. Click the Setting button  at the bottom of the trend graph.  The Scale Setting

dialog box is displayed.

2. Select the horizontal scale from the Scale list.

3. Click OK.

Displaying the Trend from Measurement Number 34

Scroll the window using the scroll bar.

 • For a Horizontal Scale of 4
    The trends from measurement numbers 4–11 
   are displayed.

• For a Horizontal Scale of 1
   The trends from measurement numbers 4–34 
   are displayed.

Selecting the Vertical Scale
Selecting the Scale of Luminance and Flicker

1. Click the button  in the Luminance, Flicker, or Reference Color Luminance rows

of the trend graph.  The scale settings dialog box is displayed.

2. Select the scale for the Max Luminance, Max Flicker, or Max Liminance

(Chroma) from the list.

3. Click OK.

4.4 Displaying a Trend Graph
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Further Details
If you selected Trend graph as one of the default windows (see section 2.3), when you

read in data from the MDT 3298 or open a saved measurement data file, a Trend graph

of the loaded data is displayed on the screen.  If the Trend graph is not displayed, you

can display it using the View menu.

Trend Graph

The items below are displayed in the order specified using the procedure in section 2.3.

• Measurement Number

The measurement number is the horizontal axis of the trend graph.  The last

measurement number, 32000, is the maximum value along the trend graph’s

horizontal axis.

• L

The trend in luminance (see section 4.1) from the measurement data table is plotted.

• F

The trend in flicker is plotted.

• x, y, and L, or u’, v’, and L

• x, y, and L or u’, v’, and L

The trend in chromaticity as expressed by the xyL or u’v’L color systems from the

R, G, B, W, User1, and User2 column groups is plotted.  The locus lines of the

trend reflect the colors corresponding to the reference coordinates specified in

section 2.5.

• limit

The display range limit for the trend in chromaticity xy or u’v’ is the same as the

display range specified in section 2.5.

Plotting Trends

• You can plot the selected data (after, not during measurement) from the Luminance,

Flicker, R, G, B, W, User1, and User2 column groups in a trend graph.

• If you select all data for plotting, all data in the measurement data table is plotted in

the order in which it was measured.

• When plotting trends while measuring, if measurement data exceeding the specified

scale of the horizontal axis and the display range is acquired, the trend locus lines

appear horizontally in the upper and lower edges of each trend graph.  After stopping

measurement, you can specify a scale greater than the largest measurement data, to

make the lines be displayed correctly.

Horizontal Scale

• The default value for the horizontal scale is 1.

• You can select a scale from 1–5.

• For a scale of 1, the displayed number of points along the horizontal axis goes up to

the 29th measurement number. If the scale is 2, 15 points are displayed, if the scale is

3, 10 points, for 4, 8 points, and 5, 6 points.

The Vertical Scale of Luminance and Flicker

• The default value for the luminance scale is 400 cd/m2, and 5% for the flicker scale.

• Select a luminance scale of 400, 4000, or 40000.  The units of luminance are cd/m2.

• Select a flicker scale of 5, 10, 15, or 20.  Flicker is expressed as a percentage.

Note
During measurement, the menu and trend graph scale selection commands (but not

measurement stop) are disabled.

4.4 Displaying a Trend Graph
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4.5 Editing the Surface Distribution Measurement
Data Table

Procedure
Read in measurement data from the MDT 3298, or open a previously saved

measurement data file.  With at least the surface distribution measurement data table

displayed, you can perform the following procedures to edit the data.  If you did not

select surface distribution as a default window using the procedure in section 2.3, refer to

section 4.1.

• Copy the data in the measurement data table to the clipboard: see below.

• Delete all data: see page 4-32.

• Delete the last data: see page 4-33.

• Display details: see page 4-34.

• Plot data: see sections 4.6 and 4.7.

Copying Data from the Measurement Data Table to the Clipboard
1. Select the measurement number on the measurement data table of the data you

wish to copy using the following buttons.

Click  to display the measurement data of the next measurement number.

Click  to display the measurement data of the previous measurement number.

Click  to display the measurement data of the measurement number 5 after the

current number.

Click  to display the measurement data of the measurement number 5 before

the current number.

Click  to display the last measurement data in the measurement data table.

Click  to display the first (measurement number 1) measurement data in the

measurement data table.

Copying a Portion of the Data

2. Drag the mouse to select the range of cells to be copied.

3. Choose Edit > Copy.  The range selected in step 2 is copied to the clipboard.
* You can also right click on the selected area to display the shortcut menu.  Or, you can

choose Copy from the menu.

4. Paste the contents of the clipboard onto a new file in a text editor.

Pasting the Contents of the Clipboard into Notepad
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Copying All Data

2. Choose Edit > Select All.  All measurement data for the selected measurement

number is selected for copying.
* You can also right click on the selected area to display the shortcut menu.  Choose Select

All.

All measurement data for the selected measurement number is selected.

3. Perform steps 3 and 4 in “Copying a Portion of the Data” above.

Deleting All Data
Note

Deleted measurement data cannot be restored.  It is recommended that you save measurement

data to a file (see section 3.3) before deleting it.

Choose Edit > Delete All.  All measurement data for the displayed measurement

numbers is deleted.  Before the deletion is carried out, a dialog box appears prompting

you to confirm deletion.
* You can also right click on the selected area to display the shortcut menu.  Choose Delete All

from the menu.

Confirmation Dialog Box

4.5 Editing the Surface Distribution Measurement Data Table
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Deleting the Last data
Note

Deleted measurement data cannot be restored.  It is recommended that you save measurement

data to a file (see section 3.3) before deleting it.

Choose Edit > Delete Last.  All data from the last measurement number is deleted.

Before the deletion is carried out, a dialog box appears prompting you to confirm

deletion.

Confirmation Dialog Box

Deletion of the Last data
The Last data before Executing Delete Last Data

The Last data after Executing Delete Last Data

4.5 Editing the Surface Distribution Measurement Data Table
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Displaying and Copying Details
Displaying Details

1. Select a cell in the row corresponding to the measurement number on the

measurement data table of the data you wish to copy.

For details about making selections, see step 1 on page 4-31.

2. Right click the selected cell.  A shortcut menu appears.

3. Select Details.  The details table appears.

If you select Details while the details table is open, it will close.

Details Table

4. Select a reference color from the Reference list in the surface distribution diagram.
The Delta Tc and Delta duv values (the difference from the reference color) in the Details
table change.

Copying a Portion of the Details

5. Drag the mouse to select the range of cells to be copied.

6. Using the mouse, right click in the details table.  A shortcut menu appears.

4.5 Editing the Surface Distribution Measurement Data Table
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7. Select Copy.  The selected range is copied to the clipboard.

8. Paste the contents of the clipboard onto a new file in a text editor.

Pasting the Contents of the Clipboard into Notepad

Copying All Details

5. Using the mouse, right click in the details table.  A shortcut menu appears.

6. Choose Select All.  All data in the details table is selected.

The Details Table with All Data Selected

7. Perform steps 6–8 in “Copying a Portion of the Details” above.

Plotting Data
You can click measurement data in the measurement data table for plotting the

chromaticity diagram, and select the data for specific measurement numbers for plotting

in the surface distribution diagram.  For those operating procedures, see sections 4.6

and 4.7.

4.5 Editing the Surface Distribution Measurement Data Table
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Further Details
Read in measurement data from the MDT 3298, or open a previously saved

measurement data file.  With at least the surface distribution measurement data table

displayed, you can perform the following procedures to edit the data.  If you did not

select surface distribution as a default window using the procedure in section 2.3, refer to

section 4.1.

Surface Distribution Measurement Data Table

Data measured by the MDT 3298 is read into the measurement data table.

• Measurement Number

Among all the displays being measured, indicates the measurement number from 1 to

32000 of the current display shown in the surface distribution.  The number cannot be

changed.

• Number

Within a single display being measured, indicates the measurement order in which

each location was measured.  It matches the surface distribution measurement order

specified in section 2.7.

• Location

Indicates the measurement locations as specified for the display currently being

measured.  It is displayed using a letter from A to M, and matches the number of

measurement points for the surface distribution specified in section 2.7.

• x, y, and L, or u’, v’, and L

This is the chromaticity and luminance per the xyL or u’v’L color systems for the

measurement location.  x, y, u’, and v’ have no units, but the units of L are cd/m_.

Measurement Data Table

Shows which measurement number
from 1 to 32000 is currently displayed 
in the surface distribution.
(In this example, number 2 of 7 surface 
distribution measurement data is displayed. )

Surface Distribution Details Table

The following items are displayed for the measurement locations (A–M) of each

measurement number.

• Measurement Time

The time the data was measured on the MDT 3298.  This time reflects the time on the

PC’s internal clock during measurement.

• X, Y, and Z

The tristimulus values.  These are displayed using the symbols X, Y, and Z, indicating

the three primary colors as perceived by the human eye.  They are assigned values

that are measured on the MDT 3298.

• x, y or u’, v’

Same as those in “Surface Distribution Measurement Data Table” above.

• Tc

The color temperature as calculated from the measurement data.  The color

temperature is the absolute temperature of a blackbody radiator having a chromaticity

equal to that of the light source.  The units of Tc are K (Kelvin).

4.5 Editing the Surface Distribution Measurement Data Table



4-37IM 329831-01E

E
d

itin
g

 an
d

 D
isp

layin
g

 M
easu

rem
en

t D
ata

4

• duv

The difference between the position of the color temperature calculated from the

measurement data, and the same color temperature position on the blackbody locus

(locus of the color temperature of the blackbody).

• Delta Tc

The difference between Tc (color temperature of the measurement data) and the color

temperature of the reference color.  You can select the reference color in the surface

distribution.

 • Delta duv

The difference between the duv of the measurement data and the duv of the

reference color.  You can select the reference color in the surface distribution.

Details Table

Measurement 
number

* When the color temperature can not be calculated from the measurement data or the
chromaticity coordinates of the reference color, ERROR appears in the Tc, duv, Delta Tc, and
Delta duv rows.

Copying to the Clipboard

You can copy the data from the measurement data table and the details table to the PC’s

clipboard.  You can paste the data from the clipboard to a text editor and create a new

document.

• Copying a Portion of the Data

Copy only the selection made by dragging the cursor with the mouse.

• Copying All Data

You can copy all the data from the measurement data table and the details table.

Deleting All Data

• All the data from the measurement data table and the details table is deleted.

• If all data is deleted, it can not be restored.  It is recommended that you save

measurement data to a file (see section 3.3) before deleting it.

Deleting the Last data

• The last data from the measurement data table and the details table are deleted.

• Deleted measurement data cannot be restored.  It is recommended that you save

measurement data to a file (see section 3.3) before deleting it.

• The data measured by the MDT 3298 is deleted one measurement number at a time.

Plotting Data

You can click measurement data in the measurement data table for plotting on the

chromaticity diagram, and select the data of specific measurement numbers for plotting

in the surface distribution diagram.  See sections 4.6 and 4.7.

Note
During measurement, all menu commands (other than measurement stop), as well as the select
measurement data, copy, and delete functions are disabled.

4.5 Editing the Surface Distribution Measurement Data Table
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4.6 Displaying the Surface Distribution
Chromaticity Diagram

Procedure
Read in measurement data from the MDT 3298, or open a previously saved

measurement data file.  With at least the surface distribution measurement data table

and chromaticity diagram displayed, you can perform the following procedures.  If you

did not select surface distribution as a default window using the procedure in section 2.3,

refer to section 4.2.

• Display, and zoom in and out on the chromaticity diagram: see below.  If the

chromaticity diagram is not displayed, perform the procedure below to display it.

• Plot in Refresh mode: see below.

• Select the bar graph scale: see page 4-40.

• Delete plotted points: see page 4-40.

Displaying and Zooming In and Out on the Chromaticity Diagram
Note

Perform step one if the chromaticity diagram is not displayed.  Note that if you perform this step

when the diagram is already open, it will close.

1. Choose View > Chromaticity Diagram, or click the Chromaticity diagram button

 on the toolbar.  The chromaticity diagram is displayed.

2. Click the Form Size button  in the diagram to zoom in and out.
For an example of zooming in and out on a chromaticity diagram, see section 4.2.
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Plotting in Refresh Mode
(In the surface distribution chromaticity diagram, you can only plot measurement

data in Refresh mode. )

Plot Measurement Data as It Is Being Read In

1. Follow the steps in section 3.1 to start measurement.  Every time measurements

are taken, the data is plotted in the chromaticity diagram.  The plotted points from

the previous data are erased.

Use the Current Data (Stop Reading In Data), or Open and Plot Data from a

Measurement Data File

1. Select the measurement numbers on the measurement data table of the data you

wish to plot using one of the following procedures.

Click  to display the measurement data of the measurement number 1 after the

current number.

Click  to display the measurement data of the measurement number 1 before

the current number.

Click  to display the measurement data of the measurement number 5 after the

current number.

Click  to display the measurement data of the measurement number 5 before

the current number.

Click  to display the last measurement data in the measurement data table.

Click  to display the first (measurement number 1) measurement data in the

measurement data table.

2. Click the mouse on the data in the measurement data table.  The measurement

data for the location corresponding to the cell you click is plotted in the chromaticity

diagram.  The plotted points from the previous data are erased.

Plotting Measurement Data

Plotted points

4.6 Displaying the Surface Distribution Chromaticity Diagram
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Selecting a Bar Graph Scale
Select a bar graph scale from the Max Luminance list in the chromaticity diagram.

When the scale is 400 cd/m2 When the scale is 4000 cd/m2

Deleting Plotted Points
Click the Clear button  in the chromaticity diagram.  All plotted points and locus lines

in the chromaticity diagram are deleted.

Deleting Plotted Points

4.6 Displaying the Surface Distribution Chromaticity Diagram
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Further Details
If you selected Chromaticity diagram as one of the default windows (see section 2.3),

when you read in data from the MDT 3298 or open a saved measurement data file, a

chromaticity diagram of the loaded data is displayed on the screen.

• If the chromaticity diagram is not displayed, you can display it using the View menu.

• To select surface distribution as a default window, refer to section 4.2.

Chromaticity Diagram

See Further Details in section 4.2, “Chromaticity Diagram.”

Zooming In and Out on the Chromaticity Diagram

• Reduced form (size) is the default zoom level.

• Zoom the diagram to more easily view the data plotted in it.

Plotting Modes

Refresh mode is the only mode available for plotting data in the chromaticity diagram.

Refresh Mode

• Erase the plotted points from the previous data, and plot only the selected data

(after, not during measurement) in the chromaticity diagram.

• If you select all data for plotting, only the last data of the selected measurement

numbers in the measurement data table is plotted.

Selecting the Bar Graph Scale

See Further Details in section 4.2, “Selecting the Bar Graph Scale.”

Deleting Plotted Points

All plotted points in the chromaticity diagram are deleted at once.

Note
During measurement, all menu commands (other than Measurement stop), as well as the

functions that allow you to zoom the chromaticity diagram in/out, select the bar graph scale, and

delete plotted points are disabled.

4.6 Displaying the Surface Distribution Chromaticity Diagram
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4.7 Displaying the Surface Distribution Diagram

Procedure
Read in measurement data from the MDT 3298, or open a previously saved

measurement data file.  With at least the surface distribution measurement data table

and the surface distribution diagram displayed, you can perform the following

procedures.

• Display the surface distribution diagram: see below.  If the surface distribution

diagram is not displayed, perform the procedure below to display it.

• Plot data: see page 4-43.

Displaying the Surface Distribution Diagram
Note

Perform this procedure if the surface distribution diagram is not displayed.  Note that if you

perform this step when the graph is already open, it will close.

Choose View > Surface Distribution Diagram, or click the Surface Distribution Diagram

button  on the toolbar.  The surface distribution diagram appears.

Surface Distribution Diagram
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Plotting Data
1. Select the reference color from the Reference list in the surface distribution

diagram to be the origin (zero) of the deviation diagram in each measurement

location (A–M) of the surface distribution .

Plot Measurement Data as It Is Being Read In

2. Follow the steps in section 3.1 to start measurement.  Every time the data for each

measurement location of the surface distribution diagram is measured, the data is

plotted in the corresponding deviation diagram on the surface distribution diagram.
• The data in measurement locations A–M represent one measurement number. After

performing measurement, if you continue on with additional measurement, the
measurement number increases by 1, and surface distribution measurement updates.

• When you plot the data from each measurement location in the deviation diagram, the
values from each measurement number are simultaneously displayed in the Average
Chromaticity, Average Luminance, Maximum Luminance, and Minimum Luminance rows
on the left of the surface distribution diagram.  Data for measurement location M is
displayed in the Deviation row.  When you continue measurement and the measurement
number increases by 1, the plotted points and the values in each row (excluding the
reference color) are erased.

• Set the display range for the deviation diagram.  For the procedure, see the next page.

Use the Current Data (Stop Reading In Data), or Open and Plot Data from a

Measurement Data File

(The measurement data is plotted on the surface distribution deviation diagram

one at a time.  You cannot select a range and plot at them all at once.

2. Select the measurement number on the measurement data table of the data you

wish to plot using one of the procedures below.  Data in each measurement

location for the selected measurement numbers is plotted in the deviation diagram.

At the same time, the values for each measurement number are displayed in the

Average Chromaticity, Average Luminance, Maximum Luminance, and Minimum

Luminance rows on the left of the surface distribution diagram.  The data from

measurement location A is displayed in the Deviation row.

Click  to display the measurement data of the measurement number 1 after the

current number.

Click  to display the measurement data of the measurement number 1 before

the current number.

Click  to display the measurement data of the measurement number 5 after the

current number.

Click  to display the measurement data of the measurement number 5 before

the current number.

Click  to display the last measurement data in the measurement data table.

Click  to display the first (measurement number 1) measurement data in the

measurement data table.

3. Click the measurement location of the data you wish to plot from the selected

measurement numbers.  The data from measurement location you clicked is

displayed in the Deviation row.

4.7 Displaying the Surface Distribution Diagram
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Plotting the Data from Measurement Number 2

Measurement Data Table

Surface 
Distribution 
Diagram

The origin of the deviation diagram 
(set to the coordinates of the reference 
color on the chromaticity diagram).

Select the reference color
The coordinates of the selected reference 
color on the chromaticity diagram

The deviation of the data from the 
reference color for the selected 
measurement location is displayed.

The average chromaticity, average 
luminance, maximum luminance, and 
minimum luminance of the selected 
measurement number is displayed.

Setting the Display Range

2. Click Set in the surface distribution diagram.  The Display Range Settings dialog

box is displayed.

3. Set the display range for the deviation diagram.

4. Click OK.

4.7 Displaying the Surface Distribution Diagram
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Further Details
If you selected Surface distribution as one of the default windows (see section 2.3), when

you read in data from the MDT 3298 or open a saved measurement data file, a surface

distribution diagram of the loaded data is displayed on the screen.  If the surface

distribution diagram is not displayed, you can display it using the View menu.

Surface Distribution Diagram

You can display the distribution of luminance and chromaticity over a wide area.

• Reference, x and y, or u’ and v’ (x and y or u’ and v’ displayed according to the

color system selected in section 2.3).

• Select the reference color from the choices below. The selected reference color

becomes the origin (zero) of the deviation diagrams in the measurement locations

(A–M) on the surface distribution diagram.

Reference R, Reference G, Reference B, Reference W, User1, User2, A–M,

Average Value.

• For Reference R–User 2, the origin is set to the reference coordinates of the

chromaticity reference selected using the procedure in section 2.5.

• If you select A–M, the origin is set to the chromaticity measured at each

measurement location.

• If you select Average Value, the origin is set to the average value of the

chromaticity measured at each measurement location.

• The chromaticity of the selected reference color is displayed in the x and y or u’

and v’ rows.

• The same reference color is applied to all measurement locations.

• Deviation, x and y, or u’ and v’

The difference between each measurement data and the reference color is displayed

in the x and y or u’ and v’ rows.

• Average Chromaticity, x and y, or u’ and v’

The average value of the chromaticity for each measurement number is displayed in

the x and y or u’ and v’ rows.

• Average Luminance

The average luminance of each measurement number is displayed.

• Maximum Luminance

The maximum luminance of each measurement number and their locations are

displayed.

• Minimum Luminance

The minimum luminance of each measurement number and their locations are

displayed.

• Display Range

You can specify in which range to display the deviation diagrams at each

measurement location (A–M) of the surface distribution diagram.  Set the range within

that of the chromaticity diagram.

Moving the Measurement Location

You can drag the deviation diagram within in the surface distribution diagram to move

the measurement locations.

Note
During measurement, all menu commands (other than measurement stop), as well as the

functions that allow you to select the reference color and display range are disabled.

4.7 Displaying the Surface Distribution Diagram
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4.8 Viewing and Changing Settings

Procedure
When you create a new file, read in data from the MDT 3298, or open a saved

measurement data file, the data is displayed on the screen in various formats.  You can

view and modify the settings for the different display formats.

Displaying the Settings

1. Choose Settings > Edit Settings.  The Settings dialog box is displayed.

Changing the Settings

2. In the Settings dialog box, select the tab of the item whose settings you wish to

change. For details on making changes, see sections 2.2–2.8.

Settings Dialog Box

Saving the Changed Settings to a File

This procedure is the same as the one in section 2.9, “Saving Settings  to a File.”

Sending the Changed Settings to the MDT 3298

This procedure is the same as the one in section 2.9, “Sending Settings to the MDT

3298.”
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Further Details
When you create a new file, read in data from the MDT 3298, or open a saved

measurement data file, the data is displayed on the screen in various formats.  You can

view and modify the settings for the different display formats.  The following items can be

changed.

Items That Can Be Changed

• Header

Information in the Header, Created by, Created on, and Comments fields can be

changed.

• View

For surface distributions, you can change whether chromaticity diagrams are

displayed.  For normal views (those other than surface distributions), you can change

whether a trend graph, chromaticity diagram, or deviation diagram are displayed.

• Chroma Reference

You can change the set of chromaticity reference values, the set’s name, the

chromaticity correction coefficient, the reference coordinates of the reference color,

and the display range of the deviation diagram.

• Measurement Mode

You can change the measurement mode and the interval.

• Surface Distribution

You can change the measurement order.

• Device Settings

You can change the settings for the backlight, averaging, and the measuring range.

Saving the Changed Settings to a File

This procedure is the same as the one in the Further Details subsection “Saving File” in

section 2.9.

Sending the Changed Settings to the MDT 3298

This procedure is the same as the one in the Further Details subsection, “Sending

Settings to the MDT 3298” in section 2.9.

Note
During measurement, all menu commands (other than measurement stop), as well as the view/

change Settings functions are disabled.

4.8 Viewing and Changing Settings
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4.9 Choosing Cascade or Tile View

Procedure
When you create a new file, read in data from the MDT 3298, or open a saved

measurement data file, the data is displayed on the screen in various formats.  You can

choose to display the graphs and diagrams in Cascade or Tile view.

Cascade

Choose Window > Cascade.  The sub windows within the Light Measurement Data

Management Software window are overlaid so that you can see their title bars.

Normal View (Other Than Surface Distribution)

Surface Distribution View

Tile

Choose Window > Tile.  The sub windows within the Light Measurement Data Management

Software window are resized and arranged so that most of their frames are visible.

Normal View (Other Than Surface Distribution)
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Surface Distribution View

Further Details
When you create a new file, read in data from the MDT 3298, or open a saved

measurement data file, the data is displayed on the screen in various formats.  You can

choose to display the graphs and diagrams in Cascade or Tile view.

Cascade View

• The sub windows within the Light Measurement Data Management Software window

are overlaid so that you can see their title bars.

• The graph or diagram displayed during procedure is that which is in the foreground

after Cascade is selected.

• The order in which the windows are cascaded depends on the types of graphs and

diagrams being displayed.

Tile View

• The sub windows within the Light Measurement Data Management Software window

are resized and arranged so that most of their frames are visible.

• The graph or diagram displayed during procedure is that which is in the foreground

after Tile is selected.

• The order in which the windows are tiled depends on the types of graphs and

diagrams being displayed.

4.9 Choosing Cascade or Tile View
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5.1 Entering a Header and Footer

Procedure
1. Choose File > Header & Footer.  The Header & Footer dialog box is displayed.

Entering a Header

2. Select the Header option.

3. Type headers in boxes 1, 2, and 3, or click the File Name , Page Number ,

Print Date , or Print Time  buttons to have the corresponding information

automatically included in the header.

4. Select Left justification, Right justification, or Center for each header from the list to

the right of its box.

The Sample box displays a sample header based on your selections.

Chapter 5 Printing
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Entering a Footer

5. Select the Footer option.

6. Same as steps 3 and 4.

The Sample box displays a sample footer based on your selections.

7. Click OK.

Further Details
You can specify headers and footers to be used when printing the measurement data

table, chromaticity diagram, deviation diagram, trend graph, or surface distribution.

Header/Footer Character Strings

• A maximum of 200 characters can be entered in each box.

• The information in the boxes is printed in order by box number.

• Click , , , or  to display a code in the box.  When printing, the following

information is printed according to the codes you include.

• &f:  directory and file name

• &p:  page number during printing

• &d:  date of printing

• &t:  time of printing (based on the PC’s internal clock)

Header/Footer Justification

You can select Left justification, Right justification, or Center in the lists to the right of

each header/footer box.

5.1 Entering a Header and Footer
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5.2 Printing

Procedure
Create a new file, read in data from the MDT 3298, or open a saved measurement data

file.  Various graphs and diagrams are displayed on the screen.  Perform the following

steps.

1. Select File > Print, or click the Print button  on the toolbar.  The Print dialog box

is displayed.

Selecting the Items to Be Printed

2. Select items to be printed in the Header, Footer group of the Print dialog box.

3. Select the print contents.
Depending on the contents you select, the message, “Print Width Exceeded” may appear.
This message indicates that the width of the items you selected is greater than the width of
the paper you are using.  Follow the procedures below in “Selecting Printer Settings” or
“Selecting a Font” to ensure that the print contents (graphs and diagrams) match the printing
width.

4. Select the desired Print Items.

Normal View (Other Than Surface Distribution)The Print Dialog Box for Surface Distribution

Surface DistributionThe Print Dialog Box for Surface Distribution
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Selecting Printer Settings

5. Click Settings in the Print dialog box.  The Print Settings dialog box is displayed.

6. Select the printer name, paper size, and orientation, and click Properties if

necessary to specify printer properties.

Selecting a Font

7. Click Font in the Print dialog box.  The Font dialog box is displayed.

8. Select a font name, style, size, and underline style if necessary.

Printing

9. Click Print in the Print dialog box.  Printing is executed.

5.2 Printing
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Further Details
When you create a new file, read in data from the MDT 3298, or open a saved

measurement data file, the data is displayed on the screen in various formats.  These

graphs and diagrams can be printed.

Printable Items

The items below can be selected for printing.  Depending on the contents you select, the

message, “Print Width Exceeded” may appear.  This message indicates that the width of

the items you selected is greater than the width of the paper you are using.  Follow the

procedures below in “Selecting Printer Settings” or “Selecting a Font” to ensure that the

print contents (graphs and diagrams) match the printing width.

• Header

The header specified by following the steps in section 5.1.

• Footer

The footer specified by following the steps in section 5.1.

• Measurement Conditions

• The information you entered in the Header, Created by, Created on, and

Comments fields when following the steps in section 2.2.

• The light source selected by following the steps in section 2.4.

• The name of the chromaticity reference specified by following the steps in section

2.5.

• Measurement Data

Measurement Data Table

When in a normal view (one other than that when displaying a surface distribution),

you can print the measurement data table on A4 size paper.

• Select Landscape for the paper orientation.

• Select a font size of 4.

• Chromaticity Diagram

Chromaticity Diagram.  If you zoom an item before printing it (see section 4.2), a

zoomed chromaticity diagram is printed.

• Deviation Diagram

Deviation Diagram.  This can only be printed when in a normal view.

• Trend Graph

Trend Graph.  This can only be printed when in a normal view.

• Surface Distribution

Surface Distribution Diagram.  This can only be printed when in a surface distribution

view.

• Measurement Number

When printing items in a measurement data table, you can select whether or not to

print the measurement numbers.

• Measurement Location

When printing a surface distribution measurement data table, you can select whether

or not to print the measurement locations.

• Determination

When printing a measurement data table in normal view, you can select whether or

not to print the determination.

Printer

Select the destination printer, orientation, and paper size, and click Properties if

necessary to specify printer properties.  Enter settings as called for by the settings dialog

boxes of the PC to which the printer is connected.

5.2 Printing
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Font

Select a font name, style, size, and underline style if necessary.   Enter settings as called

for by the font dialog box of the PC which you are using.

A Printing Example

The following is an example of header/footer and chromaticity diagram output.

• Example of a Header/Footer (See Section 5.1)

• Example of a Printed Chromaticity Diagram

5.2 Printing
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6.1 Using the Help Function

Procedure
Using the Help Contents

1. Choose Help > Contents.  The Light Measurement Data Management Software

help dialog box is displayed.

2. Select links to browse for the desired information.

Using Keyword Search

1. Choose Help > Keyword Search.  The Keyword Search dialog box is displayed.

2. Enter or select a keyword to find specific information.

Chapter 6 Other Functions
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Further Details
During operation, you can search for helpful information about this software’s operating

procedures and display that information on screen.

Using the Help Contents

• You can search for operating procedures and terminology by selecting index items

that match the procedural flow of the item you are searching for.

• By pressing the Search button you can call up a keyword search.

Keyword Search

• You can search for operational procedures or terminology using a keyword.

• Type the keyword into the search box, or select one from the list.

6.1 Using the Help Function
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6.2 Viewing Version Information

Procedure
Choose Help > About.  The About dialog box is displayed.

About Dialog Box

Further Details
The current version number and other information is displayed.
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Specifications

Software
This software can display measurement data from the MDT 3298 in various kinds of

graphs and diagrams, and save and load that data to and from files.

The name of the executable file is COLMNG.EXE.

Function
Setting Measurement and Display Conditions

• Color System

Select xyL or u’v’L.

• Measurement and Display Order

Select the order for luminance, contrast, flicker, and chromaticity.

• Default Windows

Select Measurement data view (always active), Trend graph, Chromaticity diagram,

Deviation diagram, or Surface distribution.

• Light Source

Select Type A, FL3, or CRT.

• Chromaticity Reference

• Reference Coordinates: Enter reference coordinates for the chromaticity diagrams

of each reference color (R(red), G(green), B(blue), W(white), User1, and User2).

• Display Range for the Deviation Diagram: Enter the display range for the graph that

shows the deviation from the reference color’s reference coordinates.

• Chromaticity Correction Coefficient:  Click to calculate the chromaticity correction

coefficient from the chromaticity and luminance reference values and the

chromaticity and luminance of representative measurement data.  The MDT 3298

calculates chromaticity and luminance by applying this chromaticity correction

coefficient to the actual measured tristimulus values.

• Measurement Mode

Select Continuous or Single.  For continuous measurement, you can also select an

interval.

• Surface Distribution Settings

• Number of Measurement Points: Select 4, 5, 9, or 13.  You can change the

measurement location.

• Measurement Order: Enter the order.

• Device Settings

Enter backlight, averaging, and measuring range settings for the MDT 3298.

• Saving and Loading Setup Data

• Save settings to or load settings from the PC’s storage medium.

• Transmit the light source correction coefficient, chromaticity reference, and MDT

3298 settings to and from the MDT 3298.

Saving and Loading Measurement Data

• Read in measurement data while being acquired by the MDT 3298.

• Load data stored in the MDT 3298’s memory.

• Save and load data to and from the PC’s storage medium or the MDT 3298.

Chapter 7 Specifications
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Editing and Displaying Measurement Data

• Measurement Data Table

Copy or delete measurement data to and from the clipboard.

• Chromaticity Diagram

• Zoom in or zoom out.

• Plot measurement data on the chromaticity diagram.

• Plotting modes

Select Refresh mode, Scatter mode, or Locus mode.  Only Refresh mode is

available for surface distribution.

• Bar graph

Display a bar graph of the luminance of the reference color.

• Bar graph scale

Select 400, 4000, or 40000 cd/m2.

• Deviation Diagram

• Display the statistical calculation and determination of luminance.

• Plotting modes

Select Refresh mode, Scatter mode, or Locus mode.  Only Refresh mode is

available for surface distribution.

• Trend Graph

• Display the measurement data for luminance, flicker, and chromaticity in a line

graph broken down by measurement order.

• Luminance scale

Select 400, 4000, or 40000 cd/m2.

• Flicker scale

Select 5, 10, 15, or 20%.

Print

• Print the measurement data table, chromaticity diagram, deviation diagram, trend

graph, or surface distribution diagram.

• You can also specify a header and footer, and select whether to print the

measurement conditions, measurement numbers, measurement locations, and

determinations.

Specifications
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System Requirements
Hardware

• CPU

A personal computer with a Pentium 133 MHz or faster CPU.

• Memory

32 MB or more.

• Hard Disk

A hard disk with 5 MB or more of available space.

• Serial Communications Port

A serial port complying with the EIA-574 (for 9–pin RS-232 connectors) or EIA-232

(RS-232) standard.

• Disk Drive

A CD-ROM drive.  This drive is used to install the software.

• Display

A display compatible with your operating system.  An analog RGB monitor capable of

displaying 65,536 colors or more recommended.

• Mouse or Pointing Device

A mouse or pointing device compatible with your operating system.

• Printer

A printer and printer driver compatible with your operating system.  A printer driver

compatible with your operating system.

OS

Microsoft Windows 98, Windows NT 4.0 Workstation, or Windows 2000 Professional.

Multimedia Display Tester (Model 3298)

A device operating under firmware (ROM) version 1.05 or later.

Specifications
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