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Foreword

Notes

Trademarks

Revisions

This user's manual describes the Symbol Editor’'s handling precautions, functions, operating

procedures, and other important information for use of the software. To ensure correct use, please

read this manual thoroughly during operation. After reading this manual, keep it in a convenient
location for quick reference in the event a question arises during operation. Please keep this

manual in a convenient location in case questions arise during operation. Furthermore, for handling

precautions, functions, and operating procedures for the DL series, or for the handling and
operating procedures of Windows, please see the manuals for those respective products.

» The contents of this manual are subject to change without prior notice as a result of

improvements in performance or functionality. Display contents illustrated in this manual may

differ slightly from what actually appears on your screen.

» Every effort has been made in the preparation of this manual to ensure the accuracy of its
contents. However, should you have any questions or find any errors, please contact your
nearest YOKOGAWA representative as listed on the back cover of this manual.

» Copying or reproduction by any means of all or any part of the contents of this manual without

permission is strictly prohibited.

» This software creates data files compatible with the following DL series.
DL850V, DLM2000 series, DLM4000 series, DL6000/DLM6000 series, SB5000 series, and
DL9500/DL9700 series.

* Microsoft , MS-DOS, Windows, Windows XP, Windows Vista and Windows 7 are trademarks or

registered trademarks of Microsoft Corporation in the United States and/or other countries.
» Adobe and Acrobat are trademarks of Adobe Systems incorporated.
» CANdb and CANdb++ are registered trademarks of Vector Informatik Gmbh in Germany.
» Windows Installer 3.1 is a trademark or registered trademark of Microsoft Corporation in the
United States and/or other countries.

* The company and product names used in this manual are not accompanied by the trademark or

registered trademark symbols (TM and ®).

» Other company and product names are trademarks or registered trademarks of their respective

companies.
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Product Overview

Functions
SB5000

Physical value symbol definition data for
serial bus analysis

+
Logic symbol definition data Symbol Editor

DL9700/DL9500

Save

Co
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= :

= Edit
_ Symbol
e s ﬁ

definition file'
Logic symbol
definition data #.8bl

DLM2000/DLM4000 & = o=

AVAVAV:
JLILFL

n Load reference file

Physical value symbol definition
data for serial bus analysis

+
Logic symbol definition data

(DLM6000 Only) CANdb FIBEX LIN Definition file
«.db
DL6000/DLM6000 G w.xml

1. The following are included in symbol definition files.
« Physical value symbol definition data for serial bus analysis
* Logic symbol definition data

Create and Edit Physical Value Symbol Definition Files for DL850V, DLM2000, DLM4000,

DL6000/DLM6000, and SB5000 Series Serial Bus Analysis
You can create physical value symbol definition files for serial bus analysis. Created files can be
saved for use on the DL850V, DLM2000, DLM4000, DL6000/DLM6000, and SB5000. Saved files
can be loaded and edited.

Import CANdb Files
You can load CANdb files and create physical value symbol definition files for the DL850V, the
SB5000, the DLM2000, the DLM4000, and the DL6000/DLM6000.

Import LIN Definition Files
You can load LIN definition files and create physical value symbol definition files for the DL850V.

Import FIBEX Files
You can load FIBEX files and create FlexRay physical value symbol definition files for the SB5000.

Create and Edit Logic Symbol Files for the SB5000, DLM6000, DL9700, and DL9500 Series
You can create logic symbol definition files that can be used on the SB5000, DLM6000, DL9700,
and DL9500 series. Created files can be saved for use on the SB5000, DLM6000, DL9700, and
DL9500 series. Saved files can be loaded and edited.

Search for Registered Messages
You can search created or loaded data for registered messages.
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System Requirements

Personal Computer
A personal computer (PC) is required that is running Windows XP SP2 or later, or Windows Vista,
or Windows 7, having a Pentium 4, 2 GHz or faster CPU and 512 MB or more (1 GB or more
recommended) of memory.

Display
Resolution: SVGA/XGA (XGA or higher recommended)
Colors: 65536 or more

Mouse
A mouse that is compatible with Windows XP SP2 or later, or Windows Vista, or Windows 7.

DL Series and Firmware Able to Load Symbol Definition Files (*.sbl)

DL9700/DL9500 series: Version 4.00 or later
SB5000 series: All firmware versions
DLM2000 series: All firmware versions
DLM4000 series: All firmware versions
DL6000/DLM6000 series: All firmware versions
DL850V: All firmware versions
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Important Information for Users

Disclaimers

By downloading and installing this software, the customer agrees to all of the following disclaimers.

* Yokogawa bears no liability for any problems occurring as a result of downloading or installing
this software.

* Yokogawa bears no responsibility for any damage caused directly or indirectly as a result of using
this software.

« This software is provided free of charge, however no unlimited warranty against software defects
exists, nor is any claim made that the product is free of all defects whatsoever. Also, Yokogawa is
not always able to repair defects (4bugs”) in, or respond to questions or inquiries about this
software.

* Yokogawa reserves all rights to this software, including but not limited to all property rights,
ownership rights, and intellectual property rights.

» Microsoft corporation’s MSXML is included in this software package. If any problems or trouble
occur during use of this software that are directly or indirectly attributable to MSMXL, even if
Microsoft corporation or Yokogawa were aware of such problems or trouble, or if they could
possibly have known or predicted such problems or trouble, Microsoft corporation or Yokogawa
assume no liability whatsoever to the customer or any third party, nor do they bear any
responsibility for any direct or indirect damages that may be caused by such problems or faults.
Also, regarding use of this software by the customer, if there is any legal action, claim, or demand
related to MSXML from a third party—including, but not limited to, claims of infringement of
intellectual property rights (excluding trademarks and copyrights)—against Microsoft corporation
and/or Yokogawa, the customer shall, at the customer’s expense, exempt Microsoft corporation
and/or Yokogawa, and will compensate Microsoft corporation and/or Yokogawa for all expenses
and damages including lawyer fees, etc.

Usage Precautions

+ |If the PC enters a standby mode (a feature that may have been installed), this software may not
be able to run continuously. Be sure to turn off the PC’s standby mode.

» Microsoft corporation’s MSXML 6.0 SP1 must be installed to use the FIBEX file import function.
The MSXML 6.0 SP1 installer is included in your symbol editor package. Follow the instructions to
install the program.

The OS that must be installed is Microsoft Windows XP Service Pack 2 (SP2).

» Windows Installer 3.1 or later is required to install MSXML 6.0 SP1.

If necessary, you can download it from the Microsoft Download Center.

Note:
Regarding FIBEX(Field Bus Exchange Format)
FIBEX is one kind of common data base (format) used in bus systems such as FlexRay
developed by the ASM consortium when exchanging data and information between nodes
(ECU, etc.). It defines data (messages and symboals), information about the
sending/receiving nodes, and other information in the xml language.
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Installing and Uninstalling the Software

Installing
1. Download Symbol Editor from the Yokogawa Web site. Save the file to an appropriate location
on the PC.
2. The downloaded file is compressed. Decompress the file using a suitable decompression
program (such as WinZip). The -Symbol Editor” folder is created.
Uninstalling

1. Delete the Symbol Editor folder and all of its subdirectories.

7 B9852US-01



I 1.1 Starting and Exiting the Program

* Starting the Program

Double-click Symbol Editor.exe. The program starts, and the window below appears.

72 Symbol Editor,
File Edit Wiew Help

FlexRay GAN LIN LOGIC ?
Reference List Define List
Mo, | Message | d | Signal Mo, ‘ Message | 1d | Signal

Ready

For loading files as reference data.

* Exiting the Program

Click File > Exit.

For editing definition files.

B9852US-01




1.2 Basic Operations in the Main Screen

Changes the data to edit
» FlexRay

+ CAN

+ LOGIC

* LIN

Search: Searches for messages
registered in the list

Displays the
Help Window

72 Symbol Editor,

Open: Loads symbol definition files (*.sbl)

New definition: Creates new
messages

Edit definition: Edits registered
messages

Sort messages

Click a title without No. in the table to
sort in ascending or descending order

Add definition:
Adds messages to
the definition list

Reference: Load CANdb file (*.dbc)
Load LIN definition file (*Idf)
Load FIBEX file (*.xml)
Load symbol definition file (*.sbl)

Fil=  Hdit Wiew | Help
FlexRay | CAN LIN  LOGIC $E= ?
Refgrence List Comfort.dbe Define Lisg ConfortTgtsData.shl
-L| 3| -L = =
| o, | Mesdage | 1d | Signal ~ Ma, | Message ! d | Signal
1 TP_Dpshboard 1541 data 1 Diag_Request 1792 MoMame
792 [MoMame ] Z Diag_Response 1536 MoMame
3 Diag|Response 1536 MoMame 3 DiagResponse_Makor 1537 data
4 Diaghesponse_Motor 1537 data 4 DiagResponse_DoorLeft 1543 data
5 Diaghesponse_DoorLeft 1543 data 5 DiagRequest 1542 data
& Diaghequest 1542 data & TP_Consale 1540 data
7 TP_{onsolz 1540 data M (Gakes
8 NM_fateway 1053  SleepInd 8 NM_DOORright 1052  SleepInd
9 NM_pooRright 1052 Slesplnd 9 NM_DOCRIeft 1051 Slesplnd
10 NM_pOORleft 1051  SleepInd 10 NM_Console 1050 SleepInd
11 MNM_[onsole 1050 Sleeplnd
12 DOgQR_r 497 WH_Pasition
13 Dodr_| 496 Wh_Paosition
14 Congole_2 417 Phase
15 Conpole_2 417 Active
16 Confole_2 417 Light
17 Confole_1 416 Wh_right_up
18 Congole_1 416 WH_right_down
19 Corgole_1 416 WH_left_up
20 Corfsole_1 416 Wh_left_down
21 Corsole_1 416 Mirror_r2d
22 Corjsole_1 416 Mirror_r2u
23 Corjsole_1 416 Mirror_r2r
24 Corjsole_1 416 Mirror_r2|
25 Conpsole_1 416 Mirror_lzd
26 Corsole_1 416 Mirror_|2u
27 Cofsole_1 416 Mirror_l2r
28 Comsole_1 416 Mirror_|Z|
29 Galleway 2 273 WYoltage
30 Galeway 2 273 PetrolLevel
31 Gafeway 2 273 EngSpeed
32 Gafeway 2 273 CarSpeed
33 Gafeway_2 273 EngineTemp ¥
< ¥ < >
E=l
Ready
L____ | Show definitions: Displays messages File name : J

The file name to be editing

L

Delete definition:
Deletes messages from
the definition list

Save definition:
Saves the symbol
definition file
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2.1 Loading Reference Files

- =
1. In the Reference list, click J or click File > Reference to display the Open dialog box.

B

by Recent
Documents

-

Deszktop

|

by Documents

Laok in: | () DBC |

® eF E&-

Analyzelds. dbc
Analyzelds_Sign.dbe
Analyzelds_String32.dbc
Comfaort, dbe

easy.dbc

rnokbus, dbe

PowerTrain, dbc

stress.dbc

ty Computer
by Metwork, File narne: | j | Open |
Flaces
Files af type: |.-'-‘-.II lnadable files [*.dbc; * shl) ﬂ Cancel
2. Type the name of file you wish to open in the File name box or select one from the list, then click

Open. The messages are displayed in the reference list.

Note:
» If the edit mode is CAN, CANdb (*.dbc) and symbol definition (*.sbl) files can be loaded.
» If the edit mode is FlexRay, FIBEX (*.xml) and symbol definition (*.sbl) files can be

loaded. FIBEX files are limited to FIBEX v2.x—based FlexRay definitions.
» If the edit mode is LOGIC, symbol definition (*.sbl) files can be loaded.

» If the edit mode is LIN, LIN definition (*.Idf) and symbol definition (*.sbl) files can be

loaded.
» CANdb files can contain up to 5000 messages.
» FIBEX files can contain up to 2048 messages.
* LIN definition files can contain up to 3840 messages.

B9852US-01
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I 2.2 Displaying Definitions

I'E
1. In the reference list, select a message then click , or click Edit > View to display a dialog
box for displaying definitions.

[FlexRay] Message and signal parameters §| [LOGIG] Message parameters §|
Message name: |M592 J Message name: |Symb0|1
Frame Format: Group:
Message id: " Hex Bit counk: iz
Byte count: it pattern
Base cycle: - li$$
Bin: |111><1><><><
Sgees Don't care = "x"
Signal name: |CarSpeed
Bit arder: IMSE First - o oK | g |
; N N =[] 48
Start bit: 2 B Bl i EREE
e [p " IO OO0 16
: 0
Walue type: Unsigned w| 0 Little(Intel)
Stcaling
Factar: 1.0000 Maximurm:  [255.00
Offset: 0.0000 Minimurn;  |0.0000
Unit: [k
oK | el |
[CAN] Messaee and sienal parameters Pz| [LIN] Message and signal parameters Pz|
Message name: |WheeIInF0 J Message name: | Messaged J
Frame Format: — |STD Message id: 1] D " Hex
Message id: 200 " Hex Byte count: g
Byte count: iz Checksum: Classic
Signals Signals
Signal name: |WhEE|SDEEdFR Signal name: |Signal1
Bit order: MSE First -
Eit
45
Start bit: 18 HHHHHHHH HHHHHHHE Start bit: o
Bit count: Bit count: 8 OEE
Yalue type: ’m (+ Little{Intel) Yalue bype: ’W‘ (+ Little{Intel)
Scaling Scaling
Factar: 20.000m Maximurn:  |1.3000k Factar: 1.0000 Maximumn:
Offset: 0.0000 Minimurn;  |0.0000 Offset: 0.0000 Minimumn:
Unit: [1min Unit: [
oK | FoLl | oK | Cancel |

11
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Note:
* The contents of the dialog box differs depending on the edit mode.
* The contents of messages do not change.

CAN, FlexRay, LIN

The usage of bits within the message is shown to the right of the Start bit and Bit count
boxes.

Meanings of colors

[ Iwhite: Unused bit

EGreen: Bit used by signal in question

.Gray: Bit used by other signal (4 gradations express multiple signals)

« If the FIBEX definition encoding type is something other than INDENTICAL/LINNER, the
start bit, bit count, and scaling are blank.

» For FlexRay, if the byte count is greater than 8, up to 64 bits in the position of the byte
corresponding to the start bit is displayed.

B9852US-01
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I 2.3 Adding Definitions

1.

#3 Symbol Editor,

In the reference list, select a message then click
to the definition list.

or click Edit > Add. A message is added

File Edit Wew Help

FlexRay | GAN LIN LOGIC ?
Reference List mokbus, dbe Define List *
| Ma. | 1d | Signial Mo, | IMessage | 1d | Signal

1 WheelInfolEEE 199 WheelSpeedFR

2 ‘WheelInfolEEE 199 WheelSpeedFL

3 Wheellnfo 200 WheelSpeedRR

4 Wheellnfo 200 WheelSpeedRL

4
5 wheelSpeedFR
6 wheellnfo 200 WheelSpeedFL
7 GearBoxInfo 1020 EcoMode
& GearBoxInfo 1020 shiftReguest
9 GearBoxInfo 1020 Gear
10 EngSpeedContr 300 Test
11 EngineData 100 IdleRunning
12 EngineData 100 EngTemp
13 EngineData 100 Engspeed
14 ABSdata 201 Diagnoskics
15 AB3data 201 GearLock
16 ABSdata 201 Carspeed

£ > < >
2|
Ready
Note:

You can select one message or multiple messages to add at a time.
To select multiple messages, hold down the Ctrl key while clicking each message.
When multiple messages are selected, all are added to the definition list together.
You can add definitions by dragging messages from the reference list to the definition list.

Up to 500 messages can be registered in the definition list.
Definitions cannot be added for the following signals.

(1) If the definition overlaps with another signal

(2) If part of the display screen is blank

(3) If the encoding type is something other than INDENTICAL/LINNER
(4) If the encoding information (bit order, start bit, bit count, or byte order specification) is

invalid

13
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3.1 Loading Definition Files

(EE]

1. In the definition list, click

or click File > Open to display the Open dialog box.

Look jr: | | SymbolE ditar ﬂ ¢ Ef-
E sample.sbl
by Recent
Documents
|
Deszktop

¥

by Documents

@

ty Computer

My Metwark.  File name: | j m
Places
Files of type: |Symbol define file " sti) Bl ﬂ

Type the name of file you wish to open in the File name box or select one from the list, then click
Open. The messages are displayed in the definition list.

Note:
» Symbol definition files (*.sbl) are loaded.

B9852US-01 14



3.2 New Definitions

1. Inthe definition list, click or click Edit > New to display the dialog box for new definitions.

[FlexRay] Message and signal parameters §| [LOGIG] Message parameters §|

Message name: | Message name: |
Frame Format: Group: 1 -
Message id: 1 " Decimal {* Hex Eit: count: i

Byte count: 254 Bit pattern
Base cycle: 0 Cycle repetition: |4 Hese: s
Bin: |><><><><><><><><
Signals

Don't care = "

Signal name: |NOName

Bit order: MSE First - oK | )l |

Eit

; 45
Start bit: u a2

. O i LOGIC
Bit count: 1 = o

Yalue kype: Unsigned w| * Little(Intel) " Big{Motorala)

Scaling

Factar: 1.0000 Maximumn:
Offset: 0.0000 Minimumn:

Unit: [

QK | )l

FlexRay
[CAN] Message and signal parameters g| [LIN] Message and signal parameters g|
Message name: | j Message name: | j
Frame format: 5T hd

Message id: 0 > | & Decimal " Hex
Message id: 0 *| & Decimal " Hex Byte count: Gl

Byte count: i Checksurm: Classic -

Signals Signals
Signal name: | j Signal name: |NOName j
Bit order: MSE First -
Eit Eit
) [ 48 ) 48
Start bit: u 0 =2 Start bit: u a2
' [ 16 ' 16
Bit count: 1 0o Bit count: 1 0

Yalue kype: Unsigned »| O LitHe{Intel) " Big{Matorola) Value bype: Unsigned w| * Little(Intel) " Big{Motorala)

Scaling Scaling
Factar: 1.0000 Maximumn: Fackar: 1.0000 Maximumn:
Offset: 0.0000 Minimumn: Offset: 0.0000 Minimumn:

Unit: [ Unit: [

QK | )l | oK | )l |
CAN LIN

15 B9852US-01



Note:

» The contents of the dialog box differs depending on the edit mode.
» The characters that can be used in the Message name, Signal name, and Unit boxes are:
0to9,AtoZ,atoz, %, _, (,), -, and/
* You may not enter a message name that is already assigned to a message.
» Up to 500 messages can be registered in the definition list.
CAN
* You may not enter a signal name that already exists within a message.
* Message ID setting range
If Frame format = STD, 0 to 2047 (7FF hex)
If Frame format = XTD, 0 to 536870911 (1FFFFFFF hex)
» The byte count setting range is 0 to 8.
If 0, the signal cannot be set.
* The signal start bit setting range is 0 to (byte count x 8 — 1).
» The signal bit count setting range is 1 to (byte count x 8 — start bit).
* The maximum number of characters that can be used in the Message name, Signal name,
and Unit boxes is 32.
* When creating a new definition, you can copy previously defined message and signal
settings from the Message name, Message id, and Signal name lists.
* The usage of bits within the message is shown to the right of the Start bit and Bit count
boxes.
Meanings of colors
[Iwhite: Unused bit
EGreen: Bit used by signal in question
.Gray: Bit used by other signal (4 gradations express multiple signals)
You can click or drag to select.
LIN
* You may not enter a signal name that already exists within a message.
» The message id setting range is 1 to 63 (3F hex)
* The byte count setting range is 0 to 8.
If 0, the signal cannot be set.
» The signal start bit setting range is 0 to (byte count x 8 — 1).
» The signal bit count setting range is 1 to (byte count x 8 — start bit).
» The maximum number of characters that can be used in the Message name, Signal name,
and Unit boxes is 32.
* When creating a new definition, you can copy previously defined message and signal
settings from the Message name, Message id, and Signal name lists.
» The usage of bits within the message is shown to the right of the Start bit and Bit count
boxes.
Meanings of colors
[Iwhite: Unused bit
EGreen: Bit used by signal in question
.Gray: Bit used by other signal (4 gradations express multiple signals)
You can click or drag to select.
FlexRay
* You may not enter a signal name that already exists within a message.
* The message id setting range is 1 to 2047 (7FF hex)
* The byte count setting range is 0 to 254.
If 0, the signal cannot be set.
» The signal start bit setting range is 0 to (byte count x 8 — 1).
» The signal bit count setting range is 1 to (byte count x 8 — start bit).
» The setting range for the base cycle is 0 to (cycle repetitions - 1).
» The setting range for the cycle repetition is 1 to 64.
The send schedule for messages in FlexRay is determined by the base cycle and cycle
repetition.
Base cycle: In communication cycles (0 to 63), specify the cycle at which the first
message is sent.
Cycle repetition: Specify an interval in numbers of cycles starting from the base cycle at
which messages are sent.
Ex. 1) Base cycle=3, Cycle repetition=4
The cycle count: 3, 7, 11, ...59, 63 is defined as the message send schedule.
Ex. 2) Base cycle=0, Cycle repetition=1
The entire cycle count: 0, 1, 2, ..., 63 is defined as the message send schedule.

B9852US-01 16



* The maximum number of characters that can be used in the Message name, Signal name,
and Unit boxes is 32.

* When creating a new definition, you can copy previously defined message and signal
settings from the Message name, Message id, and Signal name lists.

* The usage of bits within the message is shown to the right of the Start bit and Bit count
boxes.
Meanings of colors
[Iwhite: Unused bit

DGreen: Bit used by signal in question

.Gray: Bit used by other signal (4 gradations express multiple signals)

Up to 64 bits from the byte position corresponding to Start can be used.

You cannot click or drag the mouse to select.
LOGIC
» You cannot create an identical bit pattern to one that already exists in the same group.
* The maximum number of characters that can be used in the Message name box is 16.

17
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3.3 Editing Definitions

1. In the definition list, select a message and click

box for editing definitions.

[FlexRay] Message and signal parameters

3

[LOGIG] Message parameters

or click Edit > Edit to display the dialog

X

Message name: |M59? Message name: |Symb0|1
Frame format: Group: 1 =
Message id: " Hex Bit counk: i
B}iS @il Bit pattern
Base cycle: 3 Cycle repetition: |4 - ’”7
i |1tz
Signals : : Don't care = "
Signal name: |RH_L|ghtSW|ng
Bit order: MSE First ¥ i oK | el |
i
45
Start bit: 2 a2
v o AL 16 LOGIC
Bit count: (0 T o
Yalue kype: Signed »| & Litte{Intel) " Big{Makaorala)
Scaling
Factar: 1.0000 Maximurn: 20,000
Offset: 0.0000 Minimurn;  |-20.000
Unit: [pea
oK | el
FlexRay
[CAN] Messaee and sienal parameters Pz| [LIN] Message and signal parameters Pz|
Message name: |WheeIInF0 Message name: | Messaged
Frame Format: - Message id: a &+ Decimal " Hex
Message id: 200 + Decimal " Hex Byte count: g
Byte count: i Checksurm: Classic -
Signals Signals
Signal name:  [WheslSpesdrL Signal name: | Signall
Bit order: MSE First -
Eit Eit
; AR R EEEEE = } 48
Start bit: 32 EEEEEEEE EEEEEEEE a2 Start bit: o a2
16 16
i g 16 i : PR ™ O O
Bit count: 0 o Bit count: 5 o o o o
Value bype: Unsigned | & Little(Intel) © Big{Matorola) Value bype: Unsigned »| & Litte{Intel) " Big{Makaorala)
Scaling Scaling
Factor: 20,000m Maximum:  |1.3000k Factor: 1.0000 Maxirnurn:
Offset: 0.0000 Minimurn; ~ |0.0000 Offset: 0.0000 Minimumn:
Unit: [1min Unit: [
oK | el | oK | Cancel |

CAN

LIN

For precautions when editing definitions, see "Note” in section 3.2.

B9852US-01
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3.4 Deleting Definitions

or click Edit > Delete. The selected

1. In the definition list, select messages and click
messages are deleted from the definition list.

2 Symbol Editor

File Edit View Help

1 ‘WheellnfolEEE
2 WheelInfolEEE
3 ‘Wheslnfo

B
7 GearBoxInfo
g GearBoxInfo
9 GearBoxInfo
10 EngSpeedContr
11 Enginelata
12 Enginelbata
13 Enginelata

< > < >
| Ready

199 ‘WheelSpeedFR
199 wheelSpeedFL
200 ‘WheelSpeedrR
200 WheelSpeedrL

200
1020 EcoMode
1020 shiftRegquest
1020 Gear

300 Test

100  IdleRunning

100 EngTemp

100 EngSpeed

14 ABSdata 201 Diagnostics
15 ABSdata 201 Gearlock
16 ABSdata 201 CarSpeed

FlexRay | CAN LIN LOGIG == g
Reference List mokbus, dbc Define List WheelInfo, sbl
am| m|m|

M, | Message | Id | Signal | Na, | Message Id | Signal

4 ‘wheellnfo

200 WheelSpeedrR,
z00 ‘WwheelSpeedrL

Note:

You can select one message or multiple messages to delete at a time. To select multiple
messages, hold down the Ctrl key while clicking each message. When multiple
messages are selected, all can be deleted from the definition list together.

19
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3.5 Saving Definitions

Save As

3

by Recent
Documents

'_'F
Deszktop
by Documents
by Computer
by Metwork,
Flaces

1.

In the definition list, click

Save i | | SymbolE ditar

or click File > Save to display the Save As dialog box.

?)X

= £F B
sample.sl:ul
File name: | | Save |

Save as hype:

|S_|,|m|:u:|| define file [*.zhl]

[~
El

Cancel

2. In the File name box, type the name under which you wish to save the file or select a file from the list,
then click Save. The contents of the definition list are saved to the file.

Note:

* You can save symbol definition files (*.sbl).

B9852US-01
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4.1 Searching for Messages

HE==!

1. Click , or click Edit > Search to display the Find dialog box.

Find ]

Find Lisk

¥ Reference List " Define List

Find whak; | ﬂ

Fird | Cancel

2. Enter the string you wish to search for in the Find what box, then click Find. The matching location in
the specified list is selected and displayed.

Note:
* You can select from a history of previously entered search strings in the list.

21 B9852US-01



4.2 Selecting or Sorting All Items in the List

* Selecting All Items in the List

1. Click Edit > All to select all items in the active list.

* Sorting All Items in the List

1. Click a column title without No. to sort. Toggles between ascending and descending sort order.

2 Symbol Editor

File Edit View Help
FlexRay | CAN LIN LOGIC == g
Beference List motbus, dbe Define List WWheelInfa, shl
| - 1
i =y AN
i, | Message | Id | Signal \ | o, | Message | Id | Signal
oo i aalsnaadan \
2 WheslInfolEEE 199 WheslSpeedFL wheellnfoIEEE
3 ‘wWheellnfa 200 ‘WheelSpeedrR 3 ‘Wheellnfo 200 WheelSpeedrR
4 ‘wheellnfa 200 WheelSpeedrL 4 Wheellnfa 200 WheelSpeedrL
WheelInfo
6 wheellnfa 200 WheelSpeedFL
7 GearBoxInfo 1020 EcoMode
& GearBoxInfo 1020 shiftRequest
9 GearBoxInfo 1020 Gear
10 EngSpeedCantr 300 Test
11 EngineData 100 IdleRunning
12 Enginelbata 100 EngTemp
13 EngineData 100 EngSpeed .
14 ABSdata 201 Diagnostics Table titles
15 ABSdata 201 GearLock
16 ABSdata 201 CarSpeed
< > < >
| Ready
Note:

* When sorted, A (ascending) or ¥ (descending) is indicated in the title.
* You can change the order of the messages by dragging them to any location in the
definition list.
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I 5 Other Functions

* Version Information
1. Click Help > About to display version information.

About Symbol Editor

F Symbol Editor Version 1.40
=

Copyright [C) 2008 Yokogawa Electric Corporation. All rights reserved.
Copyright [C) 2010 Yokogawa Meters & Instruments Corporation. All rights reserved.

e User's Manual

1. Click , or click Help > User’s Manual to display the user's manual.

Note:
» Adobe Reader by Adobe Systems is required to open PDF files. You can download
Adobe Reader from the following Web page.
http://www.adobe.com/

* Viewing the Yokogawa Electric Web Site

1. Click Help > YOKOGAWA Web site > Test & Measurement, or click Help > YOKOGAWA Web
site > Symbol Editor. The Yokogawa Web site appears.

Note:
If your PC is connected to the Internet, the Yokogawa Web site is displayed.
Test & Measurement: The Yokogawa Test & Measurement home page is displayed.
Symbol Editor: The product page is displayed, containing the latest product
information including information on version upgrades.
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