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Thank you for purchasing the Xviewer (Model 701992) waveform viewer software.

This User’s Manual contains information on the functions and operation of the Xviewer,
as well as precautions that must be observed. To ensure the correct operation of the
Xviewer, read this manual thoroughly before attempting to use the product. After reading
the manual, keep it in a convenient location for quick reference whenever a question
arises during operation.

Furthermore, for handling precautions, functions, and operating procedures of the

DL series, SL1400, SL1000, or other instruments, or for the handling and operating
procedures of Windows, please see the manuals for those respective products.

The following manuals, including this one, are provided as manuals for the Xviewer.
Read them along with this manual.

Manual Title Manual No. Description

701992 IM 701992-01E  This manual. Explains the Xviewer’s standard
Xviewer User’s Manual features and how to use these features.
Xviewer EYE Video and IM 701992-61E  Explains the video and waveform viewer
Waveform Viewer Feature features and how to use these features.
User’s Manual

Xviewer DL850 Advanced IM 701992-62E  Explains the DL850 advanced utility features
Utility User’s Manual and how to use these features.

 If the most recent software version is not running on your Xviewer, not all of the
features described in this manual can be used. You can check the software version of
your Xviewer on the version information screen. For instructions on how to open the
version information screen, see section 9.2 in this manual. To upgrade to the latest
software version, go to the following Web page, and then browse to the download
page.

http://tmi.yokogawa.com/service-support/downloads

» The contents of this manual are subject to change without prior notice due to
performance/functional improvements to the software or related products. The images
appearing in this manual are for illustrative purposes only and may differ slightly from
the screens that actually appear on your machine.

» Every effort has been made in the preparation of this manual to ensure the accuracy
of its contents. However, should you have any questions or find any errors, contact
your nearest Yokogawa dealer.

» Copying or reproducing all or any part of the contents of this manual without the
permission of Yokogawa Electric Corporation is strictly prohibited.

* Microsoft, Windows, Windows XP are either registered trademarks or trademarks of
Microsoft Corporation in the United States and/or other countries.

» Adobe, Acrobat, and PostScript are either registered trademarks or trademarks of
Adobe Systems Incorporated.

* In this manual, the ® and TM symbols do not accompany their respective registered
trademark names or trademark names.

» Other company names and product names are registered trademarks or trademarks
of their respective holders.

All Rights Reserved, Copyright © 2004 Yokogawa Electric Corporation
All Rights Reserved, Copyright © 2010 Yokogawa Meters & Instruments Corporation
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Terms and Conditions of the Software License

Yokogawa Electric Corporation and Yokogawa Meters & Instruments Corporation, Japanese corporations (hereinafter called
“Yokogawa”), grant permission to use this Yokogawa Software Program (hereinafter called the “Licensed Software”) to the Licensee
on the conditions that the Licensee agrees to the terms and conditions stipulated in Article 1 hereof.

You, as the Licensee (hereinafter called “Licensee”), shall agree to the following terms and conditions for the software license
(hereinafter called the “Agreement”) based on the use intended for the Licensed Software.

Please note that Yokogawa grants the Licensee permission to use the Licensed Software under the terms and conditions herein and
in no event shall Yokogawa intend to sell or transfer the Licensed Software to the Licensee.

Licensed Software Name: ~ Xviewer (Model 701992) or XviewerEYE (Model 701992)

Number of License: The number of licenses printed on the license seal

Article 1 (Scope Covered by these Terms and Conditions)

1.1 The terms and conditions stipulated herein shall be applied to any Licensee who purchases the Licensed Software on the
condition that the Licensee consents to agree to the terms and conditions stipulated herein.

1.2 The “Licensed Software” herein shall mean and include all applicable programs and documentation, without limitation, all
proprietary technology, algorithms, and know-how such as a factor, invariant or process contained therein.

Article 2 (Grant of License)

2.1 Yokogawa grants the Licensee, for the purpose of single use, non-exclusive and non-transferable license of the Licensed
Software with the license fee separately agreed upon by both parties.

2.2 The Licensee is, unless otherwise agreed in writing by Yokogawa, not entitled to copy, change, sell, distribute, transfer, or
sublicense the Licensed Software.

2.3 The Licensed Software shall not be copied in whole or in part except for keeping one (1) copy for back-up purposes. The
Licensee shall secure or supervise the copy of the Licensed Software by the Licensee itself with great, strict, and due care.

2.4 In no event shall the Licensee dump, reverse assemble, reverse compile, or reverse engineer the Licensed Software so that
the Licensee may translate the Licensed Software into other programs or change it into a man-readable form from the source
code of the Licensed Software. Unless otherwise separately agreed by Yokogawa, Yokogawa shall not provide the Licensee the
source code for the Licensed Software.

2.5 The Licensed Software and its related documentation shall be the proprietary property or trade secret of Yokogawa or a third
party which grants Yokogawa the rights. In no event shall the Licensee be transferred, leased, sublicensed, or assigned any
rights relating to the Licensed Software.

2.6 Yokogawa may use or add copy protection in or onto the Licensed Software. In no event shall the Licensee remove or attempt to
remove such copy protection.

2.7 The Licensed Software may include a software program licensed for re-use by a third party (hereinafter called “Third Party
Software”, which may include any software program from affiliates of Yokogawa made or coded by themselves.) In the case
that Yokogawa is granted permission to sublicense to third parties by any licensors (sub-licensor) of the Third Party Software
pursuant to different terms and conditions than those stipulated in this Agreement, the Licensee shall observe such terms and
conditions of which Yokogawa notifies the Licensee in writing separately.

2.8 In no event shall the Licensee modify, remove or delete a copyright notice of Yokogawa and its licenser contained in the
Licensed Software, including any copy thereof.

Article 3 (Restriction of Specific Use)

3.1 The Licensed Software shall not be intended specifically to be designed, developed, constructed, manufactured, distributed or

maintained for the purpose of the following events:

a) Operation of any aviation, vessel, or support of those operations from the ground;,

b) Operation of nuclear products and/or facilities;,

c) Operation of nuclear weapons and/or chemical weapons and/or biological weapons; or
d) Operation of medical instrumentation directly utilized for humankind or the human body.

3.2 Even if the Licensee uses the Licensed Software for the purposes in the preceding Paragraph 3.1, Yokogawa has no liability
to or responsibility for any demand or damage arising out of the use or operations of the Licensed Software, and the Licensee
agrees, on its own responsibility, to solve and settle the claims and damages and to defend, indemnify or hold Yokogawa
totally harmless, from or against any liabilities, losses, damages and expenses (including fees for recalling the Products and
reasonable attorney’s fees and court costs), or claims arising out of and related to the above-said claims and damages.

Article 4 (Warranty)

4.1 The Licensee shall agree that the Licensed Software shall be provided to the Licensee on an “as is” basis when delivered. If
defect(s), such as damage to the medium of the Licensed Software, attributable to Yokogawa is found, Yokogawa agrees to
replace, free of charge, any Licensed Software on condition that the defective Licensed Software shall be returned to Yokogawa’
s specified authorized service facility within seven (7) days after opening the Package at the Licensee’s expense. As the
Licensed Software is provided to the Licensee on an “as is” basis when delivered, in no event shall Yokogawa warrant that any
information on or in the Licensed Software, including without limitation, data on computer programs and program listings, be
completely accurate, correct, reliable, or the most updated.

4.2 Notwithstanding the preceding Paragraph 4.1, when third party software is included in the Licensed Software, the warranty
period and terms and conditions that apply shall be those established by the provider of the third party software.

4.3 When Yokogawa decides in its own judgement that it is necessary, Yokogawa may from time to time provide the Licensee with
Revision upgrades and Version upgrades separately specified by Yokogawa (hereinafter called “Updates”).

4.4 Notwithstanding the preceding Paragraph 4.3, in no event shall Yokogawa provide Updates where the Licensee or any third
party conducted renovation or improvement of the Licensed Software.

4.5 THE FOREGOING WARRANTIES ARE EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES OF QUALITY AND
PERFORMANCE, WRITTEN, ORAL, OR IMPLIED, AND ALL OTHER WARRANTIES INCLUDING ANY IMPLIED WARRANTIES
OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE ARE HEREBY DISCLAIMED BY YOKOGAWA AND
ALL THIRD PARTIES LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA.

4.6 Correction of nonconformity in the manner and for the period of time provided above shall be the Licensee’s sole and exclusive
remedy for any failure of Yokogawa to comply with its obligations and shall constitute fulfillment of all liabilities of Yokogawa
and any third party licensing the Third Party Software to Yokogawa (including any liability for direct, indirect, special, incidental
or consequential damages) whether in warranty, contract, tort (including negligence but excluding willful conduct or gross
negligence by Yokogawa) or otherwise with respect to or arising out of the use of the Licensed Software.
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Terms and Conditions of the Software License

Article 5 (Infringement)

5.1 If and when any third party should demand injunction, initiate a law suit, or demand compensation for damages against the
Licensee under patent right (including utility model right, design patent, and trade mark), copy right, and any other rights relating
to any of the Licensed Software, the Licensee shall notify Yokogawa in writing to that effect without delay.

5.2 In the case of the preceding Paragraph 5.1, the Licensee shall assign to Yokogawa all of the rights to defend the Licensee and
to negotiate with the claiming party. Furthermore, the Licensee shall provide Yokogawa with necessary information or any other
assistance for Yokogawa’s defense and negotiation. If and when such a claim should be attributable to Yokogawa, subject to the
written notice to Yokogawa stated in the preceding Paragraph 5.1, Yokogawa shall defend the Licensee and negotiate with the
claiming party at Yokogawa’s cost and expense and be responsible for the final settlement or judgment granted to the claiming
party in the preceding Paragraph 5.1.

5.3 When any assertion or allegation of the infringement of the third party’s rights defined in Paragraph 5.1 is made, or when at
Yokogawa'’s judgment there is possibility of such assertion or allegation, Yokogawa will, at its own discretion, take any of the
following countermeasures at Yokogawa’s cost and expense.

a) To acquire the necessary right from a third party which has lawful ownership of the right so that the Licensee will be able
to continue to use the Licensed Software;

b)  To replace the Licensed Software with an alternative one which avoids the infringement; or

c) To remodel the Licensed Software so that the Licensed Software can avoid the infringement of such third party’s right.

5.4 If and when Yokogawa fails to take either of the countermeasures as set forth in the preceding subparagraphs of Paragraph
5.3, Yokogawa shall indemnify the Licensee only by paying back the price amount of the Licensed Software which Yokogawa
has received from the Licensee. THE FOREGOING PARAGRAPHS STATE THE ENTIRE LIABILITY OF YOKOGAWA AND
ANY THIRD PARTY LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA WITH RESPECT TO INFRINGEMENT OF THE
INTELLECTUAL PROPERTY RIGHTS INCLUDING BUT NOT LIMITED TO, PATENT AND COPYRIGHT.

Article 6 (Liabilities)

6.1 If and when the Licensee should incur any damage relating to or arising out of the Licensed Software or service that Yokogawa
has provided to the Licensee under the conditions herein due to a reason attributable to Yokogawa, Yokogawa shall take actions
in accordance with this Agreement. However, in no event shall Yokogawa be liable or responsible for any special, incidental,
consequential and/or indirect damage, whether in contract, warranty, tort, negligence, strict liability, or otherwise, including,
without limitation, loss of operational profit or revenue, loss of use of the Licensed Software, or any associated products or
equipment, cost of capital, loss or cost of interruption of the Licensee’s business, substitute equipment, facilities or services,
downtime costs, delays, and loss of business information, or claims of customers of Licensee or other third parties for such or
other damages. Even if Yokogawa is liable or responsible for the damages attributable to Yokogawa and to the extent of this
Article 6, Yokogawa'’s liability for the Licensee’s damage shall not exceed the price amount of the Licensed Software or service
fee which Yokogawa has received. Please note that Yokogawa shall be released or discharged from part or all of the liability
under this Agreement if the Licensee modifies, remodels, combines with other software or products, or causes any deviation
from the basic specifications or functional specifications, without Yokogawa'’s prior written consent.

6.2 All causes of action against Yokogawa arising out of or relating to this Agreement or the performance or breach hereof shall
expire unless Yokogawa is notified of the claim within one (1) year of its occurrence.

6.3 In no event, regardless of cause, shall Yokogawa assume responsibility for or be liable for penalties or penalty clauses in any
contracts between the Licensee and its customers.

Article 7 (Limit of Export)

Unless otherwise agreed by Yokogawa, the Licensee shall not directly or indirectly export or transfer the Licensed Software to any
countries other than those where Yokogawa permits export in advance.

Article 8 (Term)

This Agreement shall become effective on the date when the Licensee receives the Licensed Software and continues in effect unless
or until terminated as provided herein, or the Licensee ceases using the Licensed Software by itself or with Yokogawa'’s thirty (30)
days prior written notice to the Licensee.

Article 9 (Injunction for Use)
During the term of this Agreement, Yokogawa may, at its own discretion, demand injunction against the Licensee in case that

Yokogawa deems that the Licensed Software is used improperly or under severer environments other than those where Yokogawa
has first approved, or any other condition which Yokogawa may not permit.

Article 10 (Termination)

Yokogawa, at its sole discretion, may terminate this Agreement without any notice or reminder to the Licensee if the Licensee
violates or fails to perform this Agreement. However, Articles 5, 6, and 11 shall survive even after the termination.

Article 11 (Jurisdiction)

Any dispute, controversies, or differences between the parties hereto as to interpretation or execution of this Agreement shall be
resolved amicably through negotiation between the parties upon the basis of mutual trust. Should the parties fail to agree within
ninety (90) days after notice from one of the parties to the other, both parties hereby irrevocably submit to the exclusive jurisdiction
of the Tokyo District Court (main office) in Japan for settlement of the dispute.

Article 12 (Governing Law)

This Agreement shall be governed by and construed in accordance with the laws of Japan. The Licensee expressly agrees to waive
absolutely and irrevocably and to the fullest extent permissible under applicable law any rights against the laws of Japan which it
may have pursuant to the Licensee’s local law.

Article 13 (Severability)

In the event that any provision hereof is declared or found to be illegal by any court or tribunal of competent jurisdiction, such
provision shall be null and void with respect to the jurisdiction of that court or tribunal and all the remaining provisions hereof shall
remain in full force and effect.
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Checking the Contents of the Package

After opening the package, check that it contains the items listed below. If
any of thecontents are incorrect, missing, or damaged, contact the dealer
from whom youpurchased it.

CD x1
Model Suffix Code Description
701992 Xviewer
Grade/Number of Licenses -SP01 Standard edition (1 license)
-SP05 Standard edition (5 licenses)
-SP10 Standard edition (10 licenses)
-SP20 Standard edition (20 licenses)
-GPO1 Math edition (1 license)
-GP05 Math edition (5 licenses)
-GP10 Math edition (10 licenses)
-GP20 Math edition (20 licenses)
-ES01 XviewerEYE standard edition (1 license)
-ES02 XviewerEYE standard edition (2 licenses)
-ES03 XviewerEYE standard edition (3 licenses)
-ES04 XviewerEYE standard edition (4 licenses)
-ES05 XviewerEYE standard edition (5 licenses)
-ES10 XviewerEYE standard edition (10 licenses)
-EGO1 XviewerEYE math edition (1 license)
-EG02 XviewerEYE math edition (2 licenses)
-EGO3 XviewerEYE math edition (3 licenses)
-EG04 XviewerEYE math edition (4 licenses)
-EGO05 XviewerEYE math edition (5 licenses)
-EG10 XviewerEYE math edition (10 licenses)
1JS01 DL850 Advanced Utility (1 license)
1JS02 DL850 Advanced Utility (2 licenses)
1JS03 DL850 Advanced Utility (3 licenses)
1JS04 DL850 Advanced Utility (4 licenses)
/JS05 DL850 Advanced Utility (5 licenses)
1JS10 DL850 Advanced Utility (10 licenses)
/JS20 DL850 Advanced Utility (20 licenses)
Manuals
Manual Title Manual No.
701992 Xviewer User’s Manual (Located on the CD) IM 701992-01E
701992 Xviewer Install Manual IM 701992-02E

701992 XviewerEYE Video and Waveform Viewer Feature User's Manual [IM 701992-61E
(Located on the CD)

Xviewer DL850 Advanced Utility User’'s Manual (Located on the CD) IM 701992-62E

License seal x 1
(for /JS01 to JS20: license seal x 2)
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Symbols and Notations Used in This Manual

Marking
The following marking is used in this manual

Note Calls attention to information that is important for proper operation of
the instrument.

Notation Used in the Procedural Explanations
On pages that describe the operating procedures in each chapter, the following notations

are used to distinguish the procedures from their explanations.

Carry out the procedure according to the step numbers. All
procedures are written with inexperienced users in mind;

experienced users may not need to carry out all the steps.

S'CIEGENLNN  This section describes the setup items and the limitations regarding
the procedures.

Notation in Boldface
Boldface type indicates the names of user-controlled panel keys, and soft key items

and menu items displayed on screen.
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Product Overview

Waveform Viewer Xviewer

Viewing and Analyzing Data Saved with the Instruments

You can view and analyze data saved with the measuring instruments on a personal
computer (hereinafter, PC).

The formats of the files saved by the measuring instruments are as follows.

File Types

Model csv' WVF2 WDF
WE7000 Yes Yes No
DL1700 series Yes Yes No
DL1600 series Yes Yes No
DL1700E series Yes Yes No
DL7400 series Yes Yes No
DL750 series Yes Yes Yes®
SL1400 Yes Yes Yes®
DL9040/DL9140/DL9240 series Yes No Yes?
DL9500/DL9700 series Yes No Yes?
SB5000 series Yes No Yes?
SL1000 No No Yes? 3
DLM2000 series Yes No Yes?
DL6000/DLM6000 series Yes No Yes?
DL850 series Yes No Yes?
DLM4000 series Yes No Yes?

1 Files created and saved in ASCII format
2 Files created and saved in binary format
3 Files created with real-time recording

This document refers to the DL9040/DL9140/DL9240 series, and the DL9500/DL9700
series collectively as the “DL9000 series”.

Viewing and Transferring Files Saved with the Instruments

Xviewer supports the viewing of the instrument files as well as the transfer of files
between the instrument and your PC by using the GP-IB/USB/Ethernet interface. The
communication interfaces and functions that can be used are shown on the next page.

Nofte

Xviewer file transfer from your PC to the instrument is possible only via the USB interface.

Remote Control of the Instruments

With the GP-IB/USB/Ethernet interface, Xviewer supports the display of images (control
windows) from the instrument on your PC, as well as the remote-control of the instrument
as if you were operating the unit from its own control panel. In addition, to enable the
setup of a control window environment, Xviewer features Environment Setting Keys,
which are not found on the DL unit.

The communication interfaces and functions that can be used are shown on the next
page.

Downloading the Instruments Acquisition Data

The instrument acquisition data can be downloaded to a PC using the GP-IB, USB, or
Ethernet interface.

The communication interfaces and functions that can be used are shown on the next

page.
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Product Overview

Available communication interface

Model Interface
GP-IB uUsB Ethernet

WE7000 No No No
DL1700 series No No No
DL1600 series Yes Yes Yes
DL1700E series Yes Yes Yes
DL7400 series Yes Yes Yes
DL750 series Yes Yes Yes
SL1400 Yes Yes Yes
DL9040/DL9140/DL9240 series Yes Yes' Yes
DL9500/DL9700 series Yes Yes' Yes
SB5000 series Yes Yes' Yes
SL1000 No Yes' Yes?
DLM2000 series Yes Yes' Yes?
DL6000/DLM6000 series Yes Yes' Yes?
DL850 series Yes Yes' Yes?
DLM4000 series Yes Yes' Yes?

1 Control by USB-TMC
2 Control by VXI11

Available function

Communication Function

Model Viewing and Remote Control Downloading

Transferring Files Acquisition Data
WE7000 No No No
DL1700 series No No No
DL1600 series Yes Yes Yes

Version 1.12 or later | Version 1.12 or later | Version 1.30 or later
DL1700E series Yes Yes Yes

Version 2.11 or later

DL7400 series Yes Yes Yes

Version 1.23 or later | Version 1.23 or later | Version 2.11 or later
DL750 series Yes Yes Yes

Version 2.50 or later | Version 2.50 or later | Version 6.01 or later
SL1400 Yes Yes Yes
DL9040/DL9140/DL9240 series Yes Yes Yes

Version 1.80 or later | Version 1.64 or later | Version 1.80 or later
DL9500/DL9700 series Yes Yes Yes
SB5000 series Yes Yes Yes
SL1000 Yes No No
DLM2000 series Yes Yes Yes
DL6000/DLM6000 series Yes Yes Yes
DL850 series Yes Yes Yes
DLM4000 series Yes Yes Yes

System Environment Requirements

See section 10.2
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Important Notice

Keep the Original CD-ROM Safe
Keep the original Xviewer CD-ROM in a safe place. Normally, the software should be
installed onto and run from a hard drive.

Precautions on the Use of Xviewer

When you are using Xviewer, do not attempt to manipulate the instruments connected
to it; the units may malfunction

Xviewer may be unable to operate if the PC goes into standby mode. Disable standby
mode on your PC before starting up Xviewer.

If you start this software program when using the Ethernet interface, the line load

will differ depending on the measuring instrument used. For details, see section

8.1. Check with your network administrator as to whether these traffic loads can be
handled by your network.

Do not attempt to use Xviewer to alter the network or communication settings of the
connected the instruments. Doing so may lead to a communication failure between
the instruments.

Do not attempt any self-tests with Xviewer.

One Xviewer instance can control only one instrument. In addition, multiple PCs
cannot be connected to a single instrument.

Xviewer does not support the thumbnail previews offered by the DL1600/DL1700E
series. Also, Xviewer does not support the thumbnails or previews offered by the
DL7400 series.

In the event of a connection error with the instrument, power off the instrument, and
then turn it on again.

IM 701992-01E
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Installing/Uninstalling Xviewer

Procedure

Installing Xviewer
The steps below assume the use of Windows 7.

1.

N W

g

to the outside of the CD-ROM case.

Turn on your PC, log on with the Administrator account, then wait for Windows to
start up.

Place the Xviewer CD-ROM in the PC’s CD-ROM drive. The Xviewer Installer
starts automatically and begins to prepare the installation.

Follow the displayed instructions and then click Next.

The Agreements screen is displayed and prompts you to indicate whether you
agree with the conditions of use for the software. Once you have read and agreed
to the conditions of use, place a check mark against | Agree with the Conditions
of Use and then click Next.

A screen for entering user information is displayed. Enter the User Name,
Organization, and License Number, specify the users who will be allowed to use
Xviewer, and then click Next. The license number can be found on a label applied

Customer Information

Flease enter your information,

User Name:
|user]

Organization:

]

License Mumber:

1 =

Enter the license
number printed on
the installation disk
package

Installshield

[ < Back ][- Mext = ] [

Product information

The following product will be installed.

Product MName:

Xviewer

Mathematical Edition (1 license)

Installshield

< Back ][ Mext = ] [ Cancel ]

xii
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Installing/Uninstalling Xviewer

7. The installation folder screen is displayed. The default setting is C:\Program Files\
Yokogawa\Xviewer. To specify a different installation folder, click Browse. After
specifying the installation folder, click Next.

Destination Folder
Click Mext to install to this folder, or dick Change to install to a different folder.

|‘_-' Install Xviewer to:
'_’7 C:\Program Files\Yokogawa \Nviewer),

InstaliShield

[ < Back ]E Mext = ] [ Cancel ]

8. The installation start screen is displayed. Click Install to start installing Xviewer.
The Installer starts the installation of Xviewer.

To return to the previous screen and change installation settings, click Back. To
cancel the installation, click Cancel.

The User Account Control screen will appear part way through the installation.
Click Allow to continue with the installation.

Do you want to allow the following program to update
software on this computer?

B Program name:  Xviewer

Verified publisher: Yokogawa Meters and Instruments
Corporation
File origin: Hard drive on this computer

'\:’ ) Show details Yes E No i

Change when these notifications appear ||

IM 701992-01E
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Installing/Uninstalling Xviewer

If the software installation finishes normally, the following screen appears.

InstallShield Wizard Completed

Setup has finished installing Xviewer,

When connecting to a DL series instrument via USB, install the
dedicated USE driver.

The USE driver is induded on the product CD-ROM. ‘You can
also download the software from our Web site,

For the USE driver and installation instructions, see the user's
manual or the Web site below. https:/fyink. yokogawa.com

[ Install additional license

Cancel

9. Click Finish to close the Installer. A Yokogawa > Xviewer selection will be
available when you click Start > Programs and a shortcut icon to Xviewer will
appear on the desktop.

Nofte
If an older version of Xviewer is already installed on the PC, you must uninstall that version
before proceeding with the installation of the new one.

Uninstalling Xviewer
The steps below assume the use of Windows 7.

1. Select Control Panel from the Start menu.
2. Double-click Programs and Features on Control Panel.

3. Select Xviewer in the list displayed for Programs snf Features, and then click
Uninstall/Change.
4. Ascreen appears asking you to confirm whether you want to delete Xviewer.

Click Yes to proceed. Xviewer is removed from your PC.
Click No to cancel.

The User Account Control screen will appear part way through the uninstallation.
Click Allow to continue with the uninstallation.
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Installing/Uninstalling Xviewer

Explanation

USB Driver

To establish a USB connection with the DL series unit, Xviewer requires that the USB
driver be installed for that DL series unit. The USB driver is included in the Xviewer
installation disk. The most-recent USB driver can be downloaded from the following Web
page.

http://www.yokogawa.com/tm/tm-softdownload.htm

* Install the USB Driver
Run the Setup.exe file in the YKMUSB folder. The installation wizard starts.
For the details of the installation procedure, please see the manual (IM B9852UT-01E)
in the YKMUSB folder.
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Chapter 1 Basic Operations

1.1 Starting and Closing Xviewer

Procedure

Starting Xviewer
From the Windows Start menu, select Programs > Yokogawa > Xviewer > Xviewer.

Xviewer starts up and displays the Xviewer toolbar, controller window, and viewer
window, as shown below:

Xviewer toolbar

Fils Wiew Vindow Connect Tool Help
J =3 & x TG £ ) W ?
Controller Mew Wiewer Close Arrange CommSetting Open Inst. Control Inst.  ACQ save Help

[, e N =TE]

xviewer

E Contraller File  View
B2 Viewer! 2 S
& W w6 [ X -

— Viewer window

Ready EEEEY
ster] ||| ) @ 5 (B || rvener [viewert SMAR  seen

— Controller window

Closing Xviewer
Select File > Close Xviewer from the Xviewer toolbar.

Nofte

If the extension of the waveform data files is as follows, you can double-click the file to start
Xviewer and display the waveform on the viewer.

o wvf

e wdf

IM 701992-01E
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1.2 Basic Operations Performed From the Startup
Windows

Procedure

Xviewer toolbar:
Used to manipulate the controller window and viewer windows and to control the
connection with the instrument.

Controller window:
Used to make one of the displayed viewer windows active.

Viewer window:

Used to load, display, and analyze waveform data. Multiple viewer windows can be
displayed and used to load, display, and analyze waveform data in the respective viewer
windows.

Xviewer toolbar
— Displays or hides the controller window

— Control viewer windows
New Viewer: Opens a new viewer window
Close: Closes all the displayed viewer windows
Arrange: Arranges the displayed viewer windows into order

— Control connection with the instrument

CommSetting: Allows the specification of the settings for
communicating with the instrument’

Open Inst: Makes a connection with the instrument’ to
display and transfer files

Control Inst:  Makes a connection with the instrument? and
displays a window for handling the target
instrument

ACQ save: Downloads the instrument? acquisition data to
the PC

Displays the manual

®

Active viewer window

Loads a waveform
data file

Viewer window

Hstare If] 8 5 [0 || Boiewer | Mvienert |Movez  |[Mviewer ZEELe tem
Controller Window

Clicking an icon makes the associated viewer window active Double-clicking it
maximizes the window

1 DL750 series, DL9000 series, SB5000 series, DL7400 series, DL1700E series, DL1600 series,
SL1400, and SL1000

2 DL750 series, DL9000 series, SB5000 series, DL7400 series, DL1700E series, DL1600 series,
and SL1400
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1.2 Basic Operations Performed From the Startup Windows

Explanation

Types of Viewer Window
There are five types of viewer window:
¢ Main waveform display window: Displays all of the loaded waveform data.

e Zoom waveform display window: Zooms the loaded waveform data.

History waveform display window: Displays all the waveform data records obtained
by means of sequential store, single (N) trigger mode, and/or history feature.

X-Y waveform display window: Plots a channel (trace) in the main/zoom window as

suoneladQ oiseqg RN

an X-Y view.
* Measurement result display window: Measured values such as cursor

measurements, automatic measurements, and measurements through computation

are displayed as numerical values.

Main waveform display window History waveform display window
,. D:\Documents and Settings\Administrator\ Desktop)sampleW aveData)\2CHST (=
B [l vien snolysis window T

BEsES8 xm-|

B LA - = A z
[\ Triager Time: 2004710705 201 55,88 Wambe: of Data 10070 Al
@l Sanging ierval 10000 | "2 | ( o

25,000 f
{ f j\AAAAA~W
Il I

/

/

}

/.
i

—— Measurement result
— i o enn  display window

|
g

acH)
]

iy
1
1y

0000 20:13:43.35

25000

25000
FAYIIAY
FARTI A B
1CHY, fJ | 1’ ) / \ !” /H
¥ I 1 ] f
i h i Iy
! s 1l .
i

1
it i
0

26,000 v
No.0001 1.0011 5] 0.00020 ll
o0 Range
] s Csomeiny - f ﬂ sow ' | ¥ =] | e zom
Zoom Trigger Time: 2004/10/06 20:13:55.88 Nurnber of Data: 5007 P TH%QEV Time: 2004/10/06 2
Group1 Sampling Interval 100.00us Grogzmping Interval 100.00us
25000 25.000
ACH!
] L1 EHPE/]
%g SSS -25.000
4 No.0001
CHI L
™
-25.000
Nofioot 075060 [s] 0.25060
Kl 7 1| v
| )

7

o

|—Zoom waveform display window L X-Y waveform display window

Resizable Windows
By dragging the borders of the Xviewer toolbar, Controller window, and Viewer window,

you can change the size of the window arbitrarily.
Click Arrange on the tool bar to adjust the size of the Viewer window according to that of

the Xviewer toolbar and Controller window.

1-3
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Chapter 2  Displaying Waveform Data

21 Loading Waveform Data

1. Click = or select File > Open. The Open File dialog box appears.

Open E|®
Look in ‘@WaveDala j - £ B~
Y oo
3.3 AR ety
iy Fecent ‘ﬂﬂle_ﬂﬂﬂ
Documents ﬂsample-z_sk

T AHwingd_01_up
Aing4_0z_up
Desktop ﬂWingS_DI_UD
Awings_oz_up

ejeq wuojanepp Buikeidsiq NG

Fy Metwark File: narne: | j Open

Places

Files of type:

i m
YOKDGAWA waveform file [* wef]
YORDGAWA waveform file [* vdf)
AECI file [*osv)

Setting info [*.xrl)

Comment:

Mare Options

2. Todisplay a waveform, either select the file to open from the File name field, or
enter the name of the file and then click Open.

4., Viewer1 DiyDocuments and Settings',Administrator!Desktop!, SampleWaveData!, 2CHSINXY.WVF - [ TimeViewer] =10 x|
&8 File view Analysis Window =18 x|
EEET-EIEL:R

@A B WO S [ - | ] e

Main Trigger Time: 2004/10/06 13:34:2289 Mumber of Data: 10010

Group? 3 500.00ns

CHY

™
26,000
No.0000 - 2.5000m [s] 2.5045m

Ready
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2.1 Loading Waveform Data

When opening a file with comments:
With the DL series, when you open a file that has been saved with comments, those
comments appear in the Comment field of the dialog box.

Laok in: | = w402

L‘b

Iy Recent
Documents

De;ktop
74

by Documents

- e BerE

My Computer
My Metwork.  File name: IXY2_1 O0ER _‘_:J Open l
Flaces
Files of type: IYDKDGAWA warvefiorm file [*wef] Lj Cancel l
[ Comment: — r 1
2CVCLE SIN WAVE, C1,C3 C5:COMP, 10M5ps, Ims/div 100kpoinks | =

Ll
More Options

Comments are displayed here

When opening a file with voice memos:
With the DL750 series, when you open a file that has been saved with voice memos,
those voice memos can be played back.

Open 2K
Loak i ]C} wave _—__j & ﬁ Ea-
My Recent
Documents c
@ WOICE
‘@FLEM\.{OICE
Desktop ﬁpulse
!,@testL_GRlWVF
iy Documents
Iy Compter . .
Selecting a file that
.‘g has been saved with
— voice memos makes
My Metwark. — Fil : FOICE - 0 .
e ! = Lo Il ghis pull-down menu
Files of type: |OKOGAWS wavefom file (%) - Cancel active
—Comment: Woice
105%10 4EVENT DISPLAY |en0zj11/18 15:00:36. ———— Voice memos
" selectable
Mare Options

Stop playback of the selected voice
memo

Play back the selected voice memo

Nofte

If your PC does not have audio capabilities, the Play and Stop buttons are grayed out.
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2.1 Loading Waveform Data

Explanation

Types of Files You Can Open with Xviewer

File Type Extension

Measured waveform files saved on the DL1600 series, DL1700 series, wvf

DL1700E series, DL7400 series, DL750 series, SL1400, or WE7000

Measured waveform files saved on the DL9000 series, SB5000 series, SL1000, wdf

DLM2000 series, DLM4000 series, DL6000/DLM6000 series or DL850 series,
Files saved with the real-time recording feature of DL750 series, SL1400, SL1000 or
DL850 series

ASCII files saved on the DL1600 series, DL1700 series, DL1700E series, .CsV

DL7400 series, DL750 series, DL9000 series, SB5000 series, SL1400, WE7000, or
DLM2000 series, DLM4000 series, DL6000/DLM6000 series, or DL850 series

Display setting files saved with Xviewer xml

No

fe

To open a .wvf file, a header file (.hdr file) having the same name as the file you are trying to
open must be placed in the same folder.

Xviewer cannot simultaneously display waveforms that are captured with different
measurement intervals, memory partitions (blocks), trigger points, or other conditions. If you
attempt to load a file with waveforms that were measured under different conditions, an error
message is displayed and the file is not loaded into Xviewer.

Xviewer cannot simultaneously display the channels of waveforms measured with different
sampling intervals, record lengths, or other conditions. If you attempt to load a file with
waveforms that were measured under different conditions, an error message is displayed
and the file is not loaded into Xviewer.

Xviewer cannot load files with a trace name that includes a space. To load such a file, first
replace the spaces in TraceName in the header file (.hdr file) with underscores (_) or other
characters.

Regarding the timestamp (trigger time) displayed in the file open dialog box or on the
waveform screen when measured waveform files saved on DLM2000 series instruments of
firmware version 1.05 or earlier are opened by Xviewer.

In the case of waveform data having 1 history waveform, the displayed timestamp is the
measurement start time (when the RUN/STOP key on the DLM2000 series main unit is
pressed).

In the case of waveform data having multiple history waveforms, the displayed timestamp
differs from the time displayed on the DLM2000 series main unit.

IM 701992-01E
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2.1 Loading Waveform Data

Loading Multiple Files

A new Viewer window can be opened either by clicking the @ or selecting Window >
Viewer. Multiple Viewer windows can be open at the same time, allowing you to read and

display the contents of multiple files. When multiple Viewer windows are being displayed,

you can tile them by clicking the or M selecting Window > Tile.

Open a new viewer window
Tile the displayed viewer windows

Files that can be dragged
The files with the following extensions can be dragged from the load source window onto
the viewer window.
wvf, .wdf, .csv

Setting Options for Loading Files
Click the More Options button to specify supplementary options for loading a file after
selecting that file name.

Open PIx

Laok in: l 5 WaveData

x| c@meE-

Show or hide loading

My Fiecent Options
| N
My Metwork  File name: |2cHs Iy Bl ppen |
Places
Files of type: |YD KOGAWE waveform file [* vl wdf] _:J Clancel l

~Comment: —

—Prevent all waveform data
from being loaded.

¥ Open Mew File

|4 i u
List of waveforms in the selected file | — Open Mew File
|| IIS of waverorms in the selected tile = @ Clears the currently
| .

- File Contents displayed waveform data

i TraceMame | BlockNur I RecordLengthj Samplingnteral ! Date ALL OFF ! and loads new waveform

"%}CHI ] 12500 400.00ns 20070 data'

E)cHz s 12500 400.00ns 20070

Uncheck [TW1] the box to

load new waveform data
while keeping the current
waveform displayed.

W Trit, Current Setting

E

to the waveform data that you
want to load into the viewer

I
~Check the boxes corresponding Init. Current Setting

Clears the current display conditions (vertical axis scale,
waveform color, screen split, waveform parameters, and
computation settings) and loads new waveform data.
Uncheck the box to load new waveform data while
keeping the current display conditions.

24
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2.1 Loading Waveform Data

Loading Sequentially Numbered Files

Click either of the buttons shown below to load and display sequentially numbered files in
the folder containing the file you are currently viewing, switching the files in ascending or
descending order of file numbers.

Switches to the file whose name (number) is incremented by one
(i.e., 0000.wvf-0001.wvf-0002.wvf)

m erl D:Documents and Settings’ AdministratorDesktop'SampleWaveData', 2CHS.
Filg] _View Analysis  Window
EE@E@RE xm-
e@n-nEma s v B EEEEE

Switches to the file whose name (number) is decremented by one
(i.e., 0002.wvf ~0001.wvf-+0000.wvf)

Reference Files in the instruments
You can directly reference waveform data files saved into the media of the instruments
and which are connected to Xviewer. For details, see Section 8.3.

Automatically Loading Display Settings
Waveform data is loaded, the corresponding display settings are automatically loaded.
For automatic saving / loading of display settings, see section 5.5.

IM 701992-01E 2-5
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2.2 Displaying Waveforms in the Main View

Procedure

Explanation

Displaying Waveforms in the Main View
To display waveforms and measurement results, first open a waveform data file. To show or

hide the main waveform display window, click the or select Window > Main Window.

Main waveform
display window Show or hide the main waveform display window

D\Documents and Settings'Administrator\Desktop't ampleWaveData\2CHSINKY. WVF — [TimeViewer] 8 L= |
alysis Window -8 x|
&/ xm-|

50000ne

)
[

25000 o
No0DIO - 25000m 2] 25045m |

v
Ready [ o i 7

Details of the Main Waveform Display Window
The main waveform display window provides a global view of the waveform data.
r Number of Trigger position

the displayed group Section displayed in zoomed waveform
display window (enclosed by the bold lines)

Trigger time .
99 Number of points (record length)
by B =T
&8 Fie view Analysis Windey &l x|

cEsdE x|

LB w-t e mla ;\Jw-m-\ﬁ T Measurement
i Tiiqaer TimeCZU04/10/06 1334:22 85 Nurber ol Déaf | .
: o) 00,0005 = E=interval

oy AN SN

LENLIN SN s "
HCHA [v] R L1
th T —Trace name
i ARS AR VRS CARS vame]
_3 E00m ] @ I
e e — L = Time from a trigger
‘Zoom Trigger Time: 2004/10/06 15:34:22 83 Nurmber of Data: 4001 ]
Groupl 3 Sampling Interval: 500.00ns |4
25,000 i
— 3
wy, ><\ ><\ I
\><,_/ \\><b/ 1
25000 I
Ne.0000 998.5u Is] 1.0015m 1
= 5 i

L—— Scale values

Displaying Tooltips

If you place the pointer on the waveform for about one second, the information for that
point is displayed. For example, in the case of a time-voltage waveform, the time and
voltage are displayed. The information is displayed for the main and zoomed waveforms.
It is not displayed for history, XY, and logic waveforms.

CGHI
- 1.6945ms
G.6833W ik

2-6
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2.3 Displaying Waveforms in a Zoomed View

Procedure

Displaying Waveforms in a Zoomed View

Click the or @ select Window > Zoom Window to display a zoomed view of the
section enclosed by the bold lines in the main waveform display window.

Setting the Zoom Factor
To increase or reduce the zoom factor, click the m (Zoom-In) or m (Zoom-Out).

The section of the waveform enclosed by bold lines is

Zoom-In displayed in the zoomed view

Zoom-Out Show or hide the zoomed waveform display window
el m —iaix]
FERE JNETEY)
lef2za8 xm-| [
oL R IR () ==
%sﬂ:u 1021 Time: 2004710406 20:13.43.33 Number of D ata: ™= Sampling Interval: 100,000y
({000
”ﬁﬂmﬁﬁﬁAﬁﬁ%
4]
-5f 000
>.0000) 1.001100 E] -0.000200
&Im 000 ( somsja) If ur] s P
B e e AT Forker 03 (L) Semmmea s | NUMber of points
wow displayed
" is Q%ﬁi#&f&
-50.000
Ne.0000 0.694600 [s] -0.194500
L | | ]
Rastly | o 7
—Drag to move the section to zoom
—Double-click to show the Display Setting dialog box

— Select the number of points to be displayed

Moving the Zoomed-In Section
You can move the section to zoom by:

* Dragging the bold line
You can drag the bold line in the main waveform display window to move the
section to zoom. Use the arrow buttons to move it automatically.

* Designating a point in the Display Setting dialog box

You can double-click the bottom of the zoomed waveform display window to show
the Display Setting dialog box in which you can designate a point at which to start

the zoomed section display. Click OK to apply the point.
* Dragging the scroll bar

You can drag the scroll box at the bottom of the zoomed waveform display window

to move the section to zoom.

IM 701992-01E
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2.3 Displaying Waveforms in a Zoomed View

Explanation

Scrolling Zoomed Waveforms
* Arrow Buttons
To start scrolling, click 4 or P to specify the direction you want to scroll in.
e Stop button
To stop scrolling, click the [l .
To resume scrolling, click the 4 or P again.

Nofte

Waveforms cannot be scrolled during measurement of waveform parameters or computation.

=10l x|
=181 x|

iministrator!\Desktop\5ampleWaveData\ 2CHSINXYSW.WYF - [Tim

HS[xm-|
s B W B S 2| EE )
Number of Data: 10010

i Trigget Time: 2004 /10706 20134333
roupT Sampling Interval: 100.00ug

50000

S NN Qﬁtﬁyyﬁ%&& N
No. EI[IVE?[IEI o0 1.001100 18] -0.000200

Zoom Trigger T me: 2004710706 20.13:43 33
Broupt

Sampling Interval: 100.00us

o P NN

0000
NoOOOD 0535500 sl -0.035500

K| I B

Ready LI S

— Set the scroll rate using the control bar
—Select the scrolling direction or stop scrolling

Zoom Rate
The maximum zoom rate depends on the data being displayed. A view with 10 or fewer

points cannot be zoomed.
Scrolling the Zoomed Waveform View
The zoomed waveform view can be scrolled automatically.
Use the following buttons to select the scrolling direction and rate:
e Scrolling direction
D : Scrolls to the right
4 : Scrolls to the left
Il Stops scrolling
¢ Scrolling rate
Set one of the ten scrolling rates, from Slow to Fast.
Designating the Section to be Zoomed
To designate the point at which zooming is to start in the Display Setting dialog
box, specify the value of the left most point of the zoomed section that you want to view.
The values that can be specified vary with the zoom rate and displayed waveforms. ¢
 Inputting the number of data points: Input an integer to start display from that number
of data points.
» Inputting a time: In relative time display mode, input a real number to start display
from that time. At this time, m (10),
u (10°%), n (10°), and P (10" can be used.
(Example)
123> 1.23s
1.23m—1.23 ms
1.23E-3 > 1.23 ms
0.00123 - 1.23 ms
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2.4 Displaying Waveforms in the History View

Procedure

Displaying Waveforms in the History View
Click the or select Window > History Window to open the history waveform display
window.
Changing View Sizes
To change the size of the history waveform view, click any of the three Size buttons.
Size

o |71

Selecting the History Waveforms to be Displayed

To display all the history waveforms in the main waveform display window, click ON for ALL.
To display only the active history waveforms in the main waveform display window, click
OFF.

You can place a checkmark in the check box corresponding to individual history
waveform views to select specific history waveform views to be displayed in the main
waveform display window.

Making a History Waveform Active

To make a history waveform active in the main waveform display window, click the history
waveform view. The history waveform view is enclosed by blue lines and its history
waveform number is highlighted.

When other history waveform views are also displayed, the active history waveform view
appears brighter than the others.

— Change the size of the history
waveform view
Select whether to show all the views
F

Show or hide the history
waveform display window

or only the active view

. ViewerL. D:\Documents and Settings\ Administrator\Desktop\5ampleWd fimeviewer] ol
B8 Fie view Analysis swindow TS
E=2=sda xm-|
L@ -t plma| 2 2 - & - ||| I
Main_Trigger Time: 2004710706 201 Nunber of Dt 1001 0 Poze o~ /a1
Group ‘Sampling Intervat 100,001 @@
50.000 r
’QMM h AAARAAASR . .
TUTVUreyy Active waveform view
A AR A e =
- A WA Y \nnnn FxTer oo 5 15
Yo N N Y
[ VALY AV AT )
/\/\/\/\WN —History waveform
\ o/ display window
No. EI[I[ISWEI o 1.001100 [s] -0.000200 0002 20:14:04.46
&IM‘ 5000 ( s0msfdv) R LT B
oo Trage Tie 2000707 grber o Data 5007
e el el 00 o0us
50.000
4
ICH] ¥
4]
-50.000
Ho.0001 0.803200 Is] -0.309200
L — 0]
Resch o

— Show or hide the waveform view in the main window

Sample of minimum-size views

5z ———— Al
et = Y el

0003 10:13:49.11 §0004 10:13:49.15 §000S 10:13:49.19|
. C o il

ot

0009 10:13:49,35 0010 10:13:49 .39
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2.4 Displaying Waveforms in the History View

Explanation

Data That Can Be Loaded Using the History Waveform Display Window
The history waveform display window can display waveform records saved with the
sequential store, single (N) trigger mode, and/or history waveform handling features of
the DL series, SL1400, and SL1000.

Note

An error message will appear if there is insufficient memory.

Sizes of History Waveform Views
You can select one of three sizes for listing the history waveform views.

ALL ON/OFF

You can select whether to display all the history waveform views listed in the history
waveform display window in the main waveform display window:

ON: Displays all the history waveform views in the main waveform display window.
OFF: Displays only the active history waveform view.

Active History Waveform View

» Cursor measurements can be applied to active history waveforms.

» The waveforms of the active view appear brighter in the main waveform display
window.

» The number of the active view is highlighted in the history waveform display window.
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2.5 Displaying a Waveform in the X-Y View

Procedure

Displaying a Waveform in the X-Y View

Click the or select Window > X-Y Window to display the X-Y waveform display
window.

Selecting a Waveform to be Displayed in the X-Y view

To see a waveform displayed in the main waveform display window in the X-Y view, click
Main under Range.

To see a waveform displayed in the zoomed waveform display window in the X-Y view,
click Zoom under Range.

Setting the X-Axis

Select a waveform (trace name) to be assigned to the X-axis by using the X-Trace list
box.

All waveforms other than that assigned to the X-axis are allocated to the Y-axis.

Show or hide the X-Y waveform — Select a waveform (trace name) to
display window be assigned to the X-axis

ool kol acHsoo v ive- [ = |
J " ‘ JRET]
=& xm-

@0 p el s o] b o mEEE)E Eelgpt ? wa:j/gfotrrr]n to
gizD“vaggevame 200410706 20:13: 4339 Néﬁgii‘ﬁé?ﬁﬁvl\m\‘n”nnn., I ifP = ) .iﬂ“ e ISp aye In e
= )\Gain zoom |
s0.000 (R e znn;’l/winzmumsbgm X-Y view

5\ 000
AN
N AR VARTARN{A WA
STINTIA IATENIPNI RS IR PN S
i INIAVR TR \W\ \\ li /
H

o000 oy %E InnS e
HNo.0000 1.001100 Is] -0.000200 &E%
TR [ o = 4[] o A
Zoom Trigger Time: 2004/10/06 20:13:4333 ‘Number of Data: 5007
Group 5 ampling Interval 100.00us

50.000
"t o jn”nm T oHI ] 00000

-60.000
No.0000 0.703500 €} -0.203500
L ——— 2
o

‘— Waveform (trace name) assigned
to the X-axis and its scale

Waveform (trace name) assigned to the Y-axis and
its scale
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2.5 Displaying a Waveform in the X-Y View

Overlaying X-Y Waveforms

The active waveform in the history waveform window can be overlaid on the X-Y
waveform display window. If Range is set to Main, the waveform in the main waveform
display window is overlaid. If Range is set to Zoom, the waveform in the zoom waveform

display window is overlaid.

Display the X-Y waveform
in the main waveform display window

Select the history waveforms
and overlay the X-Y waveforms

I
orm ol o oel

0001 20135588 0002 20140446 | | T 20 0001 204 25588
Range ¥ Range
X-Tracelcm 'l |—|Main Zoam I 8 TraceICHl 'I |7|Ma\n Zoom |
R Trigger Time: 200410708 20134339 Mumber of Data: 10070 Hr Trigesr Time: 2004./10/06 20134323 Mumber of Data: 10010
Groupl Sampling Interval 100.00us Groupl Sampling Interval: 10000us
25,000 H H : 25.000 : : :
1GHS 1CHY
[
25000 : -25.000 : : : : : :
Mo, 0000 =25.000 MNo.0000 -26.000 CHT W] 26000

Nofte

* The X-Y waveform display window plots P-P data displayed in the main, zoom, or history
waveform display window into the X-Y view.

e The X-Y view of logic waveforms cannot be shown.
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2.6 Moving or Zooming Waveforms

Procedure

Moving or Zooming (Expanding/Reducing) the Waveforms Vertically

1. Click or select View > Waveform Vertical Zoom&Move.

2. Using the mouse, drag the waveform you want to move.

3. Click the waveform you want to expand. The selected waveform expands around the
clicked point. Right-click the waveform to reduce the waveform around that point.

Click this icon before moving a waveform
Drag a waveform to move it

|4, YiewerL C:Program Files' Yokogawa'\XviewersSample Data'DL7400' logic.vyf - [TimeYiewer] =1Ol x|

ejeq wuojanepp Buikeidsiq NG

& rie vien Arblyss Window 18(x
&= = @ xm- |

LB (BN ma vl D)o

Main Trigeer Naz2001702/24 200855 TWorfber of Data 1000 ol tereat 1000me o=

cursrt | cursorz | cursor Dift
3

i

90005
NoDOOD 0000 s 10000 s

)

— Left-click the waveform to expand
Right-click the waveform to reduce

Ready

Moving or Zooming (Expanding/Reducing) the Waveforms Horizontally

1. Click l_ or select View > Waveform Horizontal Zoom&Move.

2. Drag the frame or a point in the frame in the main waveform display window or the
zoom waveform display window.

3. Click on the main or zoom waveform display window to expand the zoom display
waveform around the clicked point. Right-click the waveform to reduce the
waveform around that point.

— Click this icon before moving or zooming the waveform
Drag the frame or a point in the frame to move it

|- Yiewer1 C:Program Files' Yokogawa'\Xviewer',Sample Jata'DL7400' logic.wvf - [TimeYiewer]
Fle Vien Analysk indow

> m-| |
s \%DEEII&MWFM'\ = E =
o R AR e T of Data 10010
& B Sampling Inerval: 50000ns
19628 [7FT T
o 19528
. . . . PN . . . . el
10HS |
o AR A Y
3037
_an 5818
NoODOD - 25000m & 26046m
|/V gt | Foo0 2 =] afm b | s e
Zoom Jreer Time: 2003710706 TO3F2208 b of Data 4007
ot Sampling Interval: 50000ns
1818 [T T
Ha e
AN S
U7/><\\ />’?\\
cHi . .
w S e

ATV
68186

-sates | .
NoOOOD - 21860m 5] - 1800
“

oAl

Ready

— Drag the zoom waveform display window to move it
Left-click on the zoom waveform display window to expand or
right-click to reduce
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2.6 Moving or Zooming Waveforms

Nofte

'@f or View > Waveform Horizontal Zoom&Move is selectable only if the zoom waveform
display window is displayed. For the procedure to display the window, see section 2.3.

Explanation

Applicable Windows
Move and zoom can be applied to the main or zoom waveform display window.
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2.7 Splitting the Screen

Procedure

Explanation

Splitting Waveforms by a Trace

Click the M| or select View > Split to overlap the waveforms in the main waveform
display window or zoomed waveform display window, splitting them based on the trace

name.

— View displayed according to
the split settings for the main

Turn the split view on or off waveform display window

=11

Bralysis Window 18|

IEEECEIEL::E

Loe(n)alp ma| s o h -k -| ) | e

EA'AH\ED‘T;[\IQ:ZTWE 2004/10/06 20:13: 5588 ‘Mumber of Data: 100 ’—SEEE‘ ’rg\m

T
Sartpling Intetvai 10000
aH) [Annn A
) \/LAA
50.000
20450

:\Documents and Settings\Administrator\Desktop\SampleWaveData\2CHSINKYSW.WYF - [

0000 20:13:43.39 0001 20:13:55.58

[V e—v Yy

Vg

- 0002 20:14:04.45
NoOD1 1001100 2] 0.000200

[S[an] Fo commr =1 «[m]p] s

Zoom Trigger Tme: 2008710706 20135568 Fumberof Data: 5007
o1 Sarpling Intervai - 100.00us

M gn000
- M o355
[Totom 0703500 1l 0203500

Ll — 2l
Resy )

—— Specified split settings

Split Settings

The default value for the number of split waveforms depends on the number of
waveforms that are automatically identified by Xviewer, and is used both for the main
waveform display window and zoomed waveform display window. The default value can
be changed using the split setting dialog box. Using this dialog box, you can specify
different split settings for the main waveform display window and zoomed waveform
display window or modify the default split settings. For details, see Section 3.3.

IM 701992-01E

ejeq wJiojaneps Buikedsiq H



2.8 Displaying Waveforms Acquired with the DL850
series Dual Capture Function

You can display the main and capture waveforms acquired with the DL850 series Dual
Capture function.

Procedure

Load data captured with the DL850 series Dual Capture function according to the
instructions in section 2.1, “Loading Waveform Data.” The main waveform is displayed.
Atriangle is displayed at the position of the capture waveform.

A triangle appears at the position of the capture waveform

EEFEERFEEEREEEED

Capture Waveform Display

1. Double-click the capture waveform mark, or click View > DualCapture List. The
dual capture list is displayed.

2. Double-click the capture waveform to display, or select it and click Capture. The
selected capture waveform is displayed.

Select the capture waveform to display

apture Mark List

Cagfure Mo, Poinks. Relative Time
211307 201041 o0
2

77995 2010/04/29 16:
544640 2010/04f23 16:

f
B11330 2010{04/29 16:36:14,405021
BIP97Z Z010j04/29 16: 071434
S44663 2010§04/29 16: 738343

EEE

CIick to display the selected capture waveform

Capture waveform

Appears when displaying a capture waveform

The “return to main waveform” icon

Returning to the Main Waveform

1. Click the “return to main waveform” icon, or click View > Return to main
waveform. The main waveform is displayed.

Explanation

You can link, analyze, and display the main and capture waveforms acquired with the
Dual Capture function.
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2.9 Switching between Groups

Procedure

Explanation

Switching between Groups
When you have already registered groups, you can switch between those groups either

by clicking the or .ﬁ‘ , or G;‘i by selecting View > Next Group/Previous Group.

Switch to the group whose number is one greater
than that of the current group

Switch to the group whose number is one less than
that of the current group

Sarmpling Intervat 100,001

50,000
] '
WCH1
o NS \/ \./\ 4
50.000
Mo.0001 1001100 5] -0.000200

2| Jsooo csomsian = dalr] sor
ARE] T csomsiam 5] e

comLgger Time, 2004710706 20-1355.68 Nunber of Data 5001
— Sampling Intervat 100.00us

50,000
CH1

ol o
Mo 0001 0.703500 Is] -0.203500

Ld | |

Ready

— Number of the group currently being displayed

Auto Group Setting
Click View > Auto Group Setting to open the screen below.
Enter the number of channels in a group.

Auto Group Setting

Mumnber of Channels in Group I 20

o4 I Cancel |

Grouping Channels

In the Channel Setting dialog box, you can be grouping by trace name. In addition,
the specified number of channels can be automatically allocated to a single group. For
details, see Section 3.2.

Nofte

If there are no groups, the Ii_rE and Gr’li are unavailable (no operation even if they are clicked).

Set Auto Group

Enter a value in the Number of Channels in Group box and click OK to automatically
assign the specified number of channels to a single group. For example, if you enter 30,
channels are assigned as follows: CH1 to CH30 to group1, CH31 to CH60 to group 2,
and so on. If you select the Initialize Channel Setting check box and click OK, channel
settings such as the ON/OFF condition of the display, scale, and waveform color are
initialized.

IM 701992-01E
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2.10 Showing Marks

Procedure

Explanation

Showing Marks
Click View > Show Marks. The marks are displayed.

e Viewer C:¥mark e wdf - [Time Viewer]

&8 File View Analysis Window B
BEsEE xmM-
W@ W -pSta-Od -6 @ | EE e &
Wap Trieer Time: 2009703708 (102460795 it of Data 4307
Grapl g Sampling Interval: 10000us
20000 [748%9%'?15 Sdiv]
LIPS
-20000
Ne0DOD 00000 5] 74386
/VR/E 10000 ( 100msfciv) - 4 |T >| Slow }7 Fast
Zoom Jrieeer Time: 2000704/08 081012460795 Tanber of Data 10007
Groupt Sampline Interval: 10000us
20000 i
TT00 Oms /] Mark displayed
ToHI o] \
\.___/
-20000
NeODOD 3219 42819
< >
Ready I HUM

Mark List and Jump

Click View > Mark list. The screen below appears. Select a jump destination, then click
Jump. The selected mark is displayed in the center of the zoom waveform window.

Select the jump destination

e x

Comment | Mo, ‘ Relative Time |
Markl 2844 0.28Ms
Mark2 22701 2.2701s
37519 3 5
Markg 52775 5.2775s

Marks 67603 b.7609s

EETE

L Executes the jump

Showing Marks

Marks are displayed when loading waveform data from mark files (extension: .mrk). Also,
you can display previously set marks in a list, and jump to any mark you specify. This
function is available with waveform data on which marks have been set using version 2.10

or later of the SL1000 acquisition software.
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Chapter 3  Specifying Display Settings for Waveform Data

3.1 Loading Display Settings

Procedure

Explanation

The display conditions specified on the current viewer window can be saved in XML
format. You can also include comments when saving the file.

If you load the display conditions that you created, the conditions are applied to the
current viewer window. For the procedure to create and save the display conditions, see
section 5.5.

Loading Display Settings

Click g or select File > Open to display the Open File dialog box. Select Setting info
(*.xml) in Files of type, browse to the folder containing your target file, select the name of
the file you want to open, and then click the Open. The display settings are loaded from
the file into the viewer window.

Select the folder containing your target file

_F 72X
Laook i |;‘) wave | j &= EF -

l)oLTs0
[LZIFleM
My Recent  4F pulse
Documents ooty criwe

&

@

Desklop

(&

My Documents

(“4_‘_1

fer — Select the name of the
file you want to open

My Compi

=

by Metwark. File name: ﬂ I&I
Flaces
Files af type: Setting info [".xml] LCE'|

Comment:

\ £
R
More Dptions

— Select Setting info (*.xml)

Application of Display Settings
Loading a Display Setting file already saved applies the display settings in the file to
waveform views. Chapter 3 Specifying Display Settings for Waveform Data.
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3.2 Setting Waveforms (Channels) to be Displayed

Procedure

Displaying the Channel Setting Dialog Box

Click ;.45 he or select View > Channel Setting to display the Channel Setting dialog box.
Using this dialog box, you can specify the display and group settings for the respective
channels.

Grouping Channels
You can group the channels (trace names) to be registered. You can handle waveform
display settings in units of groups.

Channel number
Select the tab corresponding to the group to be set up
Type in a name for the group

e

¥ Share channel setling in MainfZoom % Main Setting

[~ Copy Setting -
Copy rtem_] Copy ] Hasta J

OF l Cancel‘ Apply ] Mare Optionsl

L—— Channels (trace names) registered in the group

Setting Up Channels (Traces)
Set up the channels (traces) for each channel number. Click a trace name to display the
Channel dialog box, and then select a channel (trace name) from the dialog box.

Specifying whether to Show or Hide Waveforms and Cursor Measurement
Values

Specify whether to show or hide the waveform and cursor measurement values for each
channel number.

Setting Scales
Set the scale values for each channel number.

Setting Waveform Colors
Using the color palette, set the waveform colors for each channel number.

3-2
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3.2 Setting Waveforms (Channels) to be Displayed

Click the name of a trace to be displayed in the Channel dialog box,
and then select a channel (trace name) from the dialog box

Specify whether to show or hide the waveform

Specify whether to show or hide the cursor
measurement values

[V share| channel setting [v Main/Zooi: {5 Main Setting ¢ Zoom Setting Click to automatically

1t set scale values
Grl TII_II-IIIT-___H-I‘ according to the

Group Hane (TR0 amplitude
[ Dis|lay ONADFF |

Trefce

=
&

Using the color
palette, set a color
for the waveform

= o oo |t o e | e e | —

"Cnpy Setting

CDpyIteml Copy | Paste | K I (Zanct:ll Blphy | Mare Optinnsl

— Directly input scale values
— Place a checkmark in the box to specify scale values

— Select the check box to enable log scale
(only shown when the waveform to be displayed is FFT)

Specifying Waveform Mapping Manually

Click More Options to expand the dialog box.

For each channel, you can manually specify in which screen (when the viewer window
is split) to display waveforms using mapping numbers 1 to 16. Select the Mapping check
box, and then select the mapping number from the drop-down menu.

If you clear the Mapping check box, the manual mappings are not applied.

For example, if there are 4 splits and the mapping number is 10, the waveform is
displayed in the second screen from the top. When 10 is divided by 4, the remainder

is 2. This “2” indicates the second split screen. If the remainder is 0, the waveform is
displayed in the bottom-most screen.

Setting Notational Formats

Click More Options to expand the dialog box. You can specify how numerical values
are to be displayed and the number of digits to be used to indicate a numerical value in
the viewer window, as well as specify the display settings for the logic waveforms in the
fields.

Manually specify the mapping for

Specify how numerical values
the displayed waveform are to be displayed

Channel Setting, -
¥ hare channel setting in MainjZoom & Main Setti Zoor Setk

Displary ONIOFF__| 1
VWavetorn | Readout |On uta tType

- Specify the
“| number of digits to
be used to indicate
a numerical value

Disply || ormat
Decim|iPoint Lagic

Trace

- Copy Setting

o) T cancel | Apply

Specify the display settings for logic —
waveforms in the Bit Setting dialog box

Close Options

3-3
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3.2 Setting Waveforms (Channels) to be Displayed

Explanation

Channel (Trace Name) Settings Shared

Channel (trace name) settings are shared by the main waveform display window and the
zoomed waveform display window. The cursor measurement value is used as the main
waveform display setting.

To apply different channel settings to each of the windows, remove the check mark from
Apply Channel Settings in both Main/Zoom, place a check mark in Main Window or
Zoom Window, and then make the individual channel (trace name) settings.

Number of Groups and Number of Channels (Traces) that Can Be
Registered

Xviewer lets you create up to 10 channel (trace name) groups. You can register up to 90
channels per group.

Setting Items to Copy and Paste

Xviewer lets you copy the settings for a channel (trace) selectively and then paste those
settings to another channel. After pressing the Copy Item to display the Select Copied
Iltems dialog box, you can define the setting items that you want to copy in advance.
The Select Copied Items dialog box is also displayed when you execute a paste
command,allowing you to remove any unnecessary setting items and paste only those
which are required.

— Select (or deselect) a channel number Select Copied Items dialog box

g

{* Main Setting

¥ share channel setting in MainfZoom

Copy ltem Setting

[ Trace

~ Display -
L] v waveform v Readout
i-gca.l;a
v on v Min V' Max
I Color
i Display Format — —
|| Format Type | Decimal pain | Logic
oK l Cancel j

[~ Copy Setting

Cop Itami Copy ‘ Paste ]I (814 ] Cancel] Apply ‘ Mare Options

— Paste the copied setting items to the selected channel
L— Copy the setting items from the selected channel
— Select the setting items to be copied using the Select Copied Items dialog box
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3.2 Setting Waveforms (Channels) to be Displayed

Changing All Settings Together
The Channel Setting dialog box provides buttons that allow you to select and change all
the settings together.

Select or deselect all the channels

¥ Share channel setting nMaiiZoom  © MainSetting  ©

Displery OHIOFF =3 Display Format

Trace

wavetorm | Readout | On Min Auto DecimalPoint Lagic

Apply the settings
for the channel at
the the top of the

o column to other

selected channels

Copy Setting

Copy Ttem | Copy J oK cancel | | apply Close Optians

— Restore all the settings for the selected
channels to their initial values

— Turn the settings for all the selected channels on or off together

Notational Format Items
You can specify the following notational format items:

* Format Type:

* Decimal Point:

* Logic:

Select Auto Floating Point , or Exponential

Selecting either Floating Point or Exponential causes the following
data to be displayed in the viewer windows, using the selected type of
notation:

Scale Values, Values of Cursor Measurement, and Waveform
Parameters (Amplitude Maximum, Minimum, High Level, Low Level,
Peak to peak value, Average, Middle, RMS, Int1TY, and Int2TY)
Specify the number of decimal places to be displayed for both the
floating point and exponential notations.

Specify the display settings for the logic waveforms in the Bit Setting
dialog box. Specify to display up to 32 bits for the DL9700 series, and
SB5000 series, up to 16 bits for the DL9500, DL750, and SL1400
series, and up to 8 bits for the DL7400 series DLM2000 series, and
DL850 series.

Bit Setting — Groupl

it e n

Bitl
Bit?
Bitd
Bit4
Eith
Bith
Eit?
Eitd
Eitd

m
=
=
&
=
&

“‘

Bit10
Bit1l

o o o

k|
o
=
&

i o

°‘|“‘|‘|1

Display the bit name
Displayed when bit names are specified in the loaded
logic waveform

Place a checkmark against those bits that are to
be indicated

Select whether to display those waveforms that align only
with turned-on bits at regular intervals (waveform view
=3} changed), or those waveforms that align with all the bits
(waveform view unchanged) if any bits are turned off in the

dialog box.
— Display the logic waveforms using the entire window

yaup |— 1 Display logic waveforms in the upper half of the window
LzLaw — Display logic waveforms in the lower half of the window

Bi: Display Order,__ Set the order in which the bits are displayed:
MsE - LSE MSB: Displays the bits from the most significant bit
ErEerar— LSB: Displays the bits from the least significant bit
snary  Hex— 1 Display format of the values displayed in the
PR measurement result display window
[Hon  Low | Binary: Displays values in binary.
— Hex: Displays values in hexadecimal.

Bundle — Set the highlight display of logic waveforms.
High: Highlight the high level.

=1
=

ﬁ
5
&
2
g
5

Cancel

Low: Highlight the low level.

— Display the logic waveforms in bus format

IM 701992-01E
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3.2 Setting Waveforms (Channels) to be Displayed

Cursor Data Display Method (Measure Result)

The measured values can be displayed in binary or hexadecimal notation.
Binary: Displays values in binary notation.

Hex: Displays values in hexadecimal notation.

Bundle ON/OFF Setting (Bundle)

If you set Bundle to ON, the data of each logic probe (PodA, PodB, PodC, and PodD)
can be combined together into up to 32-bit data and processed. If an OFF bit is present,
the bit is displayed as a hyphen in binary display. The bit is considered to be not present
in hexadecimal display.

Cursor Data Order (Bit Display Order)

You can select the order of the bits of the logic probe. Select MSB to select bit 7 to bit
0 order; select LSB to select bit 0 to bit 7 order. In addition, the displayed order and
number vary depending on the model as follows:

DL750 Series DL7400 Series DLM2000 Series

Bit Setting — LoeicA/B

DL850 series DLM4000 Series
] Bit Settine — Loeic (L}

Location Location Locatian
11 1j1 11
1izUp 1f21p == 1fz2Up
1/2Laow 1zLow | = 1fzLaw
Eit. Display Order Bi: Display Order B | Git Display Crder
MSE LSE M5B L5B — M5B L5E
Measure result Measure result [ [ Measure result
Binary He:x Binary Hex Ll | Binary Hex
"
Activelevel = | Activelevel = | Activelevel
[High Law (High Law | F=n | Hih | Law
»
Bundle Bundle i Bundle
[
1) L7}
Cancel Concel

DL9500, DL9700, SB5000 Series
DL6000/DLM6000 Series

Bit Setting - Groupl

Bit =l Biti7 [l ~Location
Bit2 5l eitis = 1t
Bits =l Bitia = WAL
Bitd =l Bit2o "
BitS =l Bit21 = iy
Bitd = Bitz2 Bl=R Eilt Display Order
Bit7 [ gitza e

= — |
Bits =l Bit24 = =N
Bitd (2| Bit25 L Measure result
BitI0 =0 Bit2s Gl [orary  Hex
Bitll =l itz = :
. = 0 Activelevel
Biti2 =l Bit2a =
BiLz |0 =0 Bites o | o Low
I = =l Bitso =
BitlE | =l Bital = Bundle
Bit1E |l =0 Bitaz [=

o o
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3.2 Setting Waveforms (Channels) to be Displayed

Cursor Measurement Example (for V Cursor)

Cursor 1 Cursor 2
0 |
L I —
2 [ I L [

S B I I Oy Y s Y O B IO B
s Uy yuwyyuy o
s L [
6 L L LI
i

For the case above, if the data bit order is A0 to A7 BO to B7
Binary Y1:01001010 Y2: 10110010

Hexa Y1:4AY2: B2

If B7 to BO A7 to AO

Binary Y1:01010010 Y2: 01001101

Hexa Y1:52Y2:4D

If OFF bits are present, the data is displayed as follows:

Cursor 1 Cursor 2

0 |
L

s_ [ Ly
s Uy uyu

6 [ L LI
7 1L | A I

If AO to A7 BO to B7

Binary Y1:01*01*10 Y2: 10*10*10
Hexa Y1:16 Y2: 2A

If B7 to BO A7 to AO

Binary Y1:01*10*10 Y2: 01*01*01
Hexa Y1:1AY2: 15

Note

If Bundle is set to ON, the individual bit displays cannot be turned OFF.

*  When a waveform that has been saved in roll mode without any waveform data is displayed,

logic waveforms are displayed as all zeros.

*  When a waveform that has been saved on the DLM4000 with STATE set to ON and with

state source bits selected is displayed in Xviewer, all bits are displayed as state source bits.
» The waveforms of logic A and B (8 bits each) of the DL750 are displayed as a single logic

waveform (16 bits) in Xviewer.

IM 701992-01E

3-7

eleq wJiojaAep) Joj sbuneg Aejdsig BuiApoadg H



3.2 Setting Waveforms (Channels) to be Displayed

Apply Button for Confirmation
Clicking the Apply after you have changed the settings applies the previously specified
settings to the window(s) while keeping the display setting screen displayed.

Note

If you double-click the scale display area of the vertical axis, a channel setting window (simplified
version) appears as shown below.

On this window, you can turn OFF the display or set the scale for channels that have been
turned ON in advance on the channel setting window of page 3-2.

When the displayed When the displayed When the displayed
waveform is FFT waveform is not FFT waveform is logic
Channel Setting g| Channel Setting g| Channel Setting g|
Channel: - Channel: - Channel: |§E C_01 Jhd
Iv Display v Cursor Iv Display v Cursor Iv Display v Cursor
Color C 1 Color C 1 Color (|
Scale Scale Scale
" log | OMN  Auto [7 0N Auto r
Max Maz: Max
Min Min: Min
Logic

3-8
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3.3 Specifying Split Settings

Procedure

Explanation

Displaying the Split Settings Dialog box

Click ¥ beside the or | select View > Split Setting to display the Split Setting dialog
box.

Specifying Split Settings

In the Split Setting dialog box, specify whether to allow the main waveform display
window and zoomed waveform display window to share the split settings and the number
of waveform splits in the respective windows, and then click OK. The split settings that
you have specified are applied to the window(s).

Split Setting

— Select the number of waveform splits in the main
waveform display window

Split number of Main window:

Split number of Zoom window:

1 Select the number of waveform splits in the zoomed

waveform display window
Ok | Cancel |

- Place a checkmark so as to make the main waveform display window and zoomed
waveform display window share the split settings

Number of Waveform Splits that Can Be Specified

For each of the main waveform display window and the zoomed waveform display
window, you can specify Auto or any value between 1 and 16. Auto sets the number of
waveform splits according to the number of waveforms to be displayed.

Waveform Mapping

When the screen is split, waveforms are mapped in order of channel number, starting
from the top-most split screen. You can also specify arbitrary waveform mappings. For
instructions on specifying arbitrary mappings, see section 3.2.

Split Settings for the History Waveform Display Window
Split settings made for the main waveform display window are also applied to the history
waveform display window.

IM 701992-01E
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3.4 Specifying Display Settings

Procedure

Displaying the Display Setting dialog box

Click ! or select View > Display Setting to open the Display Setting dialog box.
Click the Graticule, Horizontal Axis, Color, Size, and Other information tabs, and
configure the display settings.

Making a Graticule Setting

Click the Graticule tab in the Display Setting dialog box. The Graticule pane appears.
Using this pane, you can specify the graticule type and the units of the divisions on the
vertical axis.

Select the type of graticule

i

Graticule ] Horizontal.ixis] Calor ] Size ] Dther informatinnl

[ | Wertical divizgion number:
10 i Select the vertical
division units
SupplermentaryGrid:
Auto hd; Shows/Hides the
supplementary scale

of the vertical axis
(selectable only for FFT)

Cancel | |

= ]

Setting the Horizontal Axis

Click the Horizontal Axis tab in the Display Setting dialog box to display the Horizontal
Axis pane. Using this pane, you can specify the point at which to start displaying the
zoomed section, as well as the notational format for the horizontal axis.

Selects the horizontal scale (selectable only for FFT)

Graticule  Horizontal [Asis lEoIor ] Size ] Dther informatinnl

Select the type of the time
notation to be shown on
the horizontal scale

Relative time:

Display Format Time relative to the trigger point

e ]

Time

Relative Time =]

Absolute time:
Time of the measurement
(unselectable when the
duration of measurement
time is 1 second or less)

the zoomed waveform display window

Zoom Start Pozition Decimal paint:
B T Select the number of
digits to be used for
£2500 the time indication
ok | Cancel | |

— Specify the point at which to start displaying the zoomed section in

3-10
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3.4 Specifying Display Settings

Setting the Colors

Click the Colors tab in the Display Setting dialog box to display the Colors pane. In this
pane, you can specify the colors for the background, graticule, and text using the color

palette.

Sets the color of the text

Graticule] Horizontal i Colir lSize I Other infnlmatinn]
Background Graticule |
Text l Cursar il
w/nd Back |
E———
| | IMIT.
alf. | ILancel Apply

L— Inverts the color tones.

Sets the background color for the waveforms

Sets the colors of the
graticule and the divisions

Sets the color of the
cursors

Sets the background
color of the windows

— Restores the color settings to the defaults

Also available in the Viewer window tool bar.

A Wiewer1 C:\Program Files\YokggawalXviewer\iy

File Wiew  Analvsis  Window

I-_.-j.zlir'u Trigaer Time:

Setting the Waveform Thickness and Grid Line Thickness
Click the Size tab in the Display setting dialog box to display the Pane for setting the

waveform thickness and grid line thickness.
Display setting E|
Graticule] Horizontal.t’-‘-.:-tisl Color  Size lDther infnlmatinn]

Line width

Wave

e =

l

Grid

Tpr =1

(o |

Cancel |

Select the waveform thickness
(1 to 6 px)

Select the grid line thickness
(1 to 6 px)

3-1
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3.4 Specifying Display Settings

Explanation

Displaying Scale Information in the Waveform Display Window

Click the Other information tab in the Display setting dialog box to display a panel for
setting the T/div, V/div, O Level, Bit Label, and multiple vertical scale display settings.
Select the check boxes of the desired items to display the corresponding information in
the waveform display window.

Display setting f'5_<|

Graticule] Horizontalhxis] Calar ] Size  Other infarmation l

I Display TAdiv
I Display ¥Adiv
¥ Dizplay 0 Lewvel
Iv Dizplay Bit Label

¥ Dizplay all vertical scale valus

ok | Cancel Apply

Nofte

You can also double-click the scale display area of the horizontal axis to open the Display
Setting dialog box.

Setting the Grid

Supplementary Grid

The supplementary grid can be selected only when the FFT computation waveform is

displayed.

Auto:  Automatically determines whether to display the supplementary scale on the
vertical axis.

ON: Displays the supplementary scale on the vertical axis.

OFF:  Does not display the supplementary scale on the vertical axis.

Setting the Horizontal Axis

Display Format

Sets the time type (relative or absolute) and the number of displayed digits. However,
the Display Format settings do not appear when the FFT computation waveform is
displayed.

Zoom Start Position

When relative times are being displayed, the settings vary depending on whether an
integer or a real number is input.

Integer input: Start data position

Real number input: Start time (auxiliary units m, n, u, and P can be input.)

Scale

Set the horizontal scale to LINEAR or LOG. The horizontal scale can be selected only
when the FFT computation waveform is displayed.

IM 701992-01E



3.4 Specifying Display Settings

Setting the Color

You cannot change the waveform colors in the Display Setting dialog box. To change

colors of the waveforms, use the Channel Setting dialog box. For details, see Section 3.2.

+ Changing the color tone
Clicking the Color Set button makes the appropriate color settings for monochrome
printing. To restore the color settings, click the Color Set button again.

« INIT.
Initializes the color settings to the default condition.

T/div, V/div, and 0 Level Display
You can display T/div, V/div, and 0 Level in the waveform display window. The values of
the selected items are displayed. If multiple waveforms are displayed in the waveform
display window, the V/div and 0 Level of the active waveform are displayed.

— Display V/div

— Displa

y 0 Level

— Display T/div

[
14287

-

_C e D
000v/div] 4

G
¥

W Treaer Tme 2004

70706 15342280

Tamber of Data: 10070
3

Sampling ntervat_£|i000ns

>_

=V

L~ N\

VAV AV

(Bovausseivl

K

D

\v4

\Vav4

\VAN

-3762
NoDODD - 25000m

Displaying the Bit Label
You can display the bit names of the logic waveform in the waveform display window.

Displays the bit names

28046m

Tan
Graup

2

Fee:| Time: 2007707770 14630847

Timber of Data 125000

Nroup!

"Grom2
P2 |a:

WGroups

Note

You can change the T/div character size.
Click the T/div value, and then drag any of
the four corners of the displayed frame.

00 4ussdiv
b/

(Not available in Annotation mode. For
information on Annotation mode, see
section 4.7.)

If the display area of the waveform display window is narrow, the bit label is not displayed.
Carry out the following to display the bit label.
Drag and expand the waveform display window vertically.

.

.

Reduce the number of screen divisions.

IM 701992-01E
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3.4 Specifying Display Settings

Displaying the Multiple Vertical Axes
If multiple waveforms are displayed in the waveform display window, the range of the
vertical axis of each displayed waveform can be displayed.

Displays multiple vertical scales

Toom Treesr Time: 10| R 10372285 Timber of Data: 4007
oup 3
3

(0

Ho 28000 v

oK1 0|

Nofte

Multiple vertical axes are not displayed if only a single waveform is shown in the waveform

display window.

Checking the Changed Settings

Clicking the Apply while you are changing settings applies the settings you have already
made for the window(s) to the waveform display, without closing the Display Setting
dialog box.

Note

The Supplementary Grid of the Graticule tab and the Scale of the Horizontal Axis tab can be
set only on Xviewer with the computation option if the horizontal axis unit is Hz.

314 IM 701992-01E



3.5 Turning Waveform Interpolation On and Off

Procedure

Explanation

Turning Waveform Interpolation Off
Click View > Waveform Interpolation > Off to disable interpolation between sampled
data points. Waveforms are displayed using dots.

4 Wiewer1 H:\Documents and SettingsispdciDeskt
m File BUEEN Anakysis  Window

= & v Toobar
v Status Bar

i 23 v Analysis Bar [
v ‘Window control Bar

Channel Setting. ..
Display Setting...
Split Setting...

v Split

Form Inkerpolation Off —| Disable waveform interpolation
v Line Enable waveform interpolation
bl P

Waveform Yertical ZoomBdove

Turning Waveform Interpolation On
Click View > Waveform Interpolation > Line to display linearly interpolated waveforms.

Waveform Interpolation

In interpolation zones in the T-Y waveform display,” Xviewer can display waveforms by

interpolating between sampled data points.

* Interpolation zone refers to the condition in which a given number of data points are
not contained in the 10 div along the time axis. The number of data points that causes
the interpolation zone condition to occur varies depending on the display record length
and zoom ratio.

o Off
Interpolation is disabled, and waveforms are displayed using dots. This mode makes it
easy to view the actual data positions.

[2.000rs/div]

e Line
Linear interpolation is performed between two points.
. [2.0000ms/div]

Notfte

When waveforms that have been saved with P-P Com ON are being displayed and waveform
interpolation is turned off, only P-P compressed values (the maximum and minimum sampled
data values per given period) are displayed.

IM 701992-01E
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3.6 Initializing Display Settings

Procedure

Explanation

Executing Initialization
Click File > Initialize Viewer to return display conditions to their initial settings.

- Wiewer1 C:\Program FilesyY|
E_ File Wiew Analysis  Window

E  Open.. Chrl+O
- Open Mext File
4 Open Previous File

Save As... Chrl+5
Close

Print... Chrl+P
Print Previgw. ..

Prink Setup...

Print Format. ..
Creake Report,.,

1 'Wing5_01_up
2 BCHSIMEY
3 Wing4_01_up

Tnitilize % Execute initialization

1 & Undo initialization

Undoing Initialization
Click File > Undo to restore the settings prior to the initialization.

Initialization

Returns various kinds of specified display conditions to the settings immediately after
loading the waveform data. This is useful when you wish to cancel all settings previously
entered, or wish to reenter settings from the beginning.

Undoing Initialization
If you use the Undo command, the settings prior to the initialization are restored.

Initialized Items

The main items initialized are the following.

»  Waveform color

» Color of the background, text, graticule, cursor, and window background

» Vertical axis scale values

» Logic signal display bit

* Number of screen divisions

» Sizes of windows

» Displayed windows (two: the main waveform display window and measurement result
display window)

* Zoom position and zoom ratio

* Graticule type

* Hand V cursor positions

* Horizontal and vertical axis display format

* Waveform parameter measurement items

» Computation filter, number of FFT computation points, time window, and user-defined
computational expressions

+ Deletion of all annotations

3-16
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Chapter 4  Analyzing Waveform Data

4.1 Displaying Measurement Results

Procedure

Displaying Measurements in the Result View

Open a waveform data file for which waveforms and measurement results are to be
displayed. To display or hide the measurement result display window, click the |[Eg
select Window > Measure Result.

or

Display or hide the measurement Measurement result
result display window display window

.. ViewerL D\Documents and Settings\ Administrator\Desktop\ sampleWaveData\{ FHSINXYSW.MVF - [Timeview: —iolx|
&8 File View Analysis Window 18 x|

el & xm-|

Hain Trigger T me: 2004710706 201 Nurmber of Data. 10070
Groupl 100,00

50000

aH)
4]

50000 I
NoOODT 1001100 sl ano0z200 | {1

Ready

Explanation

Items and Measured Values That Are Displayed
The items and measured values that are displayed depend on the measurements and

waveforms.

Reference to Cursor Positions

The positions of the cursors are indicated using either of the references below, according

to the notational format of the horizontal axis:

» Absolute time: The positions of cursors are indicated as absolute times.

* Relative time:  The positions of cursors are indicated as being relative to the trigger
position.

Note

When the measurement results display window is not displayed and you execute cursor
measurement, automated measurement of waveform parameters, automated measurement
of history statistics, or automated measurement of cycle statistics, the measurement results
display window will automatically appear.

IM 701992-01E 4-1
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4.2 Analyzing Waveform Data Using Cursors

Procedure

Analyzing Waveform Data Using Cursors

Choose Vertical Cursor from the M icon drop-down menu or choose Analysis >
Analysis Mode > Vertical Cursor to display two vertical cursors in the main waveform
display window and the zoomed waveform display window.

The measurement result window displays the cursor positions (time) and measured
values as well as the difference in the time and measured values between the cursors.
You can drag each cursor. You can click within the window to move Cursor 1 to that
position. Likewise, you can right-click within the window to move Cursor 2 to that position.

Make vertical cursors active
Cursor 1 (drag to move)
Cursor 2 (drag to move)
AR 1) — =il ngicates the position

JNETES]
1 of the cursor
e zﬁ/‘wﬁmsa‘uzxs © '&Mu = m’?\n - Differences in time

|
T Sompling Iry/fval: 50000ns [EE
- : ; - Z=cam| between Cursor 1
1 i %’.@4 :| and Cursor 2

. U w w W X/ Differences in

measured values
-25.000 15
Mo.0000 25000m Is] 25045m |5

between Cursor 1
and Cursor 2
%yDSDE;YIQgEYTWE 2004/10/06 19:34:22. 83 Mumber of Data: 4001

ments and Settings\Admil istrator\Desktop\ SampleWaveData\2C!

=
IEEEI" S E

Measured value on
Cursor 2
(intersections of
Cursor 2 and
waveforms)

Sampling Intervat 50000n |

25000

acH , , 4 ><.\< , ; ]
™ 1 m
-25.000 \ 1 1
NoDODD 120 il 2mz0m [
K| | — ]
Ready

\—Cursor 1 \—Cursor 2

Measured value on
Cursor 1
(intersections of
Cursor 1 and
waveforms)

Analyzing Waveform Data Using Horizontal Cursors

Choose Horizontal Cursor from the E icon drop-down menu or choose Analysis

> Analysis Mode > Horizontal Cursor to display two horizontal cursors in the main
waveform display window and the zoomed waveform display window.

The measurement result window displays the measured value at each cursor.

You can drag each cursor. You can click within the window to move Cursor 1 to that
position. Likewise, you can right-click within the window to move Cursor 2 to that position.

Make horizontal cursors active
Cursor 1 (drag to move)
Cursor 2 (drag to move)

flroveontozcmrtsw o~ [imencwerl S
N

d Settings)Admiffistrator\Desktop\samp}

&|xm- PR
A5 wa 2 L= - 8]

e Time: 2004 /10706 0.12.43.33 Number ;//Data: 10010

50000

IV WA
AR AYRIAY

ok v

[Cas: )@ Differences in

& measured values
between Cursor 1
and Cursor 2

Measured value on
Cursor 2
(intersections of

50,000
NoOOD 10011000 3] 0.0002000

Zoom Trioger Time: 2004/10706 20:1343.39 et of Data: S00T =
Groupt I

Sampling Interval: 100.00us Cursor 2 and

sa0m 1 waveforms)

o, WV VANV aN Measured value on
Cursor 1

- (intersections of
No.0000 0.5487000 €} 00487000
L1 | % Cursor 1 and
sty L4 waveforms)

Cursor 1 Cursor 2
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4.2 Analyzing Waveform Data Using Cursors

Explanation

Analyzing Waveform Data Using X-Y Cursors

Choose X-Y Cursor from the 4 | icon drop-down menu or choose Analysis > Analysis

Mode > X-Y Cursor to display two vertical cursors and two horizontal cursors in the

X-Y waveform display window. You can move a cursor by dragging it. The measurement
result display window displays the measured values at the cursor positions at that time,

as well as the differences in the measured values.

Select a waveform (trace name) assigned to the X axis
Make the X-Y cursors active

— Waveform (trace name) assigned

Vertical —‘ Vertical to the X-axis
cursor 2
s

. cursor 1 Measured value on

J[=[F .

Za| vertical cursor 1
Measured value on
vertical cursor 2

Fes@&|xm- |
B - pmE| (@) 0 mEEaE

o
[ [ z00m
0 Trigger Time: 2004/10706 15::{3.22.83 Nurber of Data: 1001
Groupl Sampling Interval: 500.00ne

2000

/

25000 :
o000 -2500000Y EAT 2500000
Resdy

L Horizontal cursor 1 — Waveforms (trace names)
Horizontal cursor 2 assigned to the Y-axis

Show waveforms assigned to the Y-axis

%~ Differences in measured
values between vertical
cursor 1 and 2

Differences in measured
values between
horizontal cursor 1 and 2

Measured value on
Cursor 2
Measured value on
Cursor 1

Analyzing Waveform Data Using H&V Cursors

Choose H&V Cursor from the [ = icon drop-down menu or choose Analysis >
Analysis Mode > H&V Cursor to display four cursors (two vertical cursors and two
horizontal cursors) in the main waveform display window and the zoomed waveform

display window. The measurement result window displays the measured value at each

cursor and the differences between the measured values between the cursors.

Cursor Measurements on History Waveform Views

When you are displaying history waveform views, only the active waveform view can be

used for measurement using the cursors.

Linking of Vertical Cursors or Horizontal Cursors

If you drag a vertical cursor or horizontal cursor while holding down the Ctrl key, the two

vertical or horizontal cursors can be moved simultaneously.

IM 701992-01E
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4.2 Analyzing Waveform Data Using Cursors

*** Indication
If the measurement result is invalid, ““**” is displayed as the measured value.

Note

You can copy the contents of the measurement results display window to the clipboard.
Specify the range to be copied, press Ctrl + C, then the measured results are copied to the
clipboard. The following methods can be used to specify a range.
» Press Ctrl + C without specifying a range to copy:

All contents in the measurement results display window are selected
» Click Trace:

All rows are selected except for the data at the cursor.
» Click the trace names of the items to copy:

The trace name row that you clicked is selected.

— Selects all rows except the cursor information.
Click once again to clear the selection.

0
-1.00110

If no range is specified,
0 all are copied.
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4.3 Automated Measurement of Waveform

Procedure

Setting Items That Are Automatically Measured

1. From the ff'-% drop-down menu, select the Wave Parameter. Or click Analysis >
Waveform Parameter Settings > Wave Parameter.

Hu- YWiewer1 H:\Documents and Settings\s pdci\Desktop\Sample\wave. WVF
n File Wwiew Analvsis window

FresEHE X O-
wi B |- B 5 "4 - &

The icon changes
according to what you select.

ﬁ;ﬁk : Wave Parameter
ﬁ - History Statistics

E.".H : Cycle Statistics

Analysis Mode
‘“Wave Parameter Settings  # ‘“Wave Parameter...,
Math Setting. .. Hiskary Skatiskics. ..
Cycle Statistics, ..

ejeq wuojanep BuizAjeuy BN

The Waveform Parameter Setting dialog box appears.

2. Inthe Waveform Parameter Setting dialog box, set the measurement items and
the conditions for displaying measured results, and then click OK.

Names of items to be measured
Select or deselect the item

avetorm{Parameter setulp =

———— (@)1 ooy wzcenetnize——— Place a checkmark to
ot i

T i - R allocate traces to the

Hop vl Firke vertical axis in the

Voltage measurement | [
items | o= )

measurement result
display window

Overshaot

— Select the number of rows
to be used to display
measured values
(allowable range: 1 to 28).

Plus widtn

Time measurement | [imwm
items

Start automated measurement

Area measurement
items

[ox | coneal |

Automated measurement starts. Two vertical cursors are displayed in the main waveform
display window, and the measured results of waveform parameters are displayed in the
measurement results display window.

IM 701992-01E 4-5



4.3 Automated Measurement of Waveform

Specifying the Automated Measurement Range
You can change the range over which to perform automated measurement of waveform

parameters. Drag the two vertical cursors to change the measurement start point and the
measurement end point. Waveform parameters are remeasured.

Operations in the Waveform Parameter’s Automated Measurement Screen

Ve

B l-—— (-
v Wave Parameter

Hiskary Skatistics
Cycle Skatistics

Settings... — Displays the Waveform Parameter
Setting dialog box

Stop automated measurement of waveform parameters

~N

Gl

Click again to start automated measurement

—— Measurement results

display window

2000
|

HeDOD 4000000 1]

.-unuu.iu{\i.i.uﬂ

|~ Cursor positions
= — Time difference between

cursors

— Measured results

— Measurement items to
measure automatically
(set in the Waveform

“vomase

Parameter Setting dialog
box)

Measurement status

Measurement
range

Measurement
start point cursor

\

Measurement
end point cursor
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4.3 Automated Measurement of Waveform

Explanation

Items that Can Be Specified
On the waveform parameters, you can set and measure voltage, time and area items.

Nofte
*  When the scope to analyze includes two cycles or more of a waveform, time-axis
parameters are analyzed only for the fist cycle.
* An FFT computation allows to make measurement only for Max and Min.
* No logic waveform can be automatically analyzed.

* \Voltage measurement items

Maximum: Maximum voltage [V] Average: Average voltage (1/n)Zxi [V] 4
Minimum: Minimum voltage [V] RMS: Root-mean-square value (1/+/n )(Z(xi)2)"2 [V]

High level: High voltage [V] Middle: Mean value for amplitude (Max + Min)/2 [V] >

Low level: Low voltage [V] Standard deviation: Standard deviation (1/n(2x2 - (£x2)/n)"2 5

Peak to peak value: P-P value (Max - Min) [V] ~ Overshoot: Amount of overshoot (Max - High)/(High - Low) x 100 [%] O

Amplitude: Amplitude (High - Low) [V] Undershoot: Amount of undershoot (Low - Min)/(High - Low) x 100 [%] ﬁ

,,,,,, L 5

; i\\/_ J Max - High Level Q@

Overshoot gf)

P-P Value (]

)

Undershoot =

N 3

-- Low Level O

)Ti!,\L, \J__ 1 Min S

Q

¢ Time measurement items

Rise time: Rise time [s] Plus duty: Duty ratio, Width1/Period x 100 [%)]
Fall time: Fall time [s] Minus duty: Duty ratio, Width2/Period x 100 [%)]
Frequency: Frequency [Hz] Plus width: Time width greater than the mesial value [s]
Period: Cycle [s] Minus width: Time width less than the mesial value [s]
Period
~— +Width —-— -Width — High Level (100%)
igh Level o
”””” N NI Distal line (90%)
Mesial line (50%)
Proximal line (10%)
VAV B E— A =aTAY e
v} | Low Level (0%)
Rise Time  Fall Time
Pulse: Pulse count Adjust the measurement scope to

the pulses you want to measure.
When Pulse=3

“===-f=-t---f-f--F--1-- Distal line (90%)
= f 1 Mesial line (50%)
bttt 1 Proximal line (10%)

~—Measurement—|
scope
T1 T2

Burst1, Burst2: Burst width [s] Adjust the measurement scope to the
burst widths you want to measure.

---- Distal line (90%)
---- Mesial line (50%)

+/--- Proximal line (10%)

~—Measurement—=

scope
P T
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4.3 Automated Measurement of Waveform

Area measurement items
Int1TY: Size of the positive portion of an amplitude
Int2TY: Size of the positive portion of an amplitude - Size of the negative portion of an
amplitude
Int1XY: < Total area in which the start and stop points trace multiple identical closed
curves
» Area enclosed by a curve connecting the start and stop points
« Area in which the start and stop points trace the shape of an “8”
» Area in which the start and stop points trace a closed curve in a spiral loop
Int2XY: « When 1Y data point corresponds to 1 X data point
* When the amplitude contains negative sections
* When multiple Y data points correspond to 1 X data point

Int1TY
Size of only the positive areas: S;+S,
| s |
| S 2 |
| |
Int2TY
Size of both positive and negative areas: S;+S3-S,
| S |
| Sq 3 |
| Sz |
| |
Int1XY
(1) Multiple loops (2) Non-closed curve
Area S =nx So Area S = So
n: Number of loops Area enclosed by a curve
connecting the start and
Start point stop points
Start and i
stop points N Waveform Stop point

(3) Loop tracing the shape of an “8” (4) Spiral loop
AreaS=S8S0x 2+ S1
As the number of loops

’ Area S = |So — S1|
< / increases, the number of

& \ \ ) 2 overlapped sections
\\*\ Start pomt \ changes.

Stop point Stop point

Start point
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4.3 Automated Measurement of Waveform

Int2XY
(1) When 1Y data point corresponds to 1 X data point
a) Start | b) X-axis (Y = 0)
point Stop point 5 Area S = -So
So Area S = So Stop point
) Start point
X-axis (Y = 0)
c) d) X-axis (Y = 0)
Start .
point Start point o Area S = So
So Area S =-So Start point
Stop point
X-axis (Y = 0) PP

(2) When the waveform contains negative amplitude

Start point
N
%2}2 X-axis (Y = 0)
Area S = So—S1
Stop point

(3) When multiple Y data points correspond to 1 X dat a point

Start
Start boint point
art poin =
P So Area S = So Stop point
AreaS=So+2x S1+S2
Stop point
X-axis (Y =0) X-axis (Y = 0)

*** Indication
If the measurement result is invalid or impossible, “***” is displayed as the measured
value. Waveforms with small amplitudes may fail to produce correct readings.

Icon Displayed during Automatic Measurement
While automatic measurement is being performed, the icon shown below appears in the
status bar.

fH; : Performing automatic measurement (blinks on and off)

Notfte

* It may take a long time to automatically analyze a waveform with some conditions for the

scope, number of items, and/or waveforms to analyze.
For example, if the measurement item is Pulse count, Burst1, Burst2, Average frequency,
or Average period and the number of data points exceeds 1 Mpoint, computation will take a
long time.

* Canceling automated measurement
While automated measurement is in progress, a cancel button and a progress bar are
displayed in the status bar. Click the Cancel button to cancel automated measurement.

" .
Cancel | - ok HUM I
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4.3 Automated Measurement of Waveform

Data Obtained through Automatic Measurements with Waveform Parameters
To keep the obtained data, save it into a file. For details, see Section 5.4.

Nofte

You can copy the contents of the measurement results display window to the clipboard.

Specify the range to be copied, and press Ctrl + C, then the measured results are copied to the
clipboard. The following methods can be used to specify a range.
» Press Ctrl + C without specifying a range to copy:
All the contents in the measurement results display window are selected
» Click Measure Item:
All rows are selected except for the data at the cursor.
» Click the measurement items of the items to copy:
The rows of the clicked items are selected

— Click here to select all rows except the cursor information.
Click once again to clear the selection.

Curzorl | Cursor? | Cursor Diff 1)
M. & &
latile Ti
Wen®s lten | CHI[Y] | CHE[Y] 2 L If no range is specified,
P-P all contents are copied
e [T
M
Win (M 1)
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4.4 Automated Measurement of History Statistics

Procedure

Setting Items That Are Automatically Measured

1. From the ﬁ; drop-down menu, select History Statistics. Or click Analysis >
Waveform Parameter Settings > History Statistics.

Ho- Viewer1 H:\Documents and Settings\spdc\Desktop\Sample\wave. WVF
m File Wiew A&nalysis ‘Window

EPErEzEE KM-
A || By |- B A - i 7 j| [
L @ Iy |- B A-0 & wave Parameter

‘Wave Parameter
H "

Cyile Statistics

The icon changes
according to what you select.

ﬁ : History Statistics

H:] : Cycle Statistics

or

4o Wiewer1 H:\Documents and Settings\spdci\Desktop\Sample
8 File  view N
Analysis Mode r

Window

WWave Parameter. .
Hisks Skatiski

Math Setting. ..

ejeq wuojanep BuizAjeuy BN

Cycle Statistics. .. k

The History Statistics Settings dialog box appears.

2. In the History Statistics Settings dialog box, set the measurement items and the
conditions for displaying measured results, and then click OK.

Names of items to be measured
Select or deselect the item

M e i Select the number of rows

to be used to display
R . measured values
- (allowable range: 1 to 28).

Histogram Settings
e — Select this check box to display
e the histogram of statistics in the
measurement results display

window.

Use a linear scale

to display the histogram's Y axis.

Use a logarithmic scale

to display the histogram's Y axis.

Peak to peak value

Anpituge

Waximum

Mimum

High level

Voltage measurement | |unes
Py

items | [

RMS

Standard deviation

Owershoct

Undershot

Rise time:

Fall time

Frequency

Period

Plus wicth

Time measurement
items

Start automated measurement

items

Area measurement [

Automated measurement starts. Two vertical cursors appear in the main waveform display
window, and the measured history statistics are displayed in the measurement results
display window.
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4.4 Automated Measurement of History Statistics

Specifying the Automated Measurement Range

You can change the range over which to perform automated measurement of history
statistics. Drag the two vertical cursors to change the measurement start point and the
measurement end point. History statistics are remeasured.

Operations in the History Statistics’ Automated Measurement Screen
4 N

B[ ——{al-
Wave Pararmeter

v History Statistics
Cycle Skatistics

Settings... — Displays the History Statistics
Settings dialog box

Stop automated measurement of history statistics

=4

Click again to start automated measurement

BN A-EOA RN
“I g in el il S—

000

— History statistic results

Kal J:’;:”A || oo / = \ A, 4 =
st () —— Measurement status

/ Measurement \
range

Measurement Measurement
start point cursor end point cursor

Displaying History Statistic Results

Bl
Cursor(1) Cursor(2) cursorift | . -
= —— === Histogram of statistic results
e | |-m e In the History Statistics Settings dialog
Statistics ftem | P-P(CH3) AmpLCH3) Max(CH3) Min(CH3) box, set whether to show or hide this area

(see the previous page).

Histogram

History statistics values
Max: Maximum value
Min: Minimum value
Avg: Average value
StdDev: Standard deviation
Count:  Number of cycles

| History Mo FRCHI) | AmpgoHd) | | &
(i uuuL i

0001
0002
0003
0004
0005
0006
0007
0008
0003
o010
0011
002

Measurement items and channels

Maximum and minimum markers
1: Displayed next to the maximum value
of each measurement item
|: Displayed next to the minimum value
of each measurement item

History numbers
Double-click a history number to display the corresponding history waveform.
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4.4 Automated Measurement of History Statistics

Explanation

Items That Can Be Measured

On the history waveforms, you can set and measure voltage, time and area items.
Items that can be measured are the same as those of the automated measurement of
waveform parameters (see page 4-7 to 4-9).

*** Indication

If the

measurement result is invalid or impossible, “***” is displayed as the measured

value. Waveforms with small amplitudes may fail to produce correct readings.

Icon

Displayed during Automated Measurement

While automatic measurement is being performed, the icon shown below appears in the
status bar.

AL

Note

Performing automate measurement (blinking)

Canceling history statistic measurement
While history statistic measurement is in progress, a cancel button and a progress bar are
displayed in the status bar. Click the Cancel button to cancel history statistic measurement.

w )

[ ] HUM

If the total number of items that is determined by the number of history waveforms, the
number of channels, and the number of measurement items exceeds 100000, computation
may not be possible. Change the number of displayed channels and measurement items so
that 100000 is not exceeded.

2

Savi

ng History Statistics’ Automated Measurement Data

To save the measured results, save them to a file. For details, see section 5.4.

Note

You can copy the contents of the measurement results display window to the clipboard. Specify
the range to be copied, and press Ctrl + C. The measured results are copied to the clipboard.
The following methods can be used to specify the range.

Press Ctrl + C without specifying a range to copy:

All the contents in the measurement results display window are selected.

Click Trace:

All rows are selected except for the cursor position information and the histograms.
Click or drag the trace names of the items to copy:

The rows of the clicked or dragged traces are selected.

— Click here to select all rows except for the cursor position information and the histograms.
Click once again to clear the selection.

ollx

Curzar(l) Cursor2) Curzar Diff

Mo,

Fizlative Time

Stavstics ftem P-P(CHI)

Histogram

— If no range is specified,
all contents are copied
StelDey
Court
Hiztory Ma.
fuulul)
[ululu]
ooz
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4.5

Automated Measurement of Cycle Statistics

Setting Items That Are Automatically Measured

1. From the ffﬁk drop-down menu, select Cycle Statistics. Or click Analysis >
Waveform Parameter Settings > Cycle Statistics.

4 Yiewer1 H:A\Documents and Settings\s pdc\Desktop\Samplewave . WVF

n File view Analysis Window

2SS
5«5@ I'I'%‘U

or

8 File  view [

Ainaly:

Math Setting. ..

> m-
A~

The icon changes
according to what you select.

El_ ﬁ;ﬁk : Wave Parameter

Wawe Parameter

History Skatistics

ﬁ : History Statistics

E.".H : Cycle Statistics

Window

iz Mode [
£ » “Wave Parameter..,
Hiskary Skatiskics. ..

Paramet

The Cycle Statistics Settings dialog box appears.

2.

In the Cycle Statistics Settings dialog box, set the measurement items and the

conditions for displaying measured results, and then click OK.

Traces and measurement
items to perform cycle
statistic measurement

(up to eight items)

Names of the traces to be measured

Gycle Slfatistics Settine]

Histogram Settings
I Display

=] ——

B | 1] Canel

Names of items to be measured

Select the reference trace for
cycle statistic measurements.

used to display measured values
(allowable range: 1 to 8).

j Select the measurement range.
All: The entire waveform is
measured.

Cursor range: The cursor range
is measured.

Select this check box to display

J, Select the number of rows to be

|
Start automated measurement

the histogram of statistics in the
measurement results display window.

Use a linear scale to display
the histogram's Y axis.

—— Use a logarithmic scale to display
the histogram's Y axis.

Automated measurement starts. Two vertical cursors appear in the main waveform display
window, and the measured cycle statistics are displayed in the measurement results display

window.

IM 701992-01E



4.5 Automated Measurement of Cycle Statistics

Specifying the Automated Measurement Range

When the measurement range is set to Cursor range, you can change the range over
which to perform automated measurement of cycle statistics. Drag the two vertical
cursors to change the measurement start point and the measurement end point. Cycle
statistics are remeasured.

When the measurement range is set to All, moving the cursors will not cause cycle
statistics to be remeasured.

Operations in the Cycle Statistics’ Automated Measurement Screen
4 N\
k] |+ ——>[bl-
Wave Pararmeter
Hiskary Skatistics
v Cyile Skatistics

Settings... — Displays the Cycle Statistics
Settings dialog box

Stop automated measurement of cycle statistics

Mv

L— Click again to start automated measurement

WwBN-FAHA-DR =
[He Toom T TSI TRSCIII e
..... e

B0

T

ejeq wuojanep BuizAjeuy BN

Lllll?llllllllllllr:

o

— Cycle statistic results

llll'lillllllllllkllll
4o :

e ] L]
- \

Measurement \
range

Measurement Measurement

start point cursor end point cursor

== s)———— Measurement status

Displaying Cycle Statistic Results

Cursor(1) Cursor(2) Cursor Dift

Relative Time

Statistics fem | P-P(CH3) Amp(CH3) Max(CH3) Min(CH3)

Histogram of statistic results

In the Cycle Statistics Settings dialog
box, set whether to show or hide this area
(see the previous page).

Histogram

Cycle statistic values
Max: Maximum value
Min: Minimum value
Avg: Average value
StdDev: Standard deviation
Count: Number of cycles

Count
| cyolena FP(CHI) | Amp(CH3) | Max(CH3) | Min(cH) | |
i U LI i3

0001
0002
0003
0004
0005
0006
0007
0008

Cycle numbers
Double-click a cycle number to display the corresponding cycle waveform.

Measurement items and channels

Maximum and minimum markers
1: Displayed next to the maximum value
of each measurement item
|: Displayed next to the minimum value
of each measurement item
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4.5 Automated Measurement of Cycle Statistics

Explanation

Items That Can Be Measured

On each period of the waveforms, you can set and measure voltage, time and area items.
Items that can be measured are the same as those of the automated measurement of
waveform parameters (see page 4-7 to 4-9).

Cycle Trace

Select the trace that will be used as the reference cycle for performing cycle statistic
measurement. If Own has been selected, cycle statistic measurement is performed using
each trace’s cycle. Cycle statistic result window will show the measured results over the
time period for the least number of cycles.

When Cycle Trace Is Set to Own

CH1

Statistically processed cycles

CH2

—————!
Statistically processed cycles

CH3

Statistically processed cycles

The number of cycles in the channel with the slowest cycle (CH3)
is four, so statistical processing is performed on the four oldest
cycles of the data for CH1 and CH2. The remaining data is not
used for statistical processing.

*** Indication
If the measurement result is invalid or impossible, “***” is displayed as the measured
value. Waveforms with small amplitudes may fail to produce correct readings.

Icon Displayed during Automated Measurement
While automatic measurement is being performed, the icon shown below appears in the
status bar.

E::H : Performing automate measurement (blinking)

Nofte

» Canceling cycle statistic measurement

While cycle statistic measurement is in progress, a cancel button and a progress bar are
displayed in the status bar. Click the Cancel button to cancel cycle statistic measurement.

.
[ oo | Rl W |

« If the total number of items that is determined by the number of cycles and the number
of measurement items exceeds 100000, computation may not be possible. Change the
measurement range and the number of measurement items so that 100000 is not exceeded.

4-16
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4.5 Automated Measurement of Cycle Statistics

Saving Cycle Statistics’ Automated Measurement Data
To save the measured results, save them to a file. For details, see section 5.4.

Note

You can copy the contents of the measurement results display window to the clipboard.

Specify the range to be copied, and press Ctrl + C. The measured results are copied to the
clipboard. The following methods can be used to specify the range.
» Press Ctrl + C without specifying a range to copy:
All the contents in the measurement results display window are selected.
» Click Trace:
All rows are selected except for the cursor position information and the histograms.
» Click or drag the trace names of the items to copy:
The rows of the clicked or dragged traces are selected.

— Click here to select all rows except for the cursor position information and the histograms.
Click once again to clear the selection. >
(=13 3
I 5 N -
Curzar(l) Cursor2) Curzar Diff "ﬁ
Mo, )
F|zlative Time -0.49 0. @
Seftosten | _pACHD) | _Ane(on) | e | Mnony 5
<
@
Histogram 3‘
2
- 3
(=53 i w]
Win — If no range is specified, Q
s all contents are copied o
StelDey
Court
Cyele Mo,

aono
ool
ooonz
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4.6 Analyzing Waveforms by Computations (Math
Edition)

Procedure

Displaying Waveforms in the Computation View

Click the or select Analysis > Math Setting to display the Math Setting dialog
box for analyzing waveforms by computational expressions. The Math Setting dialog
box allows you to set computational expressions, filters, FFT computations, and other
computations for waveforms.

|4 ¥iewer1 D:\Documents and Settings'Administrator'\Desktop', SampleWaveData', 2CHSINFFT.WYF - [TimeYiewer] =100%(
BB Fie view Analyss Window |8
|Ezsd g xm-

L IR C)

Main Tiigger 1 me: 2004710705 19272052 Nurmber of Data. 10010
Gioup! 3

Displays the Math
Setting dialog box

500,000

25,000

L, | M L1
™

o Ll

250 Computationally
o e “ analyzed waveform

L1 1
Displays the computation status

Ready

—— Label of the computationally analyzed waveform

Setting Computational Expressions

Click the Expression in the Math Setting dialog box to display the Computational
Expression screen, which allows you to specify user-defined computation settings. Set
up a required computational expression by using variables and operators.

Computational
expression number

Set the label, unit, and computation expression
in the Computational Expression screen

Math Setting

Expression = Const Yalug = Set a constant
Ki (allowable range:
:j -1.0000E+30 to
ke 1.0000E+30)
K3
KE
K7
K3
K8
K10
©EEEO) | O .
FFT Setting - [ ar EESEPS . o Apply the setting
Points: Window : [Math start paint: Math Paints: made for the
Rect e foass < o 100,100 computational
1K A Hanring Band: || gwPass = Math start history: expression at the top
FRT start Wgt: FlatTop Cutoffl: | 3.0 % 15.00kHz) ’ O{fzhe CO|Uml? ttO thel
other computationa
Cutoff2: % {15, 00kH: i
{ 2) O Cancel ‘ expressions

Specify a name for the label (using up to 31 one-byte characters)
Set the units (up to 15 one-byte characters)

user pefineMatin | =L Displays the trace names corresponding
T T e vidle|  Trace ‘ to the variables

B [ Fomn o, === Set a computational expression
[ [ ggl‘ (up to 63 characters)
S e Display the operators menu
[;jl : I ;I : I : I ﬁI : I iI : IPDSI : I : I}:Em Setting numerals and variables
ﬁPS_LOGMAG simple input

Show other computational expressions
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4.6 Analyzing Waveforms by Computations (Math Edition)

Setting Filters
Use the FILT1 and FILT2 tabs on the Math Setting dialog box to set up the filters.

Setting the Computation Start Point, the number of Computation Points

and Start History

* You can set the computation range by specifying the computation start point and
the number of computation points. You can also change the computation range by
adjusting the computation range bar, which is displayed in the waveform display
window.

» With history waveforms, you can set the number of the history waveform on which
to start computation (computation start history), the computation start point, and the
number of computed points. With this computation setting, waveforms are assigned in
order from 0 to positive integers starting with the oldest waveform.

Note

The maximum number of computed points is 12.5 Mpoints (2.5 Mpoints if there are 11 or more
MATH channels).

Math Setting

Switch between the filter
1 and filter 2 panels

Set the computation
start point
(0 to the number of

FFT Setting FILTL WFILTZ | Math Settifigs waveform points).
Pints: Window = Math start|point: Math Paints:
! T Tvee: -
Aot s v . 100,100 - Set the number of
1K = Hanri Band: || qypass - Math start history: . .
L —— computation points.
| _FeiTop | ||mCutoffts | 30 (1500 (When the number of
[ ukoff2: [0 % ( 15.00kk2) o | | caal | computation channels is
10orless: 1t0 125 M
— Set the cut-off frequency When thg number of .
computation channels is
Select the band 11 or more: 1 to 2.5 M)
— Select the type — Set the number of the history waveform on

which to start computation

Specifying FFT Settings
Use FFT Setting on the Math Setting dialog box to specify the FFT settings.

s
Expression || Const. “alue

K1
K2
K3
K4
KS
K&
K7
KB
K3
K10

3 ki
FFT Setting FILT1 IFILTZ 1 Math Settings
Points: Math statt point: Math Points:
' Topeifcanss  w i 100,100
L Band: |LgwPass - Math start history:

Hanning

a

FFT stai FlatTop CutOff1: | 3.0 % (15.00kHz) ’7

| UG (s | [ o | canel |
'— Select a time window type

'— Select the number of points to be used for FFT computations
Set the FFT start point
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4.6 Analyzing Waveforms by Computations (Math Edition)

Explanation

Function Menu Button
The Function menu button of the Computational Expression dialog box contains
operators that can be specified for user-defined computational expressions, as follows:

Basic SHIFT, ABS, SQRT, LOG, EXP, NEG, P2, P3, F1, F2

Trigonometric  SIN, COS, TAN, ATAN, PH

Pulse Width PWHH, PWHL, PWLH, PWLL, PWXX, FV, DUTYH, DUTYL

DIF & INTG DIF, DDIF, INTG, IINTG

Filter FILT1, FILT2, HLBT, MEAN, BIN

FFT LS LS-REAL, LS-IMAG, LS-MAG, LS-LOGMAG, LS-PHASE
RS RS-MAG, RS-LOGMAG
PS PS-MAG, PS-LOGMAG, PSD-MAG, PSD-LOGMAG
CS CS-REAL, CS-IMAG, CS-MAG, CS-LOGMAG, CS-PHASE
TF TF-REAL, TF-IMAG, TF-MAG, TF-LOGMAG, TF-PHASE
CH CH-MAG

Restrictions Imposed on Computational Expressions

* When m < n, a computational expression for Mathn cannot include the variable Mn
(Operations for Mathn).
Example of an expression that is not allowed: Math5 = M6 + M3

* One FFT computation allows the specification of one waveform.
Example of an expression that is not allowed: PS-MAG(C1+C2)

» A computation cannot be performed on the result of an FFT computation.
Example of an expression that is not allowed: PS-MAG(C1)+C2

Cautions on Computations

* An FFT computation that does not have a record length that is sufficient for the
required number of points for computation in the target view cannot be performed.

Settings for the Filters

e Type/Band
Gauss (gauss): Lowpass
Sharp (sharp): Lowpass/Highpass/Bandpass
IIR (butterworth):  Lowpass/Highpass/Bandpass

¢ CutOff1/CutOff2
Set either or both cutoff frequencies as a ratio to the sampling frequency. The
allowable range is 2.0% to 30.0% (0.2% steps). When you specify Bandpass for
Band, specify the orders of both CutOff1 and CutOff2. The higher the order, the
longer the computation.
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4.6 Analyzing Waveforms by Computations (Math Edition)

Computation Start Point

When computation is executed, the computation start point and the computation range
bar appear. You can move the computation start point by dragging the computation start
point mark or the left edge of the computation range bar.

Main Trigger Time: 2011/05/23 091852313168 g ember of Dt 101,000
Groupl T Sampling Intervak 20000us

B 17 (AU 1P PR . ooy an)
s ‘ it I B
oo — Computation start point
SN NN Drag the mark to move the computation start point.
oMy D*/\/\J (The number of computation points is fixed.)
0 Computation range bar
R R Humb f Data: 1,007,000
T R @Um er 0 Ilaa

;.I.—h!.m..iﬂ.\m..h..m.l.;

Drag the middle of the computation range bar
to move the computation start point.
(The number of computation points is fixed.)

—25000
No.0000 -1.000000

Drag the left edge of the computation range bar to change
the computation start point and the number of computation points.

Number of Points for Computation

» When you click the left edge of the computation range bar, a horizontal arrow cursor
appears. You can drag the edge to change the computation start point and the number
of computation points. When you click the right edge of the computation range bar, a
horizontal arrow cursor appears. In this situation, you can only change the number of
computation points.

ejeq wJiojanep) BuizAjeuy H

Variables and Operators

The variables and operators that can be used in computational expressions are listed
below. You can use up to 63 characters to define a computational expression. You can
register up to 32 computational expressions.

Variables

Variable Sample Use Description

Cx C1+C2 Value measured on channel CHx

My ABS(M1) Value of computation (Math)

T SIN(T) Integrated value for the number of data points to the time axis

x: stands for a number, However, specify the number according to the number of channels that are
loaded. For example, if three channels, CH1, CH5, and CH8, are loaded, specify the channels as
C1, C2,and C3.

y: stands for a number

Operator

Operator Sample Use Description

+ =% C1+C2 Four arithmetical Operations on two specified waveforms
SHIFT SHIFT(C1,1000) Phase shift

ABS ABS(M1) Absolute value of a specified waveform

SQRT SQRT(C2) Square root of a specified waveform

LOG LOG(C1) Logarithm of a specified waveform

EXP EXP(C1) Exponent of a specified waveform

NEG NEG(C1) Inversion

SIN SIN(T) Sine of a specified waveform

COSs COS(C1) Cosine of a specified waveform

TAN TAN(C1) Tangent of a specified waveform

ATAN ATAN(C1,C2) Arctangent of two specified waveforms (value within + 17)
P2 P2(C1) Square of a specified waveform

P3 P3(C1) Cube of a specified waveform

IM 701992-01E
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4.6 Analyzing Waveforms by Computations (Math Edition)

Operator Sample Use Description

F1 F1(C1,C2) V(Ic12+C22)) of a specified waveform

F2 F2(C1,C2) V(Ic12+C22|) of a specified waveform

K1toK10 C1+K1 Constant (any value specified)

BIN BIN(C1,A,B) Binarization of a specified waveform

PWHH PWHH(M1,A,B)  Computation of a pulse width between a rising edge and the next
rising edge

PWHL PWHL(C2,A,B)  Computation of a pulse width between a rising edge and the next
falling edge

PWLH PWLH(C1,A,B)  Computation of a pulse width between a falling edge and the
next rising edge

PWLL PWLL(C1,A,B) Computation of a pulse width between a falling edge and the
next falling edge

PWXX PWXX(C2,A,B)  Computation of a pulse width between a raising/falling edge and
the next rising/falling edge

FV FV(C1,A,B) PWHH reciprocal

DUTYH DUTYH(C1,A,B) Duty cycle between a rising edge and the next rising edge

DUTYL DUTYL(C1,A,B) Duty cycle between a falling edge and the next falling edge

MEAN MEAN(C1) 10th moving average of a specified waveform

DIF DIF(C1) Differentiation of a specified waveform

DDIF DDIF(C1) Second-order derivative of a specified waveform

INTG INTG(C1) Integration of a specified waveform

IINTG IINTG(C1) Second-order integration of a specified waveform

PH PH(C1,C2) Phases of two specified waveforms

HLBT HLBT(C1) Hilbert function of a specified waveform

FILT1 FILT1(C1) Filter for a specified waveform

FILT2 FILT2(C1) Filter for a specified waveform

LS-REAL LS-REAL(C1) Real part of the linear spectrum of a specified waveform

LS-IMAG LS-IMAG(C1) Imaginary part of the linear spectrum of a specified waveform

LS-MAG LS-MAG(C1) Amplitude of the linear spectrum of a specified waveform

LS-LOGMAG LS-LOGMAG(C1) Logarithmic amplitude of the linear spectrum of a specified
waveform

LS-PHASE  LS-PHASE(C1) Phase of the linear spectrum of a specified waveform

RS-RS-MAG RS-MAG(C1) Amplitude of the effective spectrum of a specified waveform

RS-LOGMAG RS-LOGMAG(C1) Logarithmic amplitude of the effective spectrum of a specified
waveform

PS-MAG PS-MAG(C1) Amplitude of the power spectrum of a specified waveform

PS-LOGMAG PS-LOGMAG(C1) Logarithmic amplitude of the power spectrum of a specified
waveform

PSD-MAG PSD-MAG(C1) Amplitude of the power spectrum density of a specified waveform

PSD-LOGMAG PSD-LOGMAG(C1) Logarithmic amplitude of the power spectrum density of a
specified waveform

CS-REAL CS-REAL(C1,C2) Real part of the cross spectrum of two specified waveforms

CS-IMAG CS-IMAG(C1,C2) Imaginary part of the cross spectrum of two specified waveforms

CS-MAG CS-MAG(C1,C2) Amplitude of the cross spectrum of two specified waveforms

CS-LOGMAG CS-LOGMAG(C1,C2) Logarithmic amplitude of the cross spectrum of two specified
waveforms

CS-PHASE  CS-PHASE(C1,C2) Phase of the cross spectrum of two specified waveforms

TF-REAL TF-REAL(C1,C2) Real part of the transfer function of two specified waveforms

TF-IMAG TF-IMAG(C1,C2) Imaginary part of the transfer function of two specified waveforms

TF-MAG TF-MAG(C1,C2) Amplitude of the transfer function of two specified waveforms

TF-LOGMAG TF-LOGMAG(C1,C2) Logarithmic amplitude of the transfer function of two specified
waveforms

TF-PHASE  TF-PHASE(C1,C2) Phase of the transfer function of two specified waveforms

CH-MAG CH-MAG(C1,C2) Amplitude of the coherence function of two specified waveforms

4-22
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4.6 Analyzing Waveforms by Computations (Math Edition)

Settings for FFT
e Points (number of points used for computation):
Select 100 points, 200 points, 500 points, 1000 points, 2000 points, 5000 points,
10000 points, 20000 points, 50000 points, 100000 points, 200000 points, 500000
points, 1000000 points, or 2000000 points.

Nofte

Executing an FFT calculation with 1000000 points or more, only M1 is calculated and the result
is displayed.

* FFT start point:
When the number of loaded points is less than 10M: Specify 0 to “Number of
loaded points - no. of FFT computation points”
When larger than 10M: set between computation start point and “computation start
point + 10M - no. of FFT points”

¢ Window (time window):
Select the Rect (rectangle), Hanning (hanning), or FlatTop (flat-top) window.

Displaying the FFT Range

The FFT range is indicated with a green bar on the main waveform display window and
the zoomed waveform display window.

Drag the bar to move the computation range.

If FFT cannot be performed, the bar indicating the range and the word “FFT” turn red.

. Viewer1 F\DLTS0\ZCHSINFFT2.WVF - [TimeViewer]
BB Fie view anslysis windon
EsEE Xxm-
@ - E wE N & -l

Tan
Group F
25.000 1

- \( FFT range

M

Trigger Time: 2004/10/06 1532758 o of Dt 110
\C

25,000
25,000

54
v HIUlHIIHIHHJII\HMHI
[ T

25,000
No.0000 250000m

Murnber of Data: 10010

N R O

Zoom Tiage: Tine: 2004710706 T 3236 54 Humber of Data: 4001
r0up

25,000

NCH] e
[l

25,000
22008 + + + + E: + i
aCHg, AAAAAAAANARANANAAARARAANAAAEANAANDAAAN S
¥ VUVUVVVUVURVVVTUTVVUVU VYUY VYUV VYUV UYL

Icon displayed during measurement through computation
While measurement through computation is being performed, the icon shown below
appears in the status bar.

f&l: Accessing file

Nofte

» Canceling computation
During computation, a cancel button and a progress bar are displayed in the status bar.
Click the Cancel button to cancel the computation.
If you cancel the computation, nothing will be displayed in the waveform display window and
measurement result window.

'
Cancel | - MM I

Computational accuracy
Single-precision floating-point type

IM 701992-01E
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4.6 Analyzing Waveforms by Computations (Math Edition)

Details of Various Computations
Filter (FILT1/FILT2)

Type

Type Bandwidth

Gauss Lowpass

Sharp Lowpass/Highpass/Bandpass
IIR (Butterworth) Lowpass/Highpass/Bandpass

Filter Orders
See the following table for the filter orders.

Cutoff frequency/sampling frequency x 100 2% 5% 10% 20% 30%

Gauss Lowpass 49 21 9 5 5

Sharp Lowpass 88 36 18 9 8
Highpass 159 65 33 17 13

IIR Lowpass 4 4 4 3 2

Highpass Highpass 4 4 4 4 3

Nofte
*  You can set the cutoff frequency in the range from 2 to 30% of the sampling frequency (in 0.2%
steps).

* The higher the filter order, the longer computation takes.

Filter Characteristics

Filter Pass band Ripple Attenuation slope Attenuation in the Phase
Stop band
Gauss 0dB * - Linear
Sharp +0.3dB —40 dB at 1 oct (Lowpass), —40dB Linear
—40 dB at —1 oct (Highpass)
IIR 0dB -5 dB at 1/6 oct (Lowpass), - Non-linear

—20 dB at —1 oct (Highpass)

Attenuation for a Gauss filter is —3.0 x (f/fc)2 dB (where f is the frequency and fc is the cutoff
frequency).

*

Examples of Frequency Characteristics for Various Filters

Gauss (cutoff 10%) Sharp (Lowpass, cutoff 10%) IIR (Lowpass, cutoff 10%)

df
1]

a0 1

T T if T T T T 5 T T T
a 1)

=20 -20

a0 -0

0 -0

L 1 1 .80 L 1 1 L -&0

of 0.11

0zf  03f  04f o5l of 011 0.zl 0.3f od4f  ost o5t

f: Sampling Frequency
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4.6 Analyzing Waveforms by Computations (Math Edition)

Hilbert Function (HLBT)

Normally, when we analyze a real time signal, it is convenient to think of the signal as
the real part of a complex valued signal. Analysis is often more convenient when done
using the complex signal. Given that the real time signal is considered to be the real part
of the complex signal, the imaginary part is then equal to the Hilbert transform of the real
part. When performing a Hilbert transform on a signal in the time domain, the signal is
first transformed into the frequency domain using the Fourier transform. Next, the phase
of each frequency component is shifted by —90 degrees if the frequency is positive and
+90 degrees if negative. Lastly, the Hilbert transform is completed by taking the inverse
Fourier transform. As can be seen from the above description, the Hilbert transform does
not change the order of the individual variables. The Hilbert transform of a time signal
results in another time signal.

Application Example

The Hilbert transform can be used to analyze an envelope waveform.
AM (amplitude modulation): SQRT(C1*C1+HLBT(C1)*HLBT(C1))
Demodulation of a FM signal: DIF(PH(C1, HLBT(C1)))

Phase Function (PH)

Phase function PH(C1, C2) computes tan™' (C1/C2). However, the phase function takes
the phase of the previous point into consideration and continues to sum even when the
value exceeds 11 (The ATAN function reflects at £1). The unit is radians.

_. Previous point
02
o1
? AB2 //‘i\x
NS \
62
" Previous point
02 =01 + AB2 062 =01 - A62
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4.6 Analyzing Waveforms by Computations (Math Edition)

Binary Conversion (BIN)
Performs binary conversion with respect to the specified threshold level.

The threshold level is specified as follows:
A and B represent the Upper and Lower threshold levels, respectively.
BIN(C1, A, B)

Upper threshold level
Lower threshold level

Pulse Width Computation (PWHH/PWHL/PWLH/PWLL/PWXX)
The signal is converted into binary values by comparing to a preset threshold level, and
the time of the pulse width is plotted as the Y-axis value for that interval.
The following 4 intervals are available:

PWHH: From the rising edge to the next rising edge.

PWHL: From the rising edge to the next falling edge.

PWLH: From the falling edge to the next rising edge.

PWLL: From the falling edge to the next falling edge.

PWXX: From the rising or falling edge to the next rising or falling edge.
The threshold level is specified as follows:

A and B represent the Upper and Lower threshold levels, respectively.
PWHH (C1, A, B)

Waveform to
be computed

Computed
waveform
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4.6 Analyzing Waveforms by Computations (Math Edition)

FFT

Linear Spectrum (LS-REAL/LS-IMAG/LS-MAG/LS-LOGMAG/LS-PHASE)
The linear spectrum is directly determined by the FFT. The power spectrum and cross
spectrum can be determined from one or two linear spectra.

The FFT is a complex function, and thus the linear spectrum is composed of both a real
and an imaginary part. The magnitude and phase of the frequency components of the
measured waveform can be derived from the real and imaginary parts of the FFT result.
The following spectra can be determined:

Item Expression Computation
Real part LS-REAL R

Imaginary part LS-IMAG |

Magnitude LS-MAG V(RP+1)

Log magnitude LS-LOGMAG 20 x logy/(R%+P)
Phase LS-PHASE tan~'(I/R)

Log magnitude reference (0 dB): 1 Vpeak
R, I: R and | represent the real part and the imaginary part, respectively, when each frequency
component G of a linear spectrum is represented by “R + jl.”

Rms Value Spectrum (RS-RS-MAG/RS-LOGMAG)
Rms value spectrum expresses the rms value of the magnitude of the linear spectrum. It
does not contain phase information.

ejeq wJiojanep) BuizAjeuy H

The following spectra can be determined:

Item Expression Computation
Magnitude RS-MAG (RP+1P)2
Log magnitude RS-LOGMAG 20 x logy/(R*+1%)/2

Log magnitude reference (0 dB): 1 Vrms

Power Spectrum (PS-MAG/PS-LOGMAG/PSD-MAG/PSD-LOGMAG)

The power spectrum expresses the power of each frequency component included in the
measured signal. It is determined by taking the product of the linear spectrum and its
complex conjugate. It does not contain phase information.

The following spectra can be determined:

Item Expression Computation

Amplitude PS-MAG DC component R2+ 2
AC component (RZ+ 12)/2

Log magnitude LS-MAG DC component 10 x log(R? + I?)
AC component 10 x log{(R? + 1%)/2}

Log magnitude reference (0 dB): 1 Vrms?

Power Spectral Density (PSD-MAG/PSD-LOGMAG)

The power spectral density (PSD) expresses the power spectrum per unit frequency. It is
determined by dividing the power spectrum by the frequency resolution Af found during
the analysis of the power spectrum. The results of the PSD computation vary depending
on the window function chosen. The power spectral density is used to compare power
spectra analyzed at different frequency bands. However, it is not necessary for signals
having a line spectrum such as a sine wave.

The following spectra can be determined:

Item Expression Computation

Magnitude PSD-MAG PS-MAG/Af (for rectangular window)
PS-MAG/1.5Af (for Hanning window)

Log magnitude PSD-LOGMAG 10 x logPS-MAG/Af (for rectangular window)

10 % logPS-MAG/1.5Af (for Hanning window)

Log magnitude reference (0 dB): 1 Vrms?

IM 701992-01E
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4.6 Analyzing Waveforms by Computations (Math Edition)

Cross Spectrum (CS-REAL/CS-IMAG/CS-MAG/CS-LOGMAG/CS-PHASE)
The cross spectrum is determined from 2 signals. It is found by taking the product of
the linear spectrum of one signal (Gx) and the complex conjugate (Gx*) of the linear
spectrum of the other signal (Gy).
If the linear spectra of the 2 signals are represented by

Gx = Rx +jIx

Gy =Ry +jly
then the cross spectrum Gyx is

Gyx = Gy x Gx*

= (Ry +jly)(Rx — jIx) = Ryx + jlyx

where Ryx = RyRx + lylx

lyx = Rxly — Rylx

The following spectra can be determined:

Item Expression Computation
Real part CS-REAL DC component Ryx/
AC component Ryx/2
Imaginary part CS-IMAG DC component lyx
AC component lyx/2
Amplitude CS-MAG DC component (Ryx? + lyx?)
AC component (Ryx® + lyx?)/2
Log magnitude CS-LOGMAG DC component 10 % log(Ryx? + lyx?)
AC component 10 x log(/(Ryx? + lyx2)/2)
Phase CS-PHASE tan~"(lyx/Ryx)

Transfer Function (TF-REAL/TF-IMAG/TF-MAG/TF-LOGMAG/TF-PHASE)
The transfer function expresses the frequency characteristics between the input and the
output of a system. The transfer function is given by the ratio of the linear spectrum of
the output (Gy) to the spectrum of the input (Gx) at each frequency. Also, as can be seen
from the equation below, the transfer function can be defined as the ratio of the cross
spectrum of the input and output (Gyx) and the input power spectrum (Gxx).

Transfer Function = Gy/Gx = (Gy x Gx*)/(Gx x Gx*) = Gyx/Gxx = (Ryx + jlyx)/(Rx2 + Ix2)
The following items can be determined:

Item Expression Computation

Real part TF-REAL Ryx/(Rx? + 1x?)

Imaginary part TF-IMAG lyx/(Rx? + 1x?)

Magnitude TF-MAG V(Ryx? + lyx®)/(Rx2 + Ix?)

Log magnitude TF-LOGMAG 20 x log(Ryx? + lyx2)/(Rx2 + Ix?)
Phase TF-PHASE tan~"(lyx/Ryx)

The magnitude of the transfer function gives the ratio of the magnitudes of the linear
spectra of the output and input, whereas phase of the transfer function gives the phase
difference between the two.
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Coherence Function (CH-MAG)

This function expresses the ratio of the output power generated by the input to the
system to the total output power.

Coherence function = Gyx x Gyx*/(Gxx x Gyy)

Item Expression Computation
Magnitude CH-MAG (Ryx2 + lyx2)/(Gxx x Gyy)

If the output signal is due entirely to the input signal, the coherence function becomes 1.
As the ratio decreases, it falls below 1. Thus, the coherence function always takes on a
value between 0 and 1.

Note

» On one data acquisition, the coherence function becomes 1 across all frequencies.

* The computed waveform must be averaged.

Number of FFT Computed Points

You can select 100 points, 200 points, 500 points, 1000 points, 2000 points, 5000 points,
10000 points, 20000 points, 50000 points, 100000 points, 200000 points, 500000 points,
1000000 points, or 2000000 points.

About Time Windows

You can select rectangular, Hanning, or flattop as the time window.

The rectangular window is best suited to transient signals, such as an impulse wave,
that attenuate completely within the time window. The Hanning window allows continuity
of the signal by gradually attenuating the parts of the signal located near the ends of the
time window down to the “0” level. Hence, it is best suited to continuous signals. The
frequency resolution of the Hanning window is higher compared with the Flattop window.
However, the flattop window has a higher level of accuracy of the spectrum. When the
waveform being analyzed is a continuous signal, consider the above characteristics
when selecting the proper window to use.

Window Integral Power spectrum

Rectangular
window ‘4; T —>{ ‘
! |
AR AT

U~
<
Flattop

|
Hanning window T ‘j
Sine wave o /\ — P .
[T — avs
t 4 _
: r T »‘
TRt T W g AR
Rectangular window: W(t) = u(t) —u(t—T) U(t): Step function
Hanning window: W(t)=0.5- O.5005(2Tr+)
Flattop window: W(t) = {0.54 — 0.46cos(2m %)}

sin{2m(1 — 2UT)}
2m(1 — 20T)
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4.7 Inserting Annotations in the Waveform View

Procedure

Inserting Annotations

1. Click ¥ of 'A ™, V¥ or click View > Add Annotation and select Annotation
Type. There are eight types of annotations: text, DeltaT, DeltaV, marker, Delta
marker, waveform parameter, history statistics, and cycle statistics. The pointer
icon displayed in the tool bar or waveform view changes according to the selected
annotation. For details, see the explanation starting on the next page.

2. Insert the annotation using the appropriate procedure for the selected annotation.
For details, see the explanation starting on the next page. When selecting an
annotation of a particular type while in Annotation mode, if you click a different
type of annotation that was previously inserted, the selected annotation changes
to the clicked type. Select the type of annotation

Select the type of annotation
dow

Annotation input box

o Viewer1 H:\Documes
View w

8 Fi imalysis.

-

Number of D ata: 250000
3

Annotation Setting(Text)

T Set the annotation font and
color in the dialog box that
is displayed.

CH1
0

2.0000
NoO0OD  -24.99%m sl
Ready

26.0000m

—Inserted annotation

Inserting Annotations Using the (Right-Click) Shortcut Menu

When in Annotation mode, a shortcut menu is displayed when any of the following
operations is carried out. Click New and then the type of annotation to insert the
annotation in the screen.

* Right-click in the waveform display
Right-click to display the shortcut menu.
% v Text You can set the type of annotation
DeleaT to Text, DeltaT, DeltaV, Waveform
Deltatf Parameter, History Statistics, and
Cycle Statistics.

Paste

“Wave Pararmeter
History Statistics Marker and Delta marker cannot
Cycle Statistics be selected.

* Right-click a waveform

If you place the pointer on the
waveform, the information for

that point is displayed. Right-click to display the shortcut menu.

e v Text You can set the type of annotation
-8030us 8 DeltaT to Text, DeltaT, DeltaV, Marker,
il —} Deltat Waveform Parameter, History

Marker

Statistics, and Cycle Statistics.

“Wave Pararmeter
History Statistics Delta marker cannot be selected.

Cyile Statistics
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Explanation

Copying and Pasting Annotations

Click to select the annotation to copy, then right-click to display the same shortcut menu
mentioned on the previous page. Select Copy. Right-click the location onto which you
wish to paste the annotation, then select Paste in the shortcut menu that is displayed.

Editing Annotations

Click to select the annotation to edit, then right-click to display the same shortcut menu
mentioned on the previous page. Select Edit. A dialog box corresponding to the selected
annotation is displayed. Edit the annotation, then click OK or Apply.

Deleting Annotations
To delete annotations, click View > Delete Annotation > Selected Item or All Items.

4o Yiewer] C:¥WProgram Files\YokogawavieweriWaveDat
n File | view Analysis wWindow

=1

= [ w Toolbar
— v Status Bar = =
| = = fnalysis Bar Gr= | | Tl ey

v ‘Window control Bar

Channel Setting. ..
Display Setking. ..
Split Setting. ..

v Splic

Waveform Vertical Zoom&Move

Add Annotation »

Delete Annatation EEEEEEY
Al Teem

Auko Group...

You can also click to select an annotation you wish to delete and press the Delete
key. Or, you can click to select the annotation to delete, right-click to display the same
shortcut menu mentioned on the previous page, and then select Delete.

Annotation Types
There are eight types of annotations: text, DeltaT, DeltaV, marker, Delta marker,

waveform parameter, history statistics, and cycle statistics.
¢ Linked Annotations
» DeltaT, DeltaV, marker, Delta marker, waveform parameter, history statistics, and
cycle statistics are annotations that are linked to waveforms.
» If the text annotations is linked to a waveform, they are connected by link lines.
* You can insert annotations into individual waveforms. Links to each waveform are
preserved even if you switch the displayed group.
¢ Non-Linked Annotations
Text annotations without link lines are non-linked annotations. Their positions change
relative to the size of the screen.

Example of a Text Annotation

.. *{Non-linked annotation
[Pk aveform,

Walkage
~ Linked annotation

Link line

IM 701992-01E
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4.7 Inserting Annotations in the Waveform View

Annotation-Compatible Windows

» Text, DeltaT, and DeltaV annotations can be inserted into the main waveform display
window, zoom waveform display window, and XY waveform display window.

» Marker, delta marker, waveform parameter, history statistics, and cycle statistics
annotations can be inserted into the main waveform display window and zoom
waveform display window.

* Only DeltaT annotations can be inserted into logic waveforms.

Text Pointer Icon: *A

If you select a text annotation and double-click in the waveform view or on a waveform,
the following settings dialog box is displayed. You can set the annotation display format.
If you double-clicked on the waveform, a waveform-linked annotation is inserted.

Annotation Setting(Text) &|

Annotation input box

1 Display Format 1 w
[ Show Frame = Select this check box to apply a

frame to the annotation.

‘You can select the font and color.
You can select any color.

Font: Fant style: Size:
]Microsoft Sans Serif Fegular ]9 tlevits mall
Microsoft Se ErEEEEEE
M5 Sans Serif W
M5 Serif
O M Boli
€} Palating Linotype 16
Raavi 18 D
Camnla ]
v Self-Define l }
CH1
[Annotation Cokr.. | chiz }—Ypu can select the color of a Custom colars:
displayed waveform group. EEEEEEEN
SEiE EEEEEEN
|W’estem j
Defing Custom Colars »»
(] 3 Cancel

The color selection dialog box appears.

Display Example
: : Chang_ing the Character Size

Annotation with frame

Moving an Annotation Drag one of the four corners of the frame.

Link line
Select the annotation, then drag it.

If a link line flows outside of the waveform view when zooming or
changing the scale, the link line disappears.
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4.7 Inserting Annotations in the Waveform View

DeltaT Pointer Icon: ‘g

When you select a DeltaT annotation and perform procedure a or b below in the
waveform view, the X axis value is displayed.

a. Drag horizontally.

b. Double-click to display the dialog box below. You can set the trace (waveform) to
which the annotation is linked, the display format, the arrow style, and other items.
The measurement range of the new X axis value displayed when you double-click is 2
div.

Aauctating Setting{Petial) E' Preview of the value to be displayed
} (cannot be entered).
Preview |
liace CLH; = Select the trace (waveform) to which to
Display Format link the annotation.

Fart... [~ Show Frame

lEsEEomat auto v| Dedmal |5 =——— Set the text format and decimal places
(see section 3.2, but note that

— Set the font and frame (see page 4-32).

it “Exponential” is not one of the choices).
Arrou Weight |[+ r] + Select the arrow thickness.
™ show Addtionalline |[————1 ~- Draw an additional line through the tip of
W the arrow. Also select the thickness of the

additional line.
[ Don't Show Text

Shows a DeltaT annotation spanning
vertical cursors.

— The value is not displayed.

Display Examples

DeltaT annotation with additional line DeltaT annotation spanning vertical cursors
b ;;;7Additiona| line ' __Vertical cursors

Resizing arrows

i
Select an arrow, then drag it. To Select the tip of the arrow, then drag it.
move just the value, use the The value is updated according to the
same procedure as for moving a length of the arrow.

text annotation.

If the arrow flows outside of the waveform view

If an arrow flows outside of the waveform view
when zooming or changing the scale, the value
is not displayed.

Changing the character size
Same procedure as for text annotations.

IM 701992-01E
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4.7 Inserting Annotations in the Waveform View

DeltaV Pointer Icon: ‘IF‘U

When you select a DeltaV annotation and perform procedure a or b below in the
waveform view, the Y axis value is displayed.

a. Drag vertically.

b. Double-click to display the dialog box below. You can set the trace (waveform) to
which the annotation is linked, the display format, the arrow style, and other items.
The measurement range of the new Y axis value displayed when you double-click is 2
div.

Agpetatien SeltingiDelint) @ Preview of the value to be displayed
y (cannot be entered).
Preview | e
Trace CH1 = Select the trace (waveform) to which to
Display Format link the annotation.

I~ showfrane

HEaRormali alito »| pecmal [ ~i——— Set the text format and decimal places
(see section 3.2).

— Set the font and frame (see page 4-32).

Arrow skyle
Arrow Weight [+ oRe Select the arrow thickness.
[ Show Additionalline [ ——————] ~; Draw an additional line through the tip of

the arrow. Also select the thickness of the
\\ additional line.

I Link Cursar

I Don't Show Text

| o | canel | Shows a DeltaV annotation spanning
horizontal cursors.

L— The value is not displayed.

Display Examples

DeltaV annotation with additional line DeltaV annotation spanning horizontal cursors
Additional line S

Horizontal cursors

Moving a DeitaV Resizing arrows

‘I

Select an arrow, then drag it. To Select the tip of the arrow, then drag it.
move just the value, use the The value is updated according to the
same procedure as for moving a length of the arrow.

text annotation.

When zooming the waveform vertically Changing the character size

Same procedure as for text annotations.

The length of the arrow does not change
even when zoomed.

The value is updated according to the zoom
ratio.
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Markers Pointer Icon: sfx\_,

With marker annotations, the trace, X axis value, and Y axis value at the double-clicked

point are displayed. If you select a marker annotation and double-click the waveform, the

settings dialog box below is displayed.

* You can set the trace (waveform) to which the annotation is linked, the format, the
marker style, and other items.

» There are four marker styles. Each time you insert a marker annotation, a new style is
used.

Annotation Setting(Marker)

Preview of the annotation to be
displayed (cannot be entered).

Preview |CH1 {-0.94ms, 4,3313Y)

Select the trace (waveform) to which to

ehenneil el ' link the annotation.
Format  |Chamnelame + %-value + Y-¥ale v | —Select the displayed items.
Marker

Stie | o | ~| See |smal ~l—-Select the marker style and size.

Display Format

Fant... [ show Frame

Text Format Decimal

—Set the font and frame (see page 4-32).

Y-fixis |AutD = [ =
—Set the Y (vertical) and X (horizontal)

axis text format and the decimal places
(see section 3.2).

S-fids | AUtD ~ 5 <

Trace X axis value Y axis value

n

Moving markers

.....gLIh.klme.......

Select the marker, then drag it. Select the annotation, then drag it. Only the

Only the marker moves. annotation moves.

The value is updated according to If a link line flows outside of the waveform view

the new marker location. when zooming or changing the scale, the link line
disappears.

Changing the character size
Same procedure as for text annotations.
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4.7 Inserting Annotations in the Waveform View

Delta Marker Pointer Icon: 4,

With Delta marker annotations, the DeltaT annotation (X axis value) and DeltaV

annotation (Y axis value) are displayed between two markers.

» Select the Delta marker annotation, then drag starting from any one point on the
waveform to any other point on the waveform. A DeltaT annotation and DeltaV

annotation appear between the two markers.

+ If a Delta marker is placed between two different traces, only the Delta T annotation is

displayed.

Click the waveform Drag

Release the mouse button
at the second point

* ..D.5;2ms.. c
DeltaT annotation

Double-click on an annotation to display the settings dialog box below.
» The target trace (waveform), marker style, and other items relating to markers can be

set.

» There are four marker styles. Each time you insert a marker annotation, a new style is

used.

* You can set the display format, arrow style, and other items relating to DeltaT and
DeltaV annotations. Click the DeltaT or DeltaV tab to display the corresponding

settings.

Annotation Setting(DeltaMarker)

Marker1 CH1 - Markerz CH1
Marker

DeltaT l Dieltay ]

Preview | 0.52ms

Display Format

Fanit... I Shaw Frame

Arrow Style

v Shaw Arrow | j
¥ Shaw Additionalline | —_— j

Style - Size Small -

Text Format |Auto = Decimal 5 2

Apply | OF | Cancel |

I~ Select the target trace (waveform) for
each marker.

1~ Select the marker style and size. The
style and size of paired markers 1 and 2
are the same.

— Configure the settings of DeltaT and
DeltaV annotations that are used in
Delta marker annotations.

See the explanation of each annotation

on the previous page.

¢ Clear the Show Arrow check box to
hide the annotation’s arrow and value.

» There are no cursor linking and hide
value options such as those for DeltaT
and DeltaV annotations on the

previous page.
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Display Examples

Delta marker annotation with additional line  Moving markers

Marker 1

i
\,%Marker 2
T
Additional line Select the marker, then drag.iF. The.
arrow length, value, and additional line

are updated according to the new
marker location.

Moving a DeltaT | Resizing arrows (DeltaT annotation only)

ey

s Zﬁﬁﬁmﬁ”" : £

Select the arrow of the DeltaT Select the tip of the arrow, then
annotation, then drag it. To move just the drag it. The marker is moved and
value, use the same procedure as for the value is updated according to
moving a text annotation. the length of the arrow.

Select the arrow of the DeltaV annotation, then drag it.
L% Tomove just the value, use the same procedure as for
R [TEoma moving a text annotation.

If the arrow flows outside of the waveform view

With Delta marker annotations, if a DeltaT or DeltaV annotation arrow flows outside of the
waveform view when zooming or changing the scale, the value is not displayed.

Changing the character size
Same procedure as for text annotations.

IM 701992-01E
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4.7 Inserting Annotations in the Waveform View

Waveform Parameters Pointer Icon: m
When you select a waveform annotation and perform procedure a or b below in the
waveform view, the measured value of the waveform parameter is displayed.

a. Drag horizontally.

b. Double-click to display the dialog box below. You can set the measured items, the
trace (waveform) to which the annotation is linked, the display format, the arrow style,

and other items.

The measurement range of the new waveform parameter displayed when you double

click is 2 div.

Annotation Setting(Waveform Parameter)

hieazure em

Peak to peak value

Amplitude

Polgcimum

hnimurm

High lewel

Low lewvel

Average

fofiddle

RS

Standard daviztion

Owershoot

Undershoat

Rize time

Fall time

Frequency

Pariad

Plus width

Pofinuz width

Duty

Pulze count
Burst1
Burst2

Average frequency

Fyrerage period

Int 1T
Int2 T

Init 13

IntZEY

Trace CH1 =

Murnber of column [y =

Display farmat

Font... [ Show Frame

Text Format Diecimal

Y axis param Auko = 5 -
 axis pararn Auta bt 5 =

Arrow style
Prrom woih: -

v Show Additionalline El -

‘ [8]4 | Cancel |

JSeIect the trace (waveform) to
which to link the annotation.

— Select the number of
horizontally-displayed items
(columns).

— Configure the settings of fonts
and arrows that are used in
waveform parameter
annotations.

See the explanation of the
DeltaT and DeltaV annotations
on the previous page.

» Under Vertical axis
parameters, set the vertical
axis waveform parameter text
format and decimal places.
Under Horizontal axis
parameters, set the horizontal
axis waveform parameter text
format and decimal places.
There are no cursor linking
and hide value options such
as those for DeltaT and DeltaV

Measurement items Int1XY and
Int2XY cannot be selected.

annotations.
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4.7 Inserting Annotations in the Waveform View

Display Examples

Waveform parameter annotation Resizing arrows
with additional line

Anin d02ary ]}

Select the tip of the arrow, then drag it.
The value is updated according to the
length of the arrow.

Moving a waveform parameter annotation

] i%  As you begin to move it vertically,
PP V00N . the mark indicating the direction of
motion becomes | .

¥

{1 TR
{WEE 03|

Select the arrow of a waveform
parameter annotation, then drag \
it. To move just the value, use the

same procedure as for moving a

text annotation.

As you begin to move it horizontally,
the mark indicating the direction of
motion becomes <. The value is

" iMax 10403v[{ updated according to the

~iMin 10297} measurement range of the new
location.

If the arrow flows outside of the waveform view
If an arrow flows outside of the waveform view when zooming or
changing the scale, the value is not displayed.

Changing the character size
Same procedure as for text annotations.

Copying and Pasting Annotations
Place the pointer on an annotation or window and right-click to carry out the following
operations.

Operation When pointing to an annotation When pointing on the window
New No Yes
Delete Yes No
Copy Yes No
Paste No Yes
Edit Yes No

Saving and Loading Annotations

* When saving setting information, only non-linked annotations are saved. When saved
setting information is loaded, only non-linked annotations are recalled.

» For information on saving setting information, see section 5.5.

IM 701992-01E
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4.7 Inserting Annotations in the Waveform View

History Statistic Pointer Icon: N
When you select a history statistic annotation and perform procedure a or b below in the
waveform view, the measured value of the history statistics is displayed.

a. Drag horizontally.

. S LY R Y S
StdDew 169190
Dot B

b. Double-click to display the dialog box below. You can set the measurement items, the
trace (waveform) to which the annotation is linked, the display format, the arrow style,
and other items. The measurement range of the new history statistics displayed when
you double-click is 2 div.

Annotation Settings(History Statistics)

\eacire tem o — Select the trace (waveform) to
which to link the annotation.
Peak to peak walue N Trace CH3 -
P = |—— Select the number of
Meximum Mumber of column |1 =5 horizontally-displayed items
Mnimum i Histagram Settings (columns).
High lewel * X
v ispl .
i ey - Select the check box to display
i * Linear ¢ Log . . .
Auverage g, histograms in annotations.
’:;z'e Display Format 7 | Select whether to display the
— — I Show Frame hlstogrgm s Y axis using a linear
F— = or logarithmic scale.
Texk Decimal
Undershaat dh
Fise time ¥ axisparam | Adto ~| | =l 4 Configure the settings of fonts
Fal time and arrows that are used in
i Ak - g5 hd . . . .
Frequency I xawsparam  [ro ] = history statistic annotations
Period . .
= LT See the descriptions of the
Plus width Arrow skyle .
i DeltaT and DeltaV annotations
ity Arrow ° on the previous page.
Pulse court T p— j * Use the boxes next to Y axis
] R param to set the text format
Burstz i’ 2 and the number of decimal
:e"” '*f‘”:““‘ A places for the vertical axis.
e 1 Use the boxes next to X axis
Ty param to set the text format
T and the number of decimal
ey apty [k ] cenee | places for the horizontal axis.
2 » There are no Link Cursor and

|
Measurement items Int1XY and
Int2XY cannot be selected.

Don't Show Text options,
which are available for DeltaT
and DeltaV annotations.
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4.7 Inserting Annotations in the Waveform View

Display Example

History statistic annotation with additional lines

I History List

Click the ¥ mark to display
the history list.

History Mo,

>

W00 Additional

- |
lines

457 P I B O Y o gF\l

x| o[- T3BBTmb
in 13700my
Sfwe | o[- 13755m
StdDey 419660
[ = VA T I ™

Resizing Arrows and Moving History Statistic Annotations
The procedure for resizing arrows and moving annotations are the same
as for waveform parameter annotations.

If the arrow flows outside of the waveform view
If an arrow flows outside of the waveform view when zooming or
changing the scale, the value is not displayed.

ejeq wuojanep BuizAjeuy BN

Changing the character size
Same procedure as for text annotations

Nofte

» Canceling Annotation mode
In Annotation mode, a cancel button and a progress bar are displayed in the status bar.
Click the Cancel button to cancel Annotation mode.
If you cancel Annotation mode, the waveform display window only shows an arrow that
indicates the annotation range and not the values.

|
Cancel | - MUM I
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4.7 Inserting Annotations in the Waveform View

Cycle Statistic Pointer Icon: 41}
When you select a cycle statistic annotation and perform procedure a or b below in the
waveform view, the measured value of the cycle statistics is displayed.

a. Drag horizontally.

i Coont- 1B

5 L2067
in 16867 W
e 10247.

StdDev AE910 v |

b. Double-click to display the dialog box below. You can set the measured items, the
trace (waveform) to which the annotation is linked, the display format, the arrow style,
and other items. The measurement range of the new cycle statistics displayed when
you double-click is 2 div.

hkeasure fem

Peak to peak value

Amplitude

4

hiEimum

hifinimum

High lewvel

Low lewel

Puerage

hifiddle

Rhig
Standard dewiation

Overshoot

Undershant

Rise time

Fall time

Frequency

Perind

Plus width

hinus width

Duty

Pulze count
Burst1
Burst2

Puerage frequency

fuwerage period

Int 1T
IntZ T

It 13

It 23

Annotation Settings(Cycle Statistics)

On

)

Cycle Trace  |CH3 3
Trace CH3 3

Mumber of calurmn |1 L‘r

Histogram Settings
Iv Display
i * Linear ¢ Log

Display Format

Fort...

[ Show Frame

Texk Decimal
Y axis param m m
¥ axis param Auto hd m
Arrow skyle
sron ——~
I Show Additionallini [ ———— ‘j

Apply | OK |

Cancel |

f

P

1

|
Measurement items Int1XY and
Int2XY cannot be selected.

Select the reference trace for
cycle statistic measurements.

Select the trace (waveform) to
which to link the annotation.

Select the number of
horizontally-displayed items
(columns).

Select the check box to display
histograms in annotations.
Select whether to display the
histogram's Y axis using a linear
or logarithmic scale.

Configure the settings of fonts
and arrows that are used in
cycle statistic annotations

See the descriptions of the
DeltaT and DeltaV annotations
on the previous page.

* Use the boxes next to Y axis
param to set the text format
and the number of decimal
places for the vertical axis.
Use the boxes next to X axis
param to set the text format
and the number of decimal
places for the horizontal axis.
There are no Link Cursor and
Don't Show Text options,
which are available for DeltaT
and DeltaV annotations.

4-42

IM 701992-01E



4.7 Inserting Annotations in the Waveform View

Display Example

Cycle statistic annotation with additional lines

I Cycle List

Click the ¥ mark to display

the cycle list. il ]

>

wijm me pm o pe pw mm omm B00 Aqgitional
T L7 lines

457 P I B O Y o v%

T BEEr e A R T R T N P R
in 13700my

e | LorEmEEmY . [ E ]
StdDey 419660

[ = VA T I ™

Resizing Arrows and Moving Cycle Statistic Annotations
The procedure for resizing arrows and moving annotations are the same
as for waveform parameter annotations.

If the arrow flows outside of the waveform view
If an arrow flows outside of the waveform view when zooming or
changing the scale, the value is not displayed.

ejeq wuojanep BuizAjeuy BN

Changing the character size
Same procedure as for text annotations

Nofte

« Canceling Annotation mode
In Annotation mode, a cancel button and a progress bar are displayed in the status bar.
Click the Cancel button to cancel Annotation mode.
If you cancel Annotation mode, the waveform display window only shows an arrow that
indicates the annotation range and not the values.

Cancel I'ﬁ l_ I_ W I— Z
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4.8 Transferring a Waveform View to the Clipboard

Procedure

Transferring a Waveform View to the Clipboard

Click IEI to transfer the viewer window you are viewing as image data to the clipboard.
You can see the image by executing a paste command in an application that can handle
image data.

Transfer to Clipboard

4 ¥iewerl Di\Documents and[Settings'Administrator\Desktop)SampleWaveData'\2CHSINXYSW.WYF - [Timeviewer] =10 x|
8 File view Analysis windo| =13 x|

SEEEE| x|

LR A - OERERTE
ST SO0 2 5457 N oD
e 0000

50000

b L
YR Y

50000
NeOOOD 10011000 sl 0.0002000

Ready

Nofte
Only the waveform view is transferred to the clipboard without any image of the menu bars and
other functional components.
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Chapter 5

Saving Data/Converting Data Formats

5.1 Saving Waveform Data

Procedure

Saving Waveform Data in Binary Format

Click E or select File > Save As to display the Save File dialog box. Select the folder
into which you want to save the file, specify the file name, select YOKOGAWA waveform
file (*.wvf) in Files of type, set any other required options, and then click the Save.

To set the options, click the More Options.

Select the folder into which you want to save the file

T E—

Save in: |_)WaveData ! j EF BE-
LY oo et

L2 A 2cHsThg
My Fecent | @file_ood.wf
Documents ‘ﬂsamnla-zjk‘wvf

?“_:

[
Decklop
My Documents

My Computer

‘;'ﬁ | Specify a file name
My Metwork.  File name: b Save

Flaces B | J I—I

Save az lype: |YDKD GaA waveform file [ wf) j Cancel
' Select YOKOGAWA
GomEE waveform file (*.wvf)
— Type comments
Select Waveform | ‘ Set optlons for the
AL OFF

TraceMame ‘ Elockhum | Recordlength | Sampli # | |~ Tiata Sefting data format

A*ycHa 21 1,001,000

Q{CH‘I 21 1,001,000 Data Range: all hd

Osmatht 21 1,001,000 Compression:  |Hone +| l— Select the waveforms

OFmathz 21 1,001,000 ) to save

D%MathS 21 1,001,000 Compression Rate:

O mathe 21 1,001,000

O#maths 21 1,001,000 =

O#mathe 21 1,001,000 -

O mathr 21 1,001,000

OFvmaths 21 1,001,000 o o

O#matha 21 1,001,000

O#umathio 21 1,001,000 v

< b3 r

Saved WVF files can not be loaded on the measuring instrument*.
* DL series, SL1400, SL1000

IM 701992-01E
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5.1 Saving Waveform Data

Saving Waveform Data in ASCIlI Format

Click E or select File > Save As to display the Save File dialog box. Select the folder
into which you want to save the file, specify the file name, select ASCII file (*.csv) in
Files of type, set any other required options, and then click the Save. To set the options,
click the More Options.

Select the folder into which you want to save the file

T

Save jn: |lf] G5WDats ' j &5 B
2. ] 000.csv
= L] 2CHSINAY sy

My Recent %]f\le_UUU.csv

Documents L] sample-2 Bk.csy
%]ngli_[l‘l _up.osy
%]ngli_ElZ_un.csv
Deskiop L] Wing® 01 up.csv
%]ng&UZ_un.csv

=

\$

My Documents

=
=
[w] 1
& i@
s o
i
T

. I Specify a file name

Myprlqait;vsork Filz narne: | | j Save |
Save a3 lvpe: |ASEII file [* caw] | ﬂ Cancel
Select ASCII file
(*.csv)
SR e T | Select the waveforms
ALL OFF
TraceMame ‘ Blockhum | Recordlength | Sarnpli # o - to save
— ata Setting

[ e 21 1,001,000
‘R\jC?—H 21 1,001,000 Data Range: Al - .
OAsmathn 21 1,001,000 Compression:  [Hone -] I— Set options for the
OFumathe 2 1,001,000 4 data format
Dﬂ\fl‘dathS 21 1,001,000 Compression Rate:
Dﬂ\jMath‘t 2t 1,001,000 ASCII File setting
O0%smaths 21 1,001,000 F Mo Honder

Mathe 21 1,001,000 - i
= A I™ Time &xis Information Set options for the
O%smath? 21 1,001,000 file f t
A maths 21 1,001,000 [ g lle torma
O%smatha 21 1,001,000
O"mathin 2 1,001,000 v
< | S -

5-2

IM 701992-01E



5.1 Saving Waveform Data

Saving Waveform Data in XLS Format

Click E or select File > Save As to display the Save File dialog box. Select the folder
into which you want to save the file, specify the file name, select Excel file (*.xls) in Files
of type, set any other required options, and then click the Save. To set the options, click
the More Options.

Select the folder into which you want to save the file

T )

Save n |_) Sample ' j EF E-
e
My Recent
Docurnents
?::
@
Desklop
My Documents
hy Computer
"Q Specify a file name
.1 |
My Metwark, File name: | <~ Save
Flaces | J I_I
Save a3 hype: |EKCEI file [*x5] | j Cancel
Select Excel file
(*.xIs)
Select the waveforms
Select WaveFarm I ‘ n
ALL OFF O save
TraceMame ‘ Blockhum | RecordLength | Samnpli A o -
ata Setting
E* ks 21 1,001,000
MAycrs 2t 1,001,000 e licc I A A ]
O wmatht 21 1,001,000 Compression:  |[Hone -| [7— Set options for the
OFmathz 21 1,001,000 ) file format
D%Matlﬁ 21 1,001,000 Compression Rate:
D%Math‘t 2 1,001,000 Excel file setting
OFmaths 21 1,001,000
O mathe 21 1,001,000 L e :
o I Time Axis Infarmation — Set options for the
O math? 21 1,001,000
OFwmatha 21 1,001,000 [ g data format
O maths 21 1,001,000
O ymathio 21 1,001,000 v
< ¥ r

Saving as a Floating Point Decimal File
For products of version 1.60 or later, you can save waveform data as a floating point
decimal file.
Click [ , or select File > Save As to display the Save File dialog box. Select the folder
into which you want to save the file, specify the file name, select Floating Decimal Point
(*.fld) in Files of type, set any other required options, and then click the Save. To set the
options, click the More Options.

Save Format of Floating Point Decimal Files

You can save the displayed waveform data to an FLD file (single precision floating

point decimal format). FLD files can be loaded by general purpose analysis software

such as MATLAB.

Floating Point Decimal File Save Options

When saving waveform data to FLD files, you can specify options in addition to the

waveform to save.

» Range to save: Select All, Zoom Range, or Cursor Range

» Compression: Select None, PP Comp, or Decim

» Compression Rate: Selectable when Compression is specified.

Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000

IM 701992-01E
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5.1 Saving Waveform Data

Explanation

Files Saved in Binary Format

Displayed waveform data are saved in WVF format (a Yokogawa proprietary format).
The saved data consists of the active waveform data and that for the block checked in
the history window.

Options for Saving Binary Files
When you save waveform data in WVF format, you can not only select the waveforms to
save but you can also set the following options:
» Range to save: Select All, Zoom Range, or Cursor Range
» Compression: Select None, PP Comp, or Decim
» Compression Rate: Selectable when Compression is specified.
Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.

Files Saved in ASCIl Format
Files saved in ASCII format conform to CSV format.

Note

» For waveform data that is divided into blocks, you can save only one block in ASCII format
(CSV file).
» Data cannot be saved to WVF or CSV format if the file size exceeds 2 GB.

Options for Saving CSV Files
When you save waveform data in CSV format, you can not only select the waveforms to

save but also set the following options:

Data Settings

» Range to save: Select All, Zoom Range, or Cursor Range

» Compression: Select None, PP Comp, or Decim

» Compression Rate: Selectable when Compression is specified.
Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.

File Settings

» Header: Select whether to set a header

» Time-Axis: Select whether to set information about the time-axis

» Relative Time/Absolute Time: Selecting Absolute or Relative Time (Available When
the Time Axis Information Check Box Is Selected)

Relative Time: Displays the measurement time relative to the trigger position.
Displays and saves data to the left of the on-screen trigger
position as negative values, and data to the right as positive
values.

Example: -0.00499984, 0 (Trigger position), 0.00499984

Absolute Time: Displays and saves data at the actual measured time (per the
clock).

Year/Month/Day Hour:Minute:Second

Example: 2007/07/07 18:03:47.4750002,
2007/07/07 18:03:47.48,
2007/07/07 18:03:47.4849998

Files Saved in XLS Format
Files saved in XLS format conform to MS Excel format.
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5.1 Saving Waveform Data

Options for Saving XLS Files
When you save waveform data in XLS format, you can not only select waveforms to save
but also set the following options:

Data Settings

* Range to save: Select All, Zoom Range, or Cursor Range

» Compression: Select None, PP Comp, or Decim

» Compression Rate: Selectable when Compression is specified.
Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.

File Settings

» Header: Select whether to set a header

» Time-Axis: Select whether to set information about the time-axis

Note

For waveform data divided by the block, you can save only one block you focus on into the XLS

format.

File names:
The following file names cannot be used.
AUX, CON, PRN, NUL, CLOCK, COMO to COM9, and LPTO to LPT9

IM 701992-01E
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5.2

Explanation

Transferring Waveform Data into Excel

Transferring Waveform Data into Excel

Click =] or select File > Save As to display the Save File dialog box. Select Excel
transport (*.) in Files of type, set any other required options, and then click the Save. To
set the options, click the More Options.

Save As |E| El

Save jn: | I Sample
LY

My Recent
Documents

5

Desklop

&

tdy Diocuments

tdy Computer
My Wetwork,
Flaces

L

File name:

Save as lype:

o

B cf B~

Need not be set

|ExcEL

|EKCE| tranzpoit []

ﬂ Save |
j Canicel

File name fixed

Close Options

Select Excel transport (*.)

Select Waveform

Tracelame

‘ B\ocKNuml RecordLengthl Sarmnpli #

R cHs
[ [T
O/ matht
O/ mathz
O/ mathz
O/ mathe
O/ maths
O/ maths
O/ math?
O/ maths
O/ matha
O~mathio
<

1,001,000
1,001,000
1,001,000
1,001,000
1,001,000
1,001,000
1,001,000
1,001,000
1,001,000
1,001,000
1,001,000

1,001,000 v

I
ALL OFF ‘

Data Setting
Data Range: all -

Compression:

Compression Rate:

Excel transport setting

I Mo Header

I™ Time &xis Information
ie o

Mone 2 0

Select the waveforms
to transfer

— Set options for the
data format

— Set options for the
file format

Transfer to Excel

The Transfer to Excel command directly redirects data for the selected waveforms to an
Excel sheet. Clicking the Save button automatically starts up Excel and then plots the
waveform data onto an Excel sheet according to the specified format options.

Note

« If there are a number of channels, Transfer to Excel may take a long time to complete in
some operating environments. In such a case, save the data into a CSV file, and then read
the file into Excel.

» Using the mouse to close the sheet opened by the Transfer to Excel feature causes Xviewer
to malfunction when you execute Transfer to Excel again. If you need to close the sheet
and execute Transfer to Excel again, close the first sheet, quit Xviewer, and then execute
Transfer to Excel again.

*  When the measured values exceed the measurement range, or the size of the computed
waveform data is smaller than that of the measured waveform data, the waveform data is
not saved. In this case, a value of “65535” is written into each cell.
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5.2 Transferring Waveform Data into Excel

Options for Transfer to Excel
When you transfer waveform data to Excel, you can not only select the waveforms to

transfer but also set the following options:

Data Settings

* Range to save: Select All, Zoom Range or Cursor Range

» Compression: Select None, PP Comp, or Decim

» Compression Rate: Selectable when Compression is specified.
Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.

File Settings
» Header: Select whether to set a header
» Time-Axis: Select whether to set information about the time-axis

IM 701992-01E
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5.3 Saving Waveform Data in a View

Procedure

Explanation

Saving Waveform Data in a View

Click =] or select File > Save As to display the Save File dialog box. Select the folder
into which you want to save the file, specify the file name, select Image file (*.bmp) or
Image file (*.png) in Files of type, and then click the Save.

Select the folder into which you want to save the file
Save i IaWaVBData | j L] £ E3-

Type comments

Specify a file name

File rlarne: I j Save
' &l

Save| & type IImage file [ brap] Cancel

Comment: SeleCt
=] Image file (*.bmp) or
Image file (*.png)

=l ’—I
More Cplions

Files Saved in BMP/PNG Format

You can save the viewer window you are viewing into an image data file in either BMP or
PNG format. You can attach comments to the file, but the file can include only one line of
comments.
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5.4 Saving Automated Measurement Values
forWaveform Parameters

Procedure

Explanation

Saving Values Automated Measurement Waveform Parameters

Click (=] or select File > Save As to display the Save File dialog box. Select the folder
into which you want to save the file, specify the file name, select Waveform parameter
(*.csv) in Files of type, and then click the Save.

Select the folder into which you want to save the file

Savein I@WaveData ! j - o FEr

Desktop

ﬂti"‘\

My Documehts

Specify a file name

File name: I j Save I
Save as lype [/ avetom parameter [*.csv) =l Cancel |
Comment: Select Waveform
=] parameter (*.csv)
;I Mare Options I

Files Saved in Waveform Parameters (*.csv) Format

You can save the automated measurement values for the specified waveform
parameters, history statistics, and cycle statistics (values displayed in the measurement
result display window) in a .csv file.

Saved Data

Among the automated measurement values, the following data is saved.

» Measurement results for block selected in the history window

» Trace measurement results for channel setting for which the cursor display is ON

IM 701992-01E
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5.5 Saving the Display Settings

Procedure

Explanation

Saving the Display Settings

Click =] or select File > Save As to display the Save File dialog box. Select the folder
into which you want to save the file, specify the file name, select Setting info (*.xml) in
Files of type, and then click the Save.

Select the folder into which you want to save the file

L 2]

Save in: I@WavaData ! j - & E9-

Type comments

Specify a file name

File 1fame: I j Save I
| Gav| az type ISettimg info [*.uml] j Cancel |

Setting info (*.xml)

Comment:

| W
Mare Options

Files Saved in Setting info (*.xml) Format

You can save the display settings specified for the viewer window you are viewing into
a .xml file. You can also include comments. Loading a Display Setting file already saved
applies the display settings in the file to waveform views.

Automatically Saving Display Settings

With software products of version 1.34 or later, when waveform data analysis is finished,
the corresponding display settings are automatically saved.

The next time waveform data is loaded, the corresponding display settings are
automatically loaded.

Nofte
The function that saves display settings automatically uses the MD5 Message Digest Algorithm
by RSA Data Security, Inc.
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5.6 Converting Multiple Waveform Data Files to
CSV Files

Procedure

1. Close the viewer window.

2. Click Tool > CSV Multiple files conversion on the Xviewer tool bar to display
the CSV Multiple files conversion dialog box.

A Xviewer

Fle View window Connect | Tool Help
7l ] B ?

Controller | Mew Yiswer thing  Openlnst. ControlInst,  ACQ save Help

WHE Multipls files conversion. ..

3. Select the files (WVF or WDF files)* to convert and options and click Save. The
Browse For Folder dialog box opens.

*

You can select one or more WVF and WDF files for conversion. To select multiple files,

hold down the Ctrl key while clicking to select them. When multiple files are selected, all 5
are converted to CSV files collectively.
4
Example with multiple selected files <
=}
CSY Multiple files conversion (%e]
Lok i |_J\N'aveDala j = & B QU’
-
L oo, 1<}
€] A sCHSIEY wF o)
My Recent o]
Documents =}
@ | 5
(e g4_02_ Select the =
ekl i . . —
P |l 01w J required file 5
_ ‘ﬂngS_DZ_uu‘wdf @
7 o
My Documents 2
Q
Q M
'_;g ]
My Computer 3
- Q
-
v ] (7]
My Metwork — Fil : "afingd_02_up.wdf" "fle_DO0.wed" "sample-2_ ¥ ja]
yplai;nr ile name: | ingd_02_up.w ile:_| w" sample 7J pen
Files of type: [OKOGEWS wavefarm file [* w* w) | Cancel
Diata Setting ASCII file setting
Compression: | None | Compression Rate: [ Mo Header
[ File division For each hiskary r T(‘TE fids Infarmation
5
- Set options for the data format L Set options for the file format

4. Select a save destination folder and click OK. The converted CSV files are saved
in the selected folder.
Converted files are only given the csv file name extension.

Browse For Folder 2 x|

L Lioss -]
-] sL1000

B wTviewer

EID Hviewer

— Select the save destination folder

1 waveData
A o =

O I Cancel | Newlfolder |

| 4
Select to create a new folder
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5.6 Converting Multiple Waveform Data Files to CSV Files

Explanation

Option Settings
You can specify the following two options for waveform data files to convert to the CSV
format:

Data Settings
Compression: Select None, PP Comp, or Decim
Compression Rate: Selectable when Compression is specified.
Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.
File division for each history: Select whether to divide file into every history

waveform.

File Settings
Header: Select whether to set a header

Time-Axis: Select whether to set information about the time-axis

Relative Time/Absolute Time: Selecting Absolute or Relative Time (Available When
the Time Axis Information Check Box Is Selected)

Relative Time:

Absolute Time:

Displays the measurement time relative to the trigger position.
Displays and saves data to the left of the on-screen trigger
position as negative values, and data to the right as positive
values.
Example: -0.00499984, 0 (Trigger position), 0.00499984
Displays and saves data at the actual measured time (per the
clock).
Year/Month/Day Hour:Minute:Second
Example: 2007/07/07 18:03:47.4750002,

2007/07/07 18:03:47.48,

2007/07/07 18:03:47.4849998

Records Horizontally Arranged

CH1-Record1-data001,

CH1-Record1-data002

CH1-Record1-data100

CH1-Record2-data001,

CH1-Record2-data002

CH1-Record2-data100

CH1-Record3-data001,

CH1-Record3-data002

CH1-Record3-data100

Note

CH2-Record1-data001

, CH2-Record1-data002
CH1-Record1-data003,

CH2-Record1-data003

, CH2-Record1-data100

CH2-Record2-data001

, CH2-Record2-data002
CH1-Record2-data003,

CH2-Record2-data003

, CH2-Record2-data100

CH2-Record3-data001

, CH2-Record3-data002
CH1-Record3-data003,

CH2-Record3-data003

, CH2-Record3-data100

Data cannot be saved to CSV format if the file size exceeds 2 GB.




5.7 Converting WDF Files to WVF Files

1. Close the viewer window.

2. Click Tool > WVF Multiple files conversion on the Xviewer tool bar to display
the WVF Multiple files conversion dialog box.

i Xviewer
File ‘View Window Connect | Tool Help

) 3 kil W o= m 2

Controller | New Viewer thing Openlnst. ControlInst,  ACQ save Help

3. Select the WDF files* to convert and options and click Save. The Browse For
Folder dialog box opens.

*

You can select one or more WDF files for conversion. To select multiple files, hold
down the Ctrl key while clicking to select them. When multiple files are selected, all are
converted to WVF files collectively.

Example with multiple selected files

WYF Multiple files conversion 2x|
Savein: | WaveData x| = @k E-

(000, wdf

i eorsey
| Fle_noa.wdf

Select the
required file

File name [ asingS_02_up walf" "afingd_02_up wel” "asin = | save |
Saveastpe: | YOKDGEWA wavetorm e [%wdi] =l Cancel |

ASCIL File Setting
™ o Header
I= i fzds Infarmation
£ absalute Time
& Relative Time

sjew.o ejeq Buieauo) eleq Buineg S,

"Data Setting ‘

Compression: Mone 'I Compression Rate: |20 'I

— Set options for the data format

4. Select a save destination folder and click OK. The converted WVF files are saved
in the selected folder. Converted files are only given the wvf file name extension.
Converted WVF files can not be loaded on the measuring instrument.

Browse For Folder 7] x|
&1 51000 2]
{:l WTWiewwer
=) D g
] cavoata
1| Select the save destination folder
-] Sereenrint
e =l
Qk I Canicel | Mew Folder |
| &

Select to create a new folder
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5.7 Converting WDF Files to WVF Files

Explanation

Option Settings
When converting a WDF file containing measured waveform data to WVF format, you
can select WVF format options. The options that can be specified are as follows.
Data Settings
» Compression: Select None, PP Comp, or Decim
» Compression Rate: Selectable when Compression is specified.
Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.

Note

Data cannot be saved to WVF format if the file size exceeds 2 GB.
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5.8 Converting WDF/WVF Files to FLD Files

Procedure

1. Close the viewer window.

2. Click Tool > FLD Multiple files conversion on the Xviewer tool bar to display the
FLD Multiple files conversion dialog box.

4 Xviewer EYE
File Wiew Window Connect BEER Help

® = €5V Muliple files conversion... o] 2 B %

VWP Multple Fles conversion,.. Ling  gpen Inst,  Control Inst,  ACQ save Help
FLD Multipl Fil rsion, .,
DL Advancsd Lty 3

Contraller Mew Viewer

3. Select the WDF/WVF files to convert* and any options, then click Save. The
browse folders dialog box is displayed.

* You can select one or more WDF/WVF files for conversion. To select multiple files, hold
down the Ctrl key while clicking to select them. When multiple files are selected, all are
converted to FLD files collectively.

4. Select a save destination and click OK. The converted FLD file is saved in the
selected folder.

Converted files are only given the fld file name extension.
Converted FLD files can not be loaded on the measuring instrument.

Explanation

Option Settings
When converting a WDF file containing waveform data to FLD format, you can select
FLD format options.

Data Settings

» Compression: Select None, PP Comp, or Decim

« Compression Rate: Selectable when Compression is specified.

Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000

Nofte

» Data cannot be saved to FLD format if the file size exceeds 2 GB.
» FLD files are in single precision floating point decimal format.
« FLD files can be loaded by general purpose analysis software such as MATLAB.

IM 701992-01E 5-15
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Chapter 6  Printing Waveforms in the Displayed View

6.1 Setting Up a Printer

Procedure

Setting Up a Printer

Select File > Printer Setup.... to display the Printer Setup dialog box.

Select a printer and specify the paper size, orientation, and other settings in the dialog
box, and then click OK.

Set up the properties
Select a printer of the printer

Print Setup

Prinker

Mame; lEIki OLST0-PS w201 3.10(1035F5) ﬂ Properties...

Statug; Ready
Type: Oki OLBY0-PS »2013.108
where:  IP_10.0.228 42

Comment:
Paper Origntation
Size: v @ Porrait

Source: | Automatically Select | " Landscape
Metwork. .. ok | Cancel

Select the paper — Select the orientation
size and feed

— Set up a network printer

Explanation

Set up the printer according to your system configuration.

M3IA pakeldsiq ayj} ul swaojaAep) Bunuiid ﬂ
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6.2

Printing Displayed Waveforms

Setting Up the Print Format
Select File > Print Format to display the Print Format dialog box. Fill in the comment,
header, and footer fields, specify the print mode settings, and then click the OK.

Check to print the comments

on the printout Enter comments

Print Format

HEADER: | Header — Enter text for
COMMENTS: | Comment the header
v
FOOTER:
Foater —1 Enter text for
FRINT MODE the footer
—— { DISPLAY * LONG  WINDOW/PAGE |1 -
Iy Set background color ko white when printing
Preview, . | oK | Cancel |
— Select to print L Display a — Select number of
with a white Print Preview windows for LONG
background

Select print mode

Printing

Click = to display the Print dialog box. Click OK to start printing with the settings you
specified in the Print Format dialog box.

Print

Print dialog box

" Viewer 1 Woc ss\doc_publiclyasuelwave\DL 750\w4020CY2_1KP. WVF - [ FimeViewer ]

- Pinter-

| Neme:
| Stetus  Ready

Type  OKiDLG7OPS v2113108
| Wheie  IP_10022842

Comment

I~ Pintto e

Frint range

Al

© Pages from:[1 to

1% “seteotior

Copies

Numberof copiess |1 =

W ool

6-2
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6.2 Printing Displayed Waveforms

Explanation

Printable Information
You can specify the printing of the following types of information on printouts:
e COMMENTS: Comments (printed under the waveforms.)

e HEADER: Page header
* FOOTER: Page footer
Print Mode

Set the following items for the PRINT MODE selections:
e DISPLAY: Mode in which the display on the screen is printed as is
* LONG: Prints the waveforms (main waveform display window), separating them
by the zoom rate specified for the zoomed waveform display window.(The
entire waveform view is printed by the zoomed waveform display window,
starting from the left end. In the dialog box, the size of the zoomed
waveform display window is in units of one window*.) Set a value of 1 to
10 for “WINDOW/PAGE” for the number of windows to be printed on one
page.
* The number of windows printed equals (the number of points displayed in the
main waveform display windows) divided by (the number of points displayed in the
zoomed waveform display windows), or (quotient of the division) + 1.

Print Preview

Click the Preview or select File > Print Preview to switch the viewer window to the print
preview. This lets you check the layout of the sheet you are going to print. To proceed
with printing, click the Print.

Printout Sample

Print Mode: DISPLAY Print Mode: LONG

Triggor Time: 2004 12/07 15:49.05.94
Groupl B

e

ST N R
i Y .
2 ﬂ
00000

@E”Wlﬁa“””“ (100ms/div) . (F )] Stow ‘]

T Time: 2004712707 15450584 Norbar of Dita: 200001

M3IA pakeldsiq ayj} ul swaojaAep) Bunuiid

- Fast

K o

Thathl

20000 _
No0OOD  -3002435 2002495

KTME OIS

PLNT WS - L0
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6.2 Printing Displayed Waveforms

Printing Background

Select a background color to use when printing.

» Select: Prints with a white background.

e Clear: Prints with the background color displayed on screen.

Printing Example

When printing with the on-screen When printing with the background color
background color set to white

i
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Chapter 7

Report Function

7.1

Using the Report Function (Xreport)

Procedure

Starting the Report Function

While waveforms are shown on the Viewer window, choose Create Report from the File

menu. The Xreport window opens.

Toolbar . e .
Window Image Element Display/edit fields of items

Text Element

Image Element

Please select an slement:
asic [nomation
|5 Properties

in Jrigger Tme. 2004/10/06.19.3472.89 =
Gioupl Frequency Fesolian. 20000kHz | == T = [rescer |
[ o : h
70,000 -m |} ) Author lauthor:
0.0000 200000k [H] 938 nnnyl\ Date Date: 11/Aug/2006

Xreport D:\PROGRA~1Yokngawa\Xviewer\Reportisamyle3.xrt x|
EERIEIEIEY: -
[~ Report List Layogit [Emenl P A
=/ Element Properti
H Header e
samplel = Tupe leasure Result .
Author Date s frime iewer — Element Properties
Faont barial(9)
E Align Center
: _ (oceam| ) o fo
Xviewer Report
. L) BackColor|No Fill
= : = AuteFentiFalse

= - — Basic Information
Comment
Footer Tttt o e
T
Layout View Measurement Result Element Display/edit fields of items
Report List Window Image Element (FFT)

e Toolbar

Open a report file (see section 7.3)

Save the report file (see section 7.3)

Delete a report file (see section 7.3)

Set the orientation to portrait (see section 7.4)
Set the orientation to landscape (see section 7.4)
Print (see section 7.4)
Print preview (see section 7.4)

sEX[Es(&l o @ 7 nnH

Bring to front (see section 7.2)
Delete an element (see section 7.2)
Add an element (see section 7.2)
Switch to edit mode (see section 7.2)
Redo (see section 7.2)
Undo (see section 7.2)

Options (see section 7.2)
Send to back (see section 7.2)

IM 701992-01E
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7.1 Using the Report Function (Xreport)

Explanation

Starting the Report Function
If you start the report function, the Xreport window opens. The window shows the
waveform that was shown on the Viewer window.

Xreport Window

The Xreport window consists of the following four items.

* Report List: Lists the report files with a layout image.

» Layout View: Shows elements such as waveforms and measured results.

» Element Properties: Shows/edits the properties of each element.

» Basic Information: Shows/edits the header, footer, author, date, and comment.

Report List
The report files saved in the folder below are listed with a layout image.

Xviewer installation folder > Report folder

(The default location is C:\Program Files\Yokogawa\Xviewer\Report)
The report file stores position information and properties of each element that is
positioned on the Layout View as well as basic information. The report file that you select
on the Report List is used to lay out the Layout View.
By default, the five report files (Sample1 to 5) are available. You can edit these files.

Layout View

The Layout View consists of elements, the header, the footer, the date, and the comment.

There are four types of elements available, and multiple elements can be placed on the

Layout View. When you create an element, a unique ID is assigned in order. Element1

cannot be deleted.

» Text Element: An element for placing text.

*  Window Image Element: An element for placing the image of the Viewer
Window. You can select the main, zoom, or XY display
of the Time Viewer waveform or the main, zoom, XY
display of the FFT Viewer waveform.

However, FFT Main, FFT Zoom, and FFT XY can be
placed only if the FFT Viewer is shown on the Viewer
Window.

» Measurement Result Element: An element for placing the measured results. The
measured results do not need to be shown on the
Viewer Window.

* Image Element: An element for placing the image data. A jpg, bmp, tif,
or png image can be placed.
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7.1 Using the Report Function (Xreport)

Element Properties
Shows the common properties and the properties by type for the selected element. You
can change the properties by turning Edit Mode ON.

¢ Common Properties
Element ID: Assigned automatically when an element is created. It cannot be
changed.
Type: Text, Window Image, Measure Result, or Image.

* Properties by Type

Text

Text:

Font:
Align:
BackColor:

Window Image
Target:

Measure Result

Target:

Font:

Align:
ColNum:
RowNum:
BackColor:
AutoFontSize:

Image
File Path:
H Align:
V Align:
Zoom:

Basic Information

Text (can be edited regardless of the ON/OFF state of Edit Mode).
Font, style, size, and so on to be used.

Alignment (right, left, or center).

Background color.

Time Main, Time Zoom, Time XY, FFT Main, FFT Zoom, or FFT XY.

Time Viewer or FFT Viewer.

Font, style, size, and so on to be used.

Alignment (left, center, or right).

Number of columns

Number of rows

Background color.

Automatic adjustment of the font size (True or False).

The path to the image file. Specified in the Open dialog box.
Horizontal position (Left, Center, or Right).

Vertical position (Top, Center, or Bottom).

Magpnification (Select Auto, Fix, 0.50, or 2.00. You can also set an
arbitrary magnification.)

Shows the header, footer, author, date, and comment. You can change the information
regardless of whether Edit Mode is ON. Basic information is shown at a fixed position in
the Layout View and cannot be deleted.

Nofte

« If you start the report function (Xreport), the contents of the Viewer Window are laid out in

the Layout View according to the settings of the most recent report file in the following folder.

Xviewer installation folder > Report folder

(The default location is C:\Program Files\Yokogawa\Xviewer\Report.)
» The report list can show up to 64 report files.
» If you turn Edit Mode ON, you can change the size of each element by dragging the frame.
» Font size designation is invalid if AutoFontSize is set to True.

uonjoun4 poday H



7.2 Editing Reports

Procedure

Selecting the Layout

Click the desired layout from the Report List. Layout View, Element Properties, and Basic

Information are set according to the selected report file.

Enabling Edit Mode

Click the Edit Mode on the toolbar. When Edit Mode is ON, you can add or delete

elements and change the element properties.

Adding an Element

Select the element you want to add from the drop-down menu of the Add Element on

the toolbar. A crosshair cursor appears in the Layout View. Drag the cursor to add an

element of the desired size.
Select the layout

Edit Mode
Add Element
xreport D:\ PROGRA~1'Yokogaw: | Xvic werReportisample3.xrt x|
X Ba @R /zm-E%%
~Riepoit Lit -~ Layout ~Element Frops
|5 Element Properties
Bl ement 1o ([N
sample] = Tupe Measure Result
Target | Time Yiewer
Fant. Arial(3)
1T Alon | Center
Colbum |4
sarmple? . YOKOGAWA e
Xviewer Report
,_\ BackColer| No Fill
. arne olse

Main Trigger Time: 2004/10406 1934:22.83
Groupl iy 50000ns

Element ID
Please select an slement:

- Basic Information

No0DDD  -25000m 8] 25045m
|5 Properties

Main Tiigger Time: 2004/10/0613:34:72.89

Graup! Fre

quency Fesoliion. 20000kHz : Header Header
il B Author Author:

No0ODD 200000k [H  93g000k Date Date: 11/Aug/2006

Ef

r
ou can inpu the text of header

Changing the Element Properties
Click the item field you want to change.

» Editing a Text Element

r— Element Propertie:

=l Element Properties

El ElementID | Element3 Select the element number
5 Tvee Text Select the type (Text, Window Image,
This sample 1 is composed of the
Text Please select the element, and e Measure Result, or Image)

Elementl: Text (Title)
Elementz: WindowImage (Time M

Element3: Text f
Element4: Measure Result {Time ' Edit the text
=1 FEr Trnm

Fork | Arali14) Set the font

EZ /E -1 Sclect the alignment (Left, Center, or Right)

BackZalor| No Fill Set the background color

Align
‘fou can change the type of align.
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7.2 Editing Reports

» Editing a Window Image E

lement

— Element Propertie:

=l Element Properties

[=]' Element IT Element2

= Type Window Image

________________ [ Target || = Select the waveform to be displayed

(Time Main, Time Zoom, Time XY,
FFT Main, FFT Zoom, or FFT XY)

Target

‘fou can select the bype of waveform image.

* Editing a Measure Result Element

— Element Propertie:

=l Element Properties

[=]' Element IT Element4

= Type Measure Result

Target | Time Yiewer

———Turn ON/OFF the automatic adjustmentof the font size (True/False)

Faont 145 I Gothic{9)

—Set the font

Center

——Select the alignment (Left, Center, or Right)

4

— 7 —Set the number of columns

Rowhum | B

——Set the number of rows

BackColor| No Fill

——Set the background color

AutoFonti True

———Turn ON/OFF the automatic adjustment

of the font size (True/False)

ColNum
You can set the number of colurmn,
Minirmurn is 1. Maximum is 30,

» Editing an Image Element

— Element Propertie:

=l Element Properties

[=]' Element IT Element4

= Type Image

FilePath

———— Specify the path to the image file

Halign Left

Select the horizontal position (Left, Center, or Right)

Yalign | Top

Select the vertical position (Top, Center, or Bottom)

Zaom Auto

Set the magnification of the image file*

(Auto, Fix, 0.50, 2.00, or an arbitrary magnification)

FilePath
‘fou can select an image file to display.

*  Auto: Adjusts the size so that the image fits in the Image Element frame.
Fix: Shows the image at the original size.
0.50: Shows the image at one-half the original size.
2.00: Shows the image at twice the original size.
Any: Shows the image by expanding or reducing the image to an arbitrary size.

IM 701992-01E
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7.2 Editing Reports

Explanation

Deleting an Element
Select the element you want to delete in the Layout View. Click the Delete Element on
the toolbar. The selected element is deleted.

Sending the Element to the Back or Bringing the Element to the Front
Select the element you want to move and click the Send to Back or Bring to Front.

Changes the Basic Information
Click the Header, Footer, Author, Date, or Comment field and change the contents.

Aligning the Elements
Select whether to align the elements with the grid. Click the Options on the toolbar. The
Options dialog box opens. Show/hide the grid on the layout view or set the grid spacing.

x|
¥ Backgroud arid visible Display a grid in the background
v Guide by background grid of the IayOUt view
Move the element in unit of the
Grid spacing: |5 Pixel o . .
e speene e specified grid spacing
ak. I Cancel |

Undoing or Redoing
Undo or redo an element editing operation.

Report List

Lists the report files (.xrt extension) that are stored in the folder below. The most recent
file is shown at the top of the list; the oldest file is shown at the bottom of the list.
Xviewer installation folder > Report folder

(The default location is C:\Program Files\Yokogawa\Xviewer\Report.)

Adding an Element

When Edit Mode is ON, you can select the element to be added from the following:
+ Add text (Text Element).

* Add a window image (Window Image Element).

* Add a measured result (Measure Result Element).

* Add an image (Image Element).

Changing the Element Properties
You can change the properties. The items that you can change vary depending on the

type.

Changes the Basic Information

The following basic information is shown in the report.

Header, Footer, Date, Author, and Comment

The Basic Information cannot be turned OFF. However, if you leave the text field empty,
nothing will be displayed.

7-6
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7.2 Editing Reports

Aligning the Elements
The selectable range is 1 to 100.

Undoing or Redoing

You can undo or redo a single edit operation in the layout view.

* Add or delete an element.

* Move an element or change the properties

» Set the layout view (landscape or portrait)

» Basic information of the report (header, footer, date, author, and comment)

IM 701992-01E
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7.3 Saving, Loading, or Deleting Report Files

Procedure

Loading a Report File
Click the Open on the toolbar. The Open dialog box opens. Select the report file you
want to load, and click Open. The report file settings are used to lay out the Layout View.

Saving a Report File
Click the Save As on the toolbar. The Save As dialog box opens. Set the destination, file
name and file type, and click Save. The current settings are saved.

21|

Save in:la Repart j - £ ER-
samplel . rtf
samplez, rtf
sample3, rtf
sampled, rtf
samples. rtf

File name: wingd_ 02 Save I

Save as type: | Rich Text Farmat(*.i] j Cancel |

report® it 4
Rich Text Format[* rtf]

Select the file type

Deleting a Report File

Select the file you want to delete from the Report List, and click the Delete Report on the
toolbar. The selected report file is deleted.

— Open
Save As
Delete Report

1 eport D \PROGRA~1\ Yokogawa'Xviewer'Reportsample3.xrt

EHX | Begkg®-m%8%

- Report List

=

sample

1
sample2
ample3)

[~ Layout

YOKOGAWA
Xviewer Report

Main Trigger Time: 2004/10/06 19:34:22.69
Groupt Samplyg Inierval 500.00ns

No.0000 2.5000m 5] 25045m

Main_ Trigger Time: 2004/10/05 19:34:22.89
Groupt Frequency Resaliion: 2.0000kHz

e o
mon [

NoDOOD 200000k [Hz]  996.000k

A § [

éI
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7.3 Saving, Loading, or Deleting Report Files

Explanation

Loading a Report File
Use this command to open a report file that is not shown in the Report List.

The only reports that can be loaded are the ones of file type *.xrt.

Saving a Report File
If you save the report file in the folder indicated below, the report file is shown in the

Report List.
Xviewer installation folder > Report folder
(The default location is C:\Program Files\Yokogawa\Xviewer\Report.)

The report file types that can be saved are *.xrt (report format) and *rtf (rich text format).

Nofte

Report files saved in rich text format (*.rtf) can be edited in Microsoft Word. However they can
not be edited in WordPad.

Deleting a Report File
The report files in the folder indicated below can be deleted.

Xviewer installation folder > Report folder
(The default location is C:\Program Files\Yokogawa\Xviewer\Report.)

Note

If you open a new report file, the report file that was open up to that point is discarded.

IM 701992-01E
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7.4 Printing Reports

Procedure

Selecting the Print Orientation
Click the Portrait or Landscape on the toolbar.

Print Preview
Click the Print Preview on the toolbar. A preview is shown on the screen.

Printing a Report
Click the Print on the toolbar. The Print dialog box opens. Set the printer, the range, the
number of copies, and so on, and click OK. The report is printed on the specified printer.

Portrait
Landscape
Print
Print Preview

[xreport D:\PROGRA~11Y okogawalX viewer\Reportisamples.urt

FEHX(E5(SR(EM-7%®

~Fieport Lit Layout
samplel KOGAWA
Xviewer Report
Hai_ Tiger Tir=: 200471006 1
T Erdigangig mervsl 50,000
ACHI I
samplz2 acHa
]
—
No.0000
sampled Zoom Trigger Time: 2004/10/06 13342289 Number
Groupt Smplngleervat S0BES
o
- :
———
o g
sampled
|
[ |
=
TS No.0o0o 99750 [l 1.0025m
i =
Fleas
s
&
&
&
Ber
e
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Chapter 8

Communicating with the Instruments

8.1

Procedure

frviewer

iew Windom Connect Tool Help

Notfte

Connecting to the Instruments

Before attempting to use this function, connect the PC to the instrument using an appropriate
communications cable. For details on how to make this connection, see the manual provided

with your instrument.

Setting Up/Adding a Connection
On the Xviewer tool bar, click the CommSetting to open the Communication Setting

dialog box. Then, click the Add to open the Devices dialog box, make the settings for the
connection interface and communications conditions, and then click OK.

Nofte

If connections to instruments have already been registered, those connections will be
displayed as a list. Select the required the instrument and then click the Connect to establish
the connection with the instrument.

» Up to 16 connections can be registered.

% map NS iy ) B ‘ 7
Close Arrange mmSetting  Open Inst.  CorbrolInsk.  ACK) save Help

* GP-IB connection

~ it K

Addess:

ol

©us

 Ethernet

 usamMe

1)

* USB conneciton
(Other than the DL9000/SB5000
Series, SL1000, DLM2000 series,

* USB conneciton
(DL9000/SB5000 Series,
SL1000, DLM2000 series,

DLM4000 series, DLM4000 series,
DL6000/DLM6000 serries, DL6000/DLM6000 serries,
and DL850 series) and DL850 series)
— Input the GP-IB . e o e
et = impuvouss | T
be connected lE n_umber of
(0 t0 30) T the instrument T
to be connected )
o (1to 127) e

* Network connection

(Other than the SL1000, DLM2000 series,
DLM4000 series, DL6000/DLM6000 serries,

and DL850 series)
X

 usamMe

- Input the IP address of the

instrument to be connected

- Input the network user name
for the instrument to be connected

- Input the network password
for the instrument to be connected

— Input the serial

* Network connection

(SL1000, DLM2000 series,
DLM4000 series, DL6000/
DLM6000 serries, and DL850 series)

@ Ethernet v VAT

 usamMe

—
e
—
—

- Check the VXI11

number of the
instrument to
be conncted
(9-digit)

— Input the IP address of the
instrument to be connected

IM 701992-01E
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8.1 Connecting to the Instruments

Modifying a Connection

On the Xviewer tool bar, click the CommSetting to open the Communication Setting
dialog box. Select the required the instrument and then click the Properties to open the
Devices dialog box, change the settings as needed and then click OK.

Removing a Connection
On the Xviewer tool bar, click the CommSetting to open the Communication Setting
dialog box. Select the required the instrument and then click the Remove to remove the

selected connection.

Establishing a Connection

On the Xviewer tool bar, click the CommSetting to open the Communication Setting
dialog box. Select the required the instrument and then click the Connect to establish
the connection with the instrument.

Note

If the instrument contains a very large number of files, it may take some time to establish the

connection.

Select a connection

Communication Setting

Model BLIS Address Terminator Detail Address

ETHERNET _JID G20 88 JLF ]l .6 od 68 sasined

b3 2

add Remove Property Cancel ‘ Connect q_— Establish the

selected connection

—Display the Devices dialog box, in which the settings
for the selected connection can be changed

— Remove the selected connection

Ending a Connection
A connection with the instrument is ended when you exit from Xviewer.

Notfte

The connection with the instrument cannot be ended while a file is being transferred.
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8.1 Connecting to the Instruments

Explanation

Setting Contents

Ensure that the interface settings and communication conditions are the same as for the
instrument to which you want to connect. Check the setting contents using the following

menu.

Address/ID Number

DL750 series, DL1600 series, DL1700E series:

DL7400 series:

DL9000 series, SB5000 series:
SL1400:

DLM2000 Series, DLM4000 Series:
DL6000/DLM6000 Series:

DL850 series:

Server

MISC > Remote Cntl

MISC > Remote Cntrol

SYSTEM > Remote Control > GPIB

MENU > Remote Cntl

UTILITY > Remote Control > Device > GPIB
UTILITY > Remote Control > GPIB

UTILITY > Remote Ctrl > Device > GPIB

DL750 series, DL1600 series, DL1700E series, DL7400 series:

DL9000 series, SB5000 series:

SL1400:
SL1000:

DLM2000 Series, DLM4000 Series:
DL6000/DLM6000 Series:
DL850 series:

MISC > Network > TCP/IP Setup

SYSTEM > Network > TCP/IP Setup
>Configuration

MENU > Network > TCP/IP Setup
DISPLAY key (Displays the communication
parameter screen)

UTILITY > Network

UTILITY > Network > TCP/IP Configuration
UTILITY > Network > TCP/IP

User Name (for the Network interface)
DL750 series, DL1600 series, DL1700E series:

DL7400 series:
DL9000 series, SB5000 series:

SL1400:
DL6000/DLM6000 Series:
DL850 series:

MISC > Remote Cntl > User Account

MISC > Remote Cntrol > User Account
SYSTEM > Remote Control > Network (User
Name/Password)

MENU > Remote Cntl > User Account
UTILITY > Network

UTILITY > Network

Serial No. (for the USB interface with the DL9000/SB5000 series, or SL1000,
DLM2000 Series, DLM4000 Series, DL6000/DLM6000 Series, or DL850 series)

DL 9000 series, SB5000 series:
SL1000:

DLM2000 Series, DLM4000 Series:
DL6000/DLM6000 Series:
DL850 series:

“unknown” Model Name Display

SYSTEM > Overview

The number (instrument number) marked
on the name plate of the SL1000.
UTILITY > Overview

UTILITY > Overview

UTILITY > Overview

Once you have made the connection settings and, using those settings, a connection is
made successfully, the “model name” of the connected device will appear under Model in
the Communication Setting dialog box. If a connection cannot be established, however,
an error message is displayed and “unknown” appears as the model name.
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8.1 Connecting to the Instruments

Transfer Rate

Firmware Versions

Xviewer may not be able to establish a connection with the instrument, depending on
the firmware version of the software installed in that unit. Xviewer is compatible with the
following firmware versions.

DL750 series:
DL1600 series:
DL7400 series:
DL1700E series:

Firmware versions 2.50 and later
Firmware versions 1.12 and later
Firmware versions 1.23 and later
All firmware versions

DL9040/DL9140/DL9240 series:
Control Inst is supported by firmware versions 1.64 and later.
DL file display and transfer as well as load and save are

DL9500/DL9700 series:
SB5000 series:
SL1400:

SL1000:

DLM2000 series:

DL6000/DLM6000 Series:
DL850 series:
DLM4000 series:

supported by firmware versions 1.8 and later.

All firmware versions
All firmware versions
All firmware versions
All firmware versions

Control Inst, load and save, and DLM file display and transfer
(USB upload and GP-IB download) are supported by firmware
versions 1.06 and later. DLM file display and transfer (USB

download and VXI-11 download) are supported by all firmware

versions.

All firmware versions
All firmware versions
All firmware versions

Model Transfer Rate
Download Upload
GP-IB uUsB Ethernet uUsB
DL1600 series, DL1700E series, 150 K to 450 KB/s|300 K to 600 KB/s|400 Kto 1 MB/s |5 Kto 15 KB/s
DL7400 series, DL750 series, SL1400
DL9000 series 800 KB/s 1.5 MB/s 1 MB/s 5 KB/s
SB5000 series 800 KB/s 1.5 MB/s 1 MB/s 5 KB/s
SL1000 - 9 MB/s 10 MB/s 1 MB/s
DL6000/DLM6000 series 800 KB/s 1.5 MB/s 1 MB/s 5 KB/s
DL850 series 1 MB/s 7 MB/s 5 MB/s 1 MB/s
DLM2000 series 1 MB/s 5 MB/s 4.5 MB/s 1 MB/s
DLM4000 series 700 KB/s 4.5 MB/s 4 MB/s 1 MB/s

Note

The transfer rate varies depending on the networking environment and the model being used.
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8.2

Displaying a File List

Displaying a File List
On the Xviewer tool bar, click the Open Inst to open the Communication Setting dialog
box. Select the required the instrument and then click the Connect to establish the

connection with the instrument and display a file list.

Nofte

If a connection has already been established with the required the instrument, the
Communication Setting dialog box does not appear and the file list appears immediately.
*  When you click the “Control Inst” to enable operation of the instrument from a PC, the “Open
Inst” is grayed out.
« If the instrument contains a very large number of files, it may take some time for the file list

to appear.

Changing the Order of/Updating the File List
When you click the Name, Size, Type, or Updated in the file list, the file list is sorted
based on that clicked item. Clicking Update on the tool bar causes the file list to be

refreshed based on the latest information.

Fle Edt View Tool

Update file list using latest information

(4] b £=
Up Rlefiesh, Thumbnals  Smalllgons ~ List claile
=& bLrso_t Niarme size | Type [ Last write fime [ attris=
SaTEsT File Folder 0412101348 RAW
= [ 0000.61F 60062 Gitmap Image 0000116 227 RIW
2] nooo.csv 3689 CSVFie MN0j011222:36  RIW
Dy TESTL % 0000.POF 7603 #dobe Acrobat ...  2000/0112 21:22 R
[¥] o000 prc 9596 PHG Image 20041207 20:09  RAW
= 0o0.seT 119820 SETFile 0000111215:53  RIW
4 00000000,B4P 60062 Bitmap Image 4ZZELEAT  RIW
= 00000000.PoF 14437 Adobe Acrohat.., 200412291108 RfW
(= 00000001 6P 60062 Bitmap Image: fizizaiess AW ol
< >
B A [Name [ size | Type [ Last Write Tine =1
B C () 5ec49ef1 c2czeadbgsadas1 ., File Folder 2003{12/10 10:26:34
#1) SecdgenfLcec2e8d0b95ae | [ Documents and Settings Flle Folder 2003i09{16 09:01:12
#-{3) Documents and Settings ) OFfficeScan NT File Folder 200309(19 09:37:56
HIA OfficEScapy (EProgram Files File Folder 20030915 10:02:22
G Frogram Fles % Recyded Folder 20030915 15:13:58
& Recycled () 5ystem Yolume Information Fils Folder 200G{09(16 10:12:14
i g 3:;5;2\‘;2“'"5 Tnformatio || =) Tupows File Folder 200310916 08:54:56
= (WUTemp File Folder 2003/09/16 19:30:16
1) WuTemp 9=
= |AUTOEKEC BAT 0 M5DOSBatchFlle  2005/01/13 18:16:40
< * | |l=h auroexec.cam 0 CAM File 2005401413 15:38: 14 =
Ready

Change the order
of the list

List of files on
the instrument

List of files on the PC
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8.2 Displaying a File List

Explanation

Thumbnailing Image Files

Clicking Thumbnails on the tool bar causes the image files stored on the instrument to

be displayed as thumbnails.

Note

» Files other than image files will be displayed as icons.

* Those image files for which there is no thumbnail file to display will be displayed as icons.

Thumbnail display on/off

File Edt view Tool
— 0 = i
Up Refresh Jhumbnals JSmalllons  List
=) bL7so_t T il Lo
{53 PCCard
= [ TEST
(o TESTL @
TET 0000.EMP 2
2 | [ ame size | Type [ Last Writs Time ~
SR C _)Sec49e0f1c2e2e8d0boSadat .. File: Folder 2003112410 10:26:34
) SecddelficicZeddbd5ac | (Documents and Setting: File Folder 2003/09/18 09:01:12
&-{3) Documerks and Settings [ C0fficeScan NT File Folder 200310519 0$:37:56
i {5 OFfizeScamNT () Program Files File Folder 2003/0%18 10:02:22
=2 P’ﬂg’a‘"‘;"‘“ ) Recycled Folder 2003j09)18 15:13:58
& :EE;’EEV i [5ystem Volume Information File Folder 200309/16 10:12:14
o -
i g J;NEEWDS“'"E nroMmatee— | S winpows File Folder 2003/09/18 08:54:56
B e (9 UTemp il Folder 2003/09/15 19:30:16
R - ¥ |FauToExeC BAT 0 MS5DOS Batch Fle  2005i01{13 18:16:40
< 2 | autoexec. cam 0 camFile 2005101413 15:38:14 pus
Ready

— Icon display (Example)

Changing the Size of the Displayed Thumbnails
Select Tool > Options on the file list menu bar to display the Option dialog box. Select a
size for the thumbnails (width and height), and then click the OK.

i~ Thurnbrail Size
& wWidth:216  Height:160
" width:200  Height:150
" wiidthi108 Height:&0
 \Width:54 Height:40
O, | Cancel

Displaying Realtime Recording Data
For the DL750/DL750P and SL1400

On the SL1400 and DL750/DL750P with firmware version 6.01 or later, the file list of the
[SCSI,4,0] folder on the DL750/DL750P/SL1400 can be displayed. The [SCSI,4,0] folder
contains data that has been real-time recorded on the DL750/DL750P/SL1400 (.wdf

Fie Edt Yiew Tool
& B =] U] * L 2 e = -
Opsny Tiwer Up Refiesh  Deleie Uplozd  Doyrfosd | Thumbnals  Smalllcons  List Details
M) DL7S01 me [ Size [ Type [ Last write Time [ Atribute
- @ PCCard | £41SSOBOAFF.WDF 2097152 Rviewet 2005(05(24 11:22 Rfw
51,40 EID1CH. WOF 3145728 Rwiewer 2005/06/14 09:03 R
Dscstat AElsAME. woF 45728 Kviewer 2005/06/14 09:05 R

For the DL850 series and SL1000

If files were recorded in real time on the SL1000 or DL850 series and divided into
multiple files, only the first file (****_000.WDF) is displayed.
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8.3

Manipulating Files

Downloading from the Instrument to the PC
If you select a file from the list of files stored on the instrument, the “Download” is
enabled. If you then click the Download, the selected file is transferred to the PC.

Nofte

* Multiple files can be specified for transfer.

«  While files are being transferred, the connection to the instrument cannot be terminated.

«  With the DLM2000 series and DLM 4000 series, if waveform acquisition is in progress, you
must stop waveform acquisition before performing file operations such as uploading of files
to the DLM2000 and DLM 4000, downloading of files to the PC, deletion of files, deletion of
folders, and creation of new folders.

« If files were recorded in real time on the SL1000 or DL850 series and divided into multiple
files, all divided files are downloaded when you download the displayed first file (****_000.
WDF).

— Select the required file
Perform download

File Edt View Tocl

JsE o * ‘ Py (0) =
oyt || Up Refesh  Delele | | Uelsad \Dowrload /| Thumbnas Smalloons  Lis
=3 DL7S0_1 Hame size | Type [ Last wiite Time. ||
£ pecard 0002 5T 119628 SET il o0ftjiezxse  RiW
0 sesL4,1 = 0003 €| 119828 SETFile 2005/01/13 19:55 Rt
0000 404 280680 Huiener a0smIB IS RiW
260658 Hlener 005011131355 Riw
250888 uiemer aoSjI1319SE R
o 7292204 Hviener 020f1/100L25  Riw
f 7562520 viewer 0Sj0zj08 18:07 W
42 11vERM SNF STTLE Hiemer 0szis 0de Riw
Zlsmrerm e 1043304 vlemer DSj0z08 17iz0 R —
< | »
(@ Deskion ] [Hame. | Size | Type [ Last tirite Time [
{23 My Documerts 000.HDR. 1189 HDR File 2000/01/23 07:44:04

2 iy Compurer
& My Network Places
# Recycle Bin

| oo0.vwr 20068405 Rviewer 2000/01/23 07:44:04

{2 050110
‘af Doc_Public on Mac 05 1 5¢
() instal
(£ mask_editor
1) SamplewaveData

+£3 10MPointsn00 id
>

L

[
L Indicates the transfer status

Ready |

Uploading from the PC to the Instrument
If you select a file from the list of files stored on the PC, the “Upload” is enabled. If you
then click the Upload, the selected file is transferred to the instrument.

Nofte

» Files can be transferred from the PC to the instrument (upload) only when the USB interface
is being used for the connection.

* Multiple files can be specified for transfer.

»  While files are being transferred, the connection to the instrument cannot be terminated.

* The data in the [SCSI,4,0] folder in which the realtime recording data (DL750 series and
SL1400) can be downloaded to the PC. However, you cannot create a directory in the folder
or upload data to the folder.

»  With the DL9000 series, SB5000 series, and DL6000/DLM6000 series files cannot be
uploaded to a USB memory connected to the instrument.

» If files were recorded in real time on the SL1000 or DL850 series and divided into multiple
files, all divided files are uploaded when you upload the displayed first file (****_000.WDF).

IM 701992-01E 8-7

sjuswinisu| 8y} ypum Bunesiunwwod ﬂ



8.3 Manipulating Files

— Select the required file
Perform upload
File Edt View Tool
J = w x ( @« ) - ‘ =
Openby Uiewer Up Refresh Delete Upload ) Dovrload | Thumbnals — Smallleans
1) DL7S0_t hame | Size | Type [ Last Write Time: |
(3 PeCard 0002 5E 110828 SETFik oogjoijizoas R
13 SCal 4,1 0003.5E| 119828 SETFile 2005/01/13 1955 Riw
o000 s 200688 Kviewer oosjoif13 eSS R
0001 20063 Hviewer sz iess R
ooz 20068 Hviewer o0S/0113 135 RAW
o003 s 7292204 Riewer magjoijioonzs Rw
10MMPERH WYF HR2520  Rviser 00sj0zi08 1807 RAW
1MVPER{ s S44TFIE  Huiemer oosjzjosoads RAW
WY 15043304 viewer awosiuie 1m0 RN —
4 | >
=@ Desiiop ] [ame [ sz [ Type [ostwmetive | =
{23 My Documents (= 10vPoinfsann File Folder 2005/06/10 10:40:56
4 My Computer 2 3zmPaintsnn. File Folder 2005/06/10 10:39:28
S Hy Netiork laces 11 10mPaintsnnn. zip 3357134 Compressed (al., 20041104 19:10:34
~g) Recycle Bin (5 zcHsInAET HOR 085 HOR Fle 2004/10/05 19:34:56
 osotio 51439 Hviewer 2004/10/06 19:34:58
g f:f‘;f“b"‘ onMac 05 X5 1815 HOR Fie 2004/10/05 13:40:06 |
) mask_eckor |48 zcHsTcy v 313606 Hviewer 2004/10/06 19:40:08
55 Soewaepats [ 2cHsIngvSW HOR 1707 HOR Fle 2004/10/06 20:13:20
T2 1oMPointsa00 « | | zcrstuxsw.wE 233416 Hviewer 2004/10]06 20:13:22
4 (£ 3zmPaintsn0t. zip 10594913 Compressed (2l 2004/11/04 19:13:20 |

L Indicates the transfer status

Deleting a File
If you select a file from the file list and then click the Delete, the selected file is deleted.

Nofte
*  When you delete an image file, the corresponding thumbnail file is deleted at the same time.
» Afolder cannot be deleted.
» If files were recorded in real time on the SL1000 or DL850 series and divided into multiple
files, all divided files are deleted when you delete the displayed first file (****_000.WDF).

Deleting a Folder (SL1000)
With the SL1000, If you select a folder from the file list and click Delete, the selected
folder is deleted.

Note

If you delete a folder, all files within the folder are also deleted at the same time.

Reading a Waveform Data File

If you select a WVF-format waveform data file (*.wvf / *.wdf) from the file list on the PC,
the “Open in Viewer” is enabled. If you then click the Open in Viewer, the selected file is
read and the waveform data that it contains is displayed in the Viewer window.

Display required file (waveform data) in the Viewer window

Display required file (waveform data) in the Viewer window
Delete file

It} x ° -
Refresh Delete Upload [ovrlaad! Thumbnails  Small lcons

i Details
Name [ 5ize | Type [ Last write Time [ario ]
0002 5ET 119828 SETFile 000122352 RAW
5 sesL41 0003.5ET 119825 SETFe s/ 1ess Rw
0000, 4vF 280688 viener 0050113 19:55 Riw
0001 WE 280688 Wviener 005131556 Ri
0002, wvF 280888 xviewer o0EI13 108 Rjw
0003, 4vF 7292204 Rierver 200005 Riw
A 1omrpER e TBZSZ0 Hviewer 00sfozjos 18:07  Rjw
1MVPERM WAE GHTTIE Hviener 00Sf02/09 0Ei49 Riw
MIVE 15043304 viewer LS00 1720 RAW —
| | 3
(@ Deskion - |§me | Size | Type [ Last Write Time: |
{23 My Documerts 000.HDR. 1189 HDR File 2000/01/23 07:44:04
5§ My Computer 20066405 visnver 2000/01/23 07:44:04

& My Network Places

# Recycke Bin

{2 050110
‘af Doc_Public on Mac 05 1 5¢
() instal
(£ mask_editor
1) SamplewaveData

+£3 10MPointsn00 id

Ready (I

L Select required file
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8.3 Manipulating Files

Explanation

Creating a Folder
Select Tool > New Folder on the file list menu bar to display the folder creation dialog
box. Input a name for the new folder, and then click the OK.

Notfte

* The new folder will be created under the current directory of the file list.
* For the folder name and upload file name, you can specify ASCIl characters
(alphanumerics, etc.) only.

Cautions to Observe When Transferring a Waveform Data File

A WVF-format waveform data file (*.wvf) cannot be opened unless there is an .hdr file
with the same name in the same folder. Therefore, when transferring a WVF-format file,
be careful to also transfer the corresponding .hdr file.

Nofte
Right click the files selected to be manipulated, and select one of the following from the shortcut
menu.
Download: Available when the instrument internal files or folders are selected
Upload: Available when PC files or folders are selected
Delete: Available when a file is selected

(With the SL1000, you can also select and delete a folder.)
Create folder: Available whether a file, folder, or nothing is selected

The following folder names cannot be used.

AUX, CON, PRN, NUL, CLOCK, COMO to COM9, and LPTO to LPT9
Update to Latest Information: Available whether a file, folder, or nothing is selected

When instrument internal files When PC files
[ are selected [ are selected
[=-5) DL750_1 : Deskiop -
{3 PCCard B} My Documents
L) scsL,41 " My Computer r——
i - \vj Iy Metwork Places D o3
ﬁﬂﬂﬂl | Download 2| Recycle Bin
! plzad Delete
Mooz s {03 050110
ﬁDDDS | Delete g Doc_Public on Mac 05 % S Hewy Folder
ﬁIDMI\':IF Mew Folder ) instal Refresh
Refresh
A LM Eerererrrmerrem
When folders are When right-clicking
[selected with nothing selected
: Deskiop - 3 Deskiop | | Mame |
B My Docurments Downlnad :I..D My Documents J_@_DMPointsDDD
- g My Computer Dszmpaintsl H- i My Computer [k
4 iy Hetwork Places E1ompaintsn 0 o 44 My Hetwork Places (1 10MPointsD00.2ip
<2l Recyce Bin [ 2cHsmErT e | 2/ Recydle Bin B achsirrTioR
0 050110 A zchsmerT | D osoun A 2CHSINFFT. wWvE
[#-fgf Doc_Public on Mac OF ¥ S¢ @ Jp— (=ilT=2 H-fg Doc_Public on Mac Of @ SCHSTNCY HDR Uplaad
R ' H-1-) install ! Delete
2 mask_odtor g;;:g;:;;-smm New Fokder
03 SamplewwaveData ﬁ ! Refresh
L A0MPainksaan | | SECHSTHRYSW, W
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8.4 Operating the Instruments from a PC(Other
than the DL9000/SB5000/DLM2000/DLM4000/
DL6000/DLM6000/DL850 series)

Procedure

Displaying the Control Screen

Click the Control Inst on the Xviewer tool bar to display the Communication Setting
dialog box. If you then select the required the instrument and then click the Connect, a
connection with the instrument is established and the control screen (an image of the

front panel) appears.

Nofte

» If a connection has already been established with the required the instrument, the
Communication Setting dialog box does not appear and the control screen appears

immediately.

*  When you click the “Open Inst” to display a list of files on the instrument, the “Control Inst” is

grayed out.

Controlling the Update of the Display

Click the UPDATE on the control screen to forcibly update the control screen display. If
you click the PAUSE, the update of the control screen is stopped temporarily. Clicking

the PAUSE again restarts the update of the screen display.

Operation of the Control Screen
The control screen allows you to operate or control a DL unit using the PC’s mouse or
keyboard.

Setting Screen Display Options

i— Set display options

Save image of the screen
Update screen display
Pause screen update

Click the OPTION on the control screen to display the Option dialog box. Set the control
screen display size, the refresh rate, and display brightness, and then click the OK.

Select screen size

Eos Feigbiomss - Select screen refresh rate

- Set screen brightness
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8.4 Operating the Instruments from a PC(Other than the DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series)

Explanation

Saving an Image of the Screen
Click the CAPTURE on the control screen to display the file save dialog box. Select the
folder into which you want to save the file, specify the file name, select a save color and
then click the OK.

Select a file save location

Save As |E”E]
Save in: |_? Hveiver I L] & £ Bl

= ). [SlcAPTEDDOS (ML CAPTEDD12  SLCAPTEODIS |«
| ) captEODDl  [SlcapTEoDo?  [MlcapTEoois  [SlcapTeEoots [Sde
|l capTEDDDZ  |SLCAPTEDODE ML CAPTEOO14 [l CAPTEOOZO (%«
|l captEDDD:  [SLCARTEOOODS  [SLCAPTEOOIS | CAPTEODZ1
| capTEoDDd ML CARTEOOLD (ML CAPTEODLE | CAPTEODZZ
|*capTECODS  |SlCAPTEODIL ML CAPTEO017 | CAPTEO0Z3

Input a file name
| >

Save as type: ||mage file: [*. brnp) ﬂ Cancel

Galor
~ OFF | F ON " ON{Reverse) " ONGray)
I—Select a save color
Nofte

Press the SHIFT key (keyboard) and click the CAPTURE button (control screen) to copy the
screen to the clipboard.

Option Settings

The following settings can be made for the screen display options.

» Display size (Size): Select 100%, 75%, or 50%

» Display refresh rate (Update Interval): Select 1 sec, 2 sec, 5 sec, 10 sec, 30 sec, 1
Min, 5 Min, 10 Min, 20 Min, 30 Min, 1 hr, or
Minimum

* Brightness (Brightness): Adjust using the slide bar

Nofte

» Depending on the network transmission method or the communications load, the actual
display refresh rate may be slower that the set value.

*  When you select Minimum for the screen refresh rate, the fastest possible refresh rate for
your environment is set automatically. Note that if the connection to the instrument is made
via a network, the network load may affect the refresh rate.

Using the Display Update Button

» The UPDATE button is used to forcibly refresh the display when, for example, a slow
refresh rate has been set or refresh has been temporarily stopped (when the PAUSE
button is available).

» The PAUSE button is used to temporarily stop refresh when the ON/OFF settings of
many items must be changed, values must be entered using the keyboard, or when
better system response is needed.

Screen Image Save Format
When you click the CAPTURE button to save a screen image, an image of the currently
displayed screen is saved as a BMP-format file.

IM 701992-01E
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8.4 Operating the Instruments from a PC(Other than the DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series)

Screen Image Save Color

When you save a screen image, you can select and of the following colors.

e OFF: Screen image is saved in monochrome

¢ ON: Screen image colors are saved as is

¢ ON (Reverse): Other than the channel colors are saved in monochrome
e ON (Gray): Other than monochrome colors are saved as grays

Using the Mouse

If you position the mouse cursor to a control key or knob on the control screen, the
mouse pointer (icon) changes, indicating that key or knob on the screen can be operated.
The displayed icon and the action of the mouse changes depending on where on the

control screen it is positioned.

Mouse Pointer Displayed Icon & Setting Operation

Position Mouse Action

Operation key dhry
Click Same as pressing an operation key

Soft key menu or {52

dialog box Click Same as pressing a soft key or a button
Wheel Same as turning the jog shuttle

Voltage axis information {’@

display area Click Same as pressing a channel key
Wheel Same as turning the V/DIV knob

Time axis information JI@

display area Wheel Same as turning the T/DIV knob

Jog shuttle left- and @@5

right-hand areas Click Same as turning the jog shuttle to the left of the right
Wheel Same as turning the jog shuttle

V/DIV knob left-and G/ @

right-hand areas Click Same as turning the V/DIV knob to the left or the right
Wheel Same as turning the V/DIV knob

T/IDIV knob left-and <G/ @y

right-hand areas Click Same as turning the T/DIV knob to the left or the right
Wheel Same as turning the T/DIV knob

Example of Using the Control Screen

Using the Operation Keys

— Click to select Sine

:i

L0, 00irs
Pulze -7y cownula

Line -,

mmv:‘ PAUSE

i) ) JuLd _mu D L)
st s P .w

LD pmeser) 001)
g12 )

a3) | ’ { ,
@ L - LU,

'- Sl

_)w

.'_‘.”.‘_J..._._J Q :/

RESET '] SEL _!P!’
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8.4 Operating the Instruments from a PC(Other than the DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series)

Soft Key Menu Operation
Turning the wheel here allows you to set a record length
|— Clicking here selects Envelope

g 10000, ﬂu: | P‘USE
h o0 | e
|

WM .mu.:m.) i)

' Irms™ AESET ) m;w}
W MW QD UG

FIHLE l.‘?’.‘h’!‘{-"‘—g
SET O BELAY
#oSE ' AELS ff.:’

Jog Shuttle Operation

= e e e | PRUSE
Length [
50Kk HoFmal | DnEiie BEE ov (OFE OK | = Ext

CLEET Ehap
lw‘-----‘?ﬁ"

RESET i I&!&‘I’

SiHFLE ]fl.u;( ff
WoPE j PSS .r!’

Clicking or turning the wheel here lets you set a record length

V/DIV Knob Operation
— Voltage axis information
display area
CLEET
B SE=5E
wm .m:.).ua.)m CHL 1:1
HE W Wi = i
Ewy 1 :"f;
1.9 Ufdiv
i
M3
:.l“ !kl
Turning the wheel changes

: the V/div setting
Click or turn the wheel
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8.4 Operating the Instruments from a PC(Other than the DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series)

T/DIV Knob Operation

— Voltage axis information
display area

GLEER
Y - . g c
.‘ gok  Hormal
L) sy

. tnsan

Turning the wheel changes
the V/div setting

Click or turn the wheel

Dialog Box Operation
» Position the mouse cursor to the item you want to turn ON:
Click the jog shuttle or turn the wheel

* ON/OFF setting: Click SELECT or click the item directly, as shown below

Trace Hode Cond Lt lon
S| R L S L |
] e
[ I L S L |
e [eT [ T T

Hathi—— [EPFF DN [T

fathz” — [PFF.OF [ UT. TN
[hRD_— TR
Sequence [ Fingle " Contlme %

[E] Save to File (2] Hard Copy

(©) Ipage Save (T Semd Hall Mall Count [ 1047
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8.5

Operating DL9000/SB5000/DLM2000/DLM4000/
DL6000/DLM6000/DL850 series from a PC

Displaying the Control Screen

Click the Control Inst on the Xviewer tool bar to display the Communication Setting
dialog box. If you then select the required the instrument and then click the Connect, a
connection with the instrument is established and the control screen (an image of the
front panel) appears.

Nofte

» If a connection has already been established with the required the instrument, the
Communication Setting dialog box does not appear and the control screen appears
immediately.

*  When you click the “Open Inst” to display a list of files on the instrument, the “Control Inst” is
grayed out.

« In the following cases, the control screen display cannot be updated:

* While editing waveform, square, or polygon zones

» During processing of cycle statistics

» During statistical processing of history data

« In the following cases, the control screen display cannot be updated:

» While editing waveform, square, or polygon zones
» During processing of cycle statistics
» During statistical processing of history data

Controlling the Update of the Display

Choose Menu > View > Update in the control screen to force an update of the control
screen. Choose Menu > View > Pause to pause updating of the control screen. To
restart display updating, choose View > Pause again.

Operation of the Control Screen
The control screen allows you to operate or control the instrument using the PC’s mouse
or keyboard.

DL9000 Series SB5000 series

E i L e

The LOGIC button is displayed for the DL9500/DL9700 Series or SB5000 series.

IM 701992-01E
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8.4 Operating DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series from a PC

DLM2000 series

English panel sheet

| N
English panel sheet
Displayed on 4-channel models and models with a logic input terminal.

DL6000/DLM6000 series DL850 series
N 151

TOKDGAAS #

|
English panel sheet English panel sheet

Do not connect from the PC while hard disk recording is occurring on the DL850 series.
*  When controlling the DL850 series from the PC, do not start hard disk recording on the
DL850 series. Doing so can overload the DL850 series internal processing, resulting in
malfunction.

Screen Display Size
Choose Menu > View > Zoom > Smaller, Standard, or Larger. The control screen

changes to the selected size.

Copying the Image to the Clipboard
Select Tool > Copy Image to Clipboard or Copy Image to Clipboard (Reverse).
» Copy Image to Clipboard
The image of the display section of the control window is copied to the clipboard.
» Copy Image to Clipboard (Reverse)
The image of the display section of the control window is copied to the clipboard
without the background color.
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8.5 Operating DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series from a PC

Explanation

Saving an Image of the Screen

Choose Menu > File > Save > Image in the control screen to display the file save dialog
box. Select the folder into which you want to save the file; specify the file name, save as
type, and color; and then click the Save.

Select the file save destination

2|

Save in:l@Xviewer ! j & = EB-

Report
ReporkC
ReportE
SampleData

Enter the file name

Select the file type

File: name: IScreen Save I
Save as type: IBitmap Files [*BMP) j Cancel |

Calor
& OMEbit] ¢ OM[1EbE) ¢ OM(Reverss)  ON(Gray) DFF—’——SeleCt the color

4

Screen Display Size
You can select the zone from below.
Smaller, standard, larger

Display Update Interval
You can select the zone from below.
300 ms, 500 ms, 1s,2s,5s,10s

Note

» Depending on the network transmission method or the communications load, the actual
display update interval may be slower that the set value.

*  With the DLM2000 series, the image on the PC may be disrupted immediately after
transferring waveform screens or saving screen images. This does not affect the data. The
image will recover automatically after the next screen update.

Display Update Operation Control

» Forced updating is used when setting a slow display update rate or when pausing
display updating (by choosing Menu > View and selecting Pause).

» Pause is used to improve the response when turning many items ON/OFF at once, or
when entering numerical and other values with the keyboard.

Screen Image Save Format
An image of the currently displayed screen is saved as a BMP-format file.

IM 701992-01E
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8.4 Operating DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series from a PC

Selecting the Color Mode

You can select the color mode. The selectable color modes vary between BMP and PNG
formats.

« BMP: 8 bit, 16 bit, reverse, grayscale, and color OFF (black and white)

* PNG: 16 bit, reverse, grayscale, and color OFF (black and white)

Using the Mouse

If you position the mouse cursor to a control key or knob on the control screen, the
mouse pointer (icon) changes, indicating that key or knob on the screen can be operated.
The displayed icon and the action of the mouse changes depending on where on the
control screen it is positioned.

Mouse Pointer Displayed Icon & Setting Operation

Position Mouse Action

Operation key {@
Click Same as pressing an operation key

Roraty-knob left- and f“@ :Bj\’

right-hand areas Click Same as turning the rotary knob to the left of the right
Wheel Same as turning the rotary knob

Center of POSITION, {7

SCALE knob Click Same as pushing the POSITION knob or SCALE
Wheel knob

POSITION, SCALE, @ ;aj"

T/DIV, and MAG knob  Click Same as turning the POSITION, SCALE, T/DIV, and

left- and right-hand MAG knob to the left or the right

areas Wheel Same as turning the POSITION, SCALE, T/DIV, and

MAG knob

IM 701992-01E



8.4 Operating DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series from a PC

DLM2000 Series, DLM4000 Series, DL6000/DLM6000 Series, DL850 series

Mouse Pointer Displayed Icon & Setting Operation
Position Mouse Action
Operation Key hm
Click Same as when pressing a key.
Around the left or
right sideof the
jog shuttle

Wheel

Same as turning the jog shuttle to the left
or right. The setting can be changed at a
setting resolution of 1, 10, or 20 times
depending on the location of the mouse
pointer. Hold down the mouse button to
change the setting repeatedly.

Same as turning the jog shuttle.

™

Center of POSITION,  ifm
SCALE, TRIGGER Click
LEVEL, or ZOOM knob

Same as pushing the corresponding knob.

Around the left, right,
or bottom of
POSITION or
TRIGGER LEVEL knob

Click

Same as turning the corresponding knob to
the left or right. The setting can be changed
at a setting resolution of 1 or 10 times
depending on the location of the mouse
pointer. If you click in the bottom area where
the number 123 appears, an input box is
displayed for direct input of a setting value.
Hold down the mouse button to change the
setting repeatedly.

Same as turning the corresponding knob.

Around the left or

right of SCALE,
TIME/DIV, or Same as turning the corresponding knob to the left
ZOOM knob or right. The setting can be changed at a setting
resolution of 1 time.
Wheel Same as turning the corresponding knob.
Center of the SET 1G]
key Click Same as pressing the SET key.
Around the left, right, /,,1\___\
top, or bottom of the @
SET key Ny
Click Same as pushing the SET key in the direction of

the arrow.

IM 701992-01E
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8.4 Operating DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series from a PC

Example of Using the Control Screen

Using the Operation Keys

L3 & m MENT
(e (80, oy
e
zﬁﬁ

OO0l = -

Click to display the cursor menu.

Rotary Knob Operation

E. . & m weny
o o

T g u_n_p
& ) e e

"l 1] E F X

A\ & i e

_iEd A B c
°°° o e o o, vl

Click or turn the wheel

T/DIV Knob Operation

SCALE Knob Pushing Operation

Click or turn the wheel

Nofte
» If you hold down the ctrl key and right click in the control screen, you can select from the
following settings menu.
» Save (Image, Waveform)
* Zoom (Smaller, Standard, Larger)
* Pause

* Update
« Options
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8.6 Downloading the Instruments Waveform Data
(Other than the DL9000/SB5000/DLM2000/
DLM4000/DL6000/DLM6000/DL850 series)

Click the ACQ save on the Xviewer toolbar. A control screen and file save dialog box
open. If the connection with the instrument is not established, the Communication Setting
dialog box opens. Establish a connection with the instrument according to the operations
given in section 8.1.

Saving the Waveform Data
Set the destination and file name and click the OK. The extension is .wvf.

Explanation

Waveform data can be downloaded (saved) to the PC.

Click the CAPTURE on the control screen to display the file save dialog box. Set Save
as type to *.wvf, specify the file name, and select Save to download (save) the waveform
data.

Waveforms That Are Saved

All waveforms including computed waveforms displayed on the control screen are saved.
However, if multiple history waveforms are displayed with the history memory function,
only the waveform selected with Select Record is saved.

Applicable Models

» DL750 series (firmware version 6.01 or later)

» DL1600 series (firmware version 1.30 or later)
» DL1700E series (software version 2.11 or later)
» DL7400 series (software version 2.11 or later)
+ SL1400
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8.6 Downloading the Instruments Waveform Data (Other than the DL9000/SB5000/DLM2000/DLM4000/DL6000/DLM6000/DL850 series)

No

te

If the data compression setting of the instrument (P-P Comp, Decim, etc.) is ON, turn data

compression OFF before saving the waveform data.
On the DL1600 series, waveform data cannot be downloaded if the record length is greater
than or equal to 8 MW.
When multiple history waveforms are displayed, the instrument settings are changed when
downloading is executed as follows:

DL750 series, DL7400 series, and SL1400: HISTORY > DisplayMode > One

DL1600 series and DL1700E series: HISTORY > Display > One
Sub waveforms acquired using the dual capture function on the DL750 are not saved.
DL9000 series (firmware version 1.80 and later)
SB5000 series
DLM2000 series (firmware version 1.06 and later)

8-22
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8.7 Downloading DL9000/SB5000/DLM2000/
DLM4000/DL6000/DLM6000/DL850 series
Waveform Data

Procedure

Click the ACQ save on the Xviewer toolbar. A control screen and file save dialog box
open. If the connection with the instrument is not established, the Communication Setting
dialog box opens. Establish a connection with the instrument according to the operations
given in section 8.1.

Saving the Waveform Data
Set the destination and file name and click the OK. The extension is .wdf.

Explanation

Waveform data can be downloaded (saved) to the PC.

From the File menu on the control screen, point to Save and choose Waveform to
display the file save dialog box. Set Save as type to *.wdf, specify the file name, and
select Save to download (save) the waveform data.

Waveforms That Are Saved
All waveforms including computed waveforms displayed on the control screen are saved.

Applicable Models

» DL9000 series (firmware version 1.80 or later)

» SB5000 series

« DLM2000 series (firmware version 1.06 or later)
+ DL6000/DLM6000 series

» DL850 series

» DLM4000 series

Note

The image on the PC may be disrupted immediately after downloading waveform data. This

does not affect the data. The image will recover automatically after the next screen update.

IM 701992-01E 8-23

sjuswinisu| 8y} ypum Bunesiunwwod ﬂ



Chapter 9

Troubleshooting

9.1

Troubleshooting

Problem

Probable Cause/Corrective Action

An error occurs when installing

Another version of Xviewer is already installed.
Uninstall the other version of Xviewer, then
reinstall.

Xviewer cannot communicate with the
instruments (DL series, SL1400, SL1000, or
DLM2000, or DL6000/DLM6000, or DL850 series

The GP-IB, USB or Ethernet interface cable is
incorrectly connected

Connect the cable correctly.

The address specified for the GP-IB interface is
incorrect.

For instruments other than the DL9000, SB5000
SL1000 DLM2000/DL6000/DLM6000/ DL850
series, the ID of the USB interface might be set
incorrectly.

For instruments other than the DL9000, SB5000
SL1000 DLM2000/DL6000/DLM6000/ DL850/
DL850V, the serial number of the USB interface
might be set incorrectly.

A USB driver might not be installed.

The IP address, subnet mask, and default
gateway of the Ethernet interface might not be
set correctly.

With the SL1000 DLM2000/DL6000/DLM6000/
DL850 series, the VXI11 check box might not be
selected.

A file cannot be opened

A .hdr file having the same name as the file you
are trying to open is not present in the same
folder.

Place the header file in the folder.

The file is not of a type that the instrument
Xviewer can handle.

A trace name is incorrectly displayed

If a trace name includes a space, it may not
appear correctly.

A voice memo cannot be played back

Your PC does not support audio playback Use
Xviewer on a PC with sound capabilities.

Comments in files saved on the DL750 series are
not displayed

DL750.dIl does not exist in the folder in which
Xviewer is installed, or an old version of DL750.
dll exists Install the latest version of DL750.
dli(see page 2-3).

The Yokogawa web page is inaccessible

Your PC is connected with the Internet.

A message stating “Insufficient memory.
Terminate any unnecessary
applications.” appears.

There is insufficient memory Reduce the number
of waveforms to be loaded, or terminate another
application.

| cannot load files that were recorded in real time
on the SL1000/DL850 series series.

You may be specifying a divided file from real-
time recording other than the first file. Try loading
the first file (****_0000.WDF).

Note

For up-to-date information on the Xviewer, check the YOKOGAWA Web page (see section 9.4).
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9-2

9.2 Viewing Version Information

Procedure

Select Help > About Xviewer The version of Xviewer you are currently using is
displayed.

Hviewer

v r B | "‘ _Jf “
L Aviewer e

@ 2005-2011 Yokogawa Electric Corporation.All rights reserved.

Product Mame @ 701992 sviewer ~
Standard Edition(1 license)

Mersion (170

License Mo, 1 O01- sk hetbok— ekt

Adred lirense M. N02- mmmm—mmmm—mmm»lfMarhemariral Frinrtinn Add-0
<

Displays the version information including
the added license number
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9.3 Starting Online Help

Procedure

Explanation

?
Click 4, or choose Help > Help > User’s Manual on the tool bar If Acrobat Reader
is installed in the PC, it launches, and a pdf file of this instrument’s user’s manual is
displayed.

44 XviewerEYE

Fle View Window Conmect Tool [
® F) 3| _toKkoGawA Webpsge * | & 2 =
Contraller Iew Viewer Cloz Us

) RwiewerETE
Addliense nurber... DLB50AdvancedUtiy
About Hviewer...

Online Help
You can display a pdf file of this instrument’s user’s manual If a notice of alteration has

been made, you can display a pdf of the notice by choosing Help > Help > Notice of
Alteration from the tool bar.

Note

Adobe Reader by Adobe Systems is required to open PDF files You can download Adobe
Reader from the following Web page.
http://lwww.adobe.com/products/acrobat/readstep2.htmi

IM 701992-01E
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9.4 \Visiting the Yokogawa Web Page

Procedure

Explanation

Select Help > YOKOGAWA Web Page > Test & Measurement, or Help >
YOKOGAWA Web Page > Xviewer to access our web page.

File Views Window Connect  Tool

= F kot

Controllsr | Hew Viswsr  Clod gl

Hyigwer

Add license number...

About Xviewer, .,

When your PC is connected to the Internet, you can visit our web page.

Test & Measurement: Displays our Test & Measurement top page.

Xviewer: Displays the Xviewer page. Up-to-date information such as
updates on the Xviewer is provided.
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9.5 Adding a License Number

Procedure

,‘.,1‘ Xviewer

You can update the standard version of Xviewer by adding the license for the XViewer
Math Edition.

701992 Xviewer (latest standard version after version 1.31) must be installed before
installing the Computation Function Setup Upgrade Version.

If the version of Xviewer that you are using is old, uninstall it and then install the latest
Xviewer.

Nofte
» For the installation and uninstallation Procedures, see page xii.
» To check the version, see section 9.2, “Viewing Version Information.”

1. Start Xviewer (standard version) that is already installed.

2. Select Help > Add licenseNo. The dialog box for registering the license number
opens.

3. Enter the number indicated on the license label, and click Add If the upgrade
completes successfully, a message appears prompting you to restart Xviewer

4. Click OK.

5. Restart Xviewer.

Add LicenseNo - x|
File Wiew ‘Window Connect Tool | Help :

|

R @ 3 YOKOGAWS Web page » » Input a licensero you want add.
Cantroller i I D02-XxxX-XXXH-XxXX] add

Mew Viewer Clo: Help ¥

¥

x

@ Restart Xvigwer,

6. Select Help > About Xviewer. Check the version information. For details, see
section 9.2.
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Chapter 10 Specifications

10.1 Applicable Models and Features

Models from which Xviewer can load waveform data:

DL750 series, DL9000 series, SB5000 series, DL7400 series, DL1700 series, DL1700E
series, DL1600 series, WE7000, SL1400, SL1000, DLM2000 series, DLM4000 series,
DL6000/DLM6000 series, and DL850 series

File Types Supported by Xviewer

Files created and saved in binary format (.wvf files)
DL750/DL7400/DL1700/DL1700E/DL1600 series, SL1400, and WE7000

Files created and saved in ASCII format (.csv files)
DL750/DL9000/SB5000/DL7400/DL1700/DL1700E/DL1600 series, SL1400, WE7000,
DLM2000 series, DLM4000 series, DL6000/DLM6000, and DL850 series

Files created and saved in binary format (.wdf files) DL9000 series, SB5000 series,
SL1000, DLM2000 series, DLM4000 series, DL6000/DLM6000, and DL850 series
Files of data created with real-time recording (.wdf files)

DL750 series, SL1400, and SL1000

DL750 series, DL7400 series, DL1700E series, DL1600 series, DL9000 series, SB5000
series, SL1400, SL1000, DLM2000 series, DLM4000 series, DL6000/DLM6000, and
DL850 series

DL750 series, DL7400 series, DL1700E series, DL1600 series, DL9000 series, SB5000
series, SL1400, DLM2000 series, DLM4000 series, DL6000/DLM6000, and DL850 series
DL750 series (firmware version 6.01 or later),

DL1600 series (firmware version 1.30 or later),

DL1700E series (firmware version 2.11 or later),

DL7400 series (firmware version 2.11 or later),

DL9000 series (firmware version 1.80 or later),

SB5000 series, SL1400, and DLM2000 series

SL1400

DLM2000 series

DL6000/DLM6000 series

DL850 series

DLM4000 series

Main waveform view, zoom waveform view, history waveform view, X-Y waveform
view, and measurement result view

Measurements with vertical/horizontal/X-Y cursors

Waveform parameter automatic measurement/computational measurement (optional)/
Insertion of annotations

Multiple files conversion (wdf to wvf, wvf/wdf to csv)

Saving and printing of the data

Play back of voice memos saved with the DL750 series
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10.2 System Environment Requirements

Operating System

Microsoft Windows XP (SP 2 or later) |Microsoft Windows 7 or Windows 8

PC Hardware

CPU Pentium 4, 2 GHz or better Core 2 Duo, 2 GHz or better
Memo 1 GB or more 1 GB or more
Y (2 GB recommended) (2GB recommended)
ﬁ%age available on Free space equaling 2 GB + the size of files to be loaded
Peripherals
Display XGA or higher (Colors: 65536 or more)
Drive CD-ROM drive, mouse, and printer
Communication GP-IB'/USBEthernet
interface
GP-IB Board or ) . 3
PCMCIA Card GP-IB board made by National Instruments Corporation or PCMCIA card

Sound capabilities Required to play back voice memos.

1 Not supported by the SL1000.

2 To use the USB interface, a dedicated USB driver is required.

3 The operation of the PCMCIA-GPIB card is not guaranteed on Windows 7 or Windows 8.

DPI setting
To display the characters correctly on Xviewer, you must set the “Display Properties” of

Windows. In the Display Properties dialog box, click the Settings tab and click Advanced.
Under the General tab, set the “DPI setting” to Normal size (96 DPI). The Font size
setting under the Appearance tab in the Display Properties dialog box is irrelevant.
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10.3 Software Versions and the Added Functions

The table below shows the software versions and the corresponding added functions.
If the software is not of the newest version, you will not be able to use all the functions
covered in this manual. Check the software version on the version information screen
that appears by selecting Help > Version. For details on the procedure, see section 9.2.

Software Versions and the Main Functions That Have Been Added

Version Added Function Applicable Models Reference Page/
Section/Chapter
1.10 or later Support for DL9000" DL9000 Series Section 10.1
ACQ save function DL750 Series/ DL1600 Section 8.4
(Downloads the DL acquisition data to the PC) Series?
Log scale - Page 3-9 and section
(Set vertical and horizontal axes when displaying 3.4
the FFT waveform)
Display the range over which FFT is performed and All models® Section 4.6
set the start point
Display the computation start position marker and ~ All models® Page 4-19
set the start point
Analyze waveform data using H&V cursors All models® Section 4.2
File associations (wvf and wdf) - Page 1-1
(Double-click the file to start Xviewer)
Drag and drop CSV files on the viewer window - Page 2-4
Restore the waveform color and the number of DL750 Series/ DL9000 -
divided displays when the file is loaded* Series
1.20 or later Supports the DL90005 DL9000 Section 8.5 and
10.1
ACQ save function DL1700E/DL7400 series®  Section 8.4
(Downloads the DL acquisition data to the PC)
Copying of cursor/waveform parameter - Sections 4.2 and
measurement results to the clipboard 4.3
Automatic display of the measurement results - Section 4.1
window
Restored when loading waveform color, number of DL1600/DL1700E/ DL7400 —
display divisions, and vertical axis upper and lower series
limit values’
Arrange Controller window/Xviewer tool bar/Viewer — Section 1.2
window
Displays T/Div and V/Div on the waveform display — Section 3.4
window
1.21 or later Open DL, and ACQ save function DL9000 series® Section 8.1, 8.2,
(Displays and transfers DL files and downloads the 8.3,8.7 and 10.1
acquisition data to the PC)
1.30 or later Supports the SL1400 SL1400 Section 10.1
Report function - Chapter 7
Displays 0 level on the waveform display window — — Page 3-11
1.31 or later Support for DL9710L. DL9710L Chapter 8
Additional display format of the measured result - Page 3-5

(hexadecimal, Bundle display)

Additional Measure item (integration of the X-Y
waveform)

Pages 4-8 and 4-9

Horizontal zoom operation (expand or reduce at the —

clicked position and drag the window)

Section 2.6

(Continues to the next page)
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10.3 Software Versions and the Added Functions

Version Added Function Applicable Models Reference Page/
Section/Chapter
1.31 or later Bit Label display and multiple vertical axes display — Page 3-11
added to the waveform display window
Edit function added to the report function (undo, - Section 7.2
redo, and grid display)
Save format of the screen image added inthe DL — Section 8.5
control
Overlaying of the X-Y waveforms - Section 2.5
1.32 or later Support for the DL1735E, DL9505L, DL9510L, and DL1735E, DL9505L, -
DL9705L. DL9510L, DL9705L
Changed button names (Open DL -> Open Inst., - Sections 1.2, 8.1,8.2,
and DL Control-> Control Inst.). and 8.4
Added function for selecting Absolute Time or - Sections 5.1 and 5.6
Relative Time when saving ASCI| files.
Changed name of CSV conversion function menu  — Section 5.6

(Convert to CSV -> CSV Multiple files conversion),
and added function for selecting the save folder.

Added function for converting WDF files to multiple — Section 5.7
WVF files.
Added function for setting the background colorto - Section 6.2
white for printing.
Added function to the report function for savingto  — Section 7.3
rich text format (rtf).
1.33 or later Support for SL1000. - Section 10.1
1.34 or later Support for SB5000 series. SL1000 SB5310/SB5710  Section 10.1
1.40 or later Support for Windows Vista — Section 10.2
Added function for manual placement of waveforms — Section 3.2
on the split screen
Added character size changing function for T/div - Section 3.4
display
Added initialization function for screen display - Section 3.6
conditions
Added types of annotations, and improved — Section 4.7
annotation functions
1.41 or later Support for DLM2000 series (excluding GP-IB DLM2022/DLM2024/ Section 10.1
communications and the acquisition data download DLMZ2032/ download
function.) DLM2034/DLM2052/
DLM2054
1.43 or later Full support for the DLM2000 series DLM2022/DLM2024/ Section 10.1
DLM2032/ DLM2034/
DLM2052/DLM2054
1.44 or later Support for the SL1000 mark function SL1000 Section 10.1
1.51 or later Support for DL6000/DLM6000 series DL6000/DLM6000 series ~ Section 10.1
1.60 or later Added function for converting WDF/WVF files to - Section 5.8
multiple FLD files.
Support for DL850 DL850 Section 10.1
Support for Windows 7
Support for Floating Point Decimal Files
1.61 or later Support for DL850V DL850 Advanced Utirity DL850 Section 10.1 or
IM701992-62E
1.62 or later Support for the merging files to view the waveforms DL850/DL850V IM701992-62E
of multiple files at the same time
1.63 or later Support for the DL850V version-up DL850/DL850V -
Support for the Xviewer EYE IM701992-61E
1.64 or later Support for the DL850/DL850V Real Time Math(/  DL850/DL850V -
G3)

(Continues to the next page)
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10.3 Software Versions and the Added Functions

Version Added Function Applicable Models Reference Page/
Section/Chapter
1.70 or later Added automated measurement functions for history — Sections 4.4 and 4.5
statistics and cycle statistics to the automated
measurement of waveform parameters
Added history statistics and cycle statistics to the — — Section 4.7
annotation types
Added a feature for turning waveform interpolation — Section 3.3
on and off
Support for Math operations over a specified range — Section 4.6
Added a feature for changing the waveform - Section 3.4
thickness and grid line thickness that are displayed
on the screen
1.72 or later Support for model 720241 16-CH Temperature/ DL850/DL850V -
Voltage Input Module for DL850/DL850V and model
720221 CAN & LIN Bus Monitor Module for DL850V
1.73 or later Support for the DLM4000 series DLM4000 Section 10.1
Added a feature that measures cycle statistics Section 4.6
over the entire range (mode in which automatic
measurement is not performed).
1.74 or later Support for the DLM4000 series logic 16 bit input. ~ DLM4000 Section 10.1
Added file division for each history waveform. Section 5.6
1.75 or later Support for the DL850E/DL850EV DL850E/DL850EV Section 10.1
1.76 or later Support for Windows 7 - -

End of support for Windows Vista

Support for model 701281 frequency module DL850 series, SL1000

1 Waveform data (wdf file) can be loaded.

2 Supported on version 1.30 or later on the DL1600 Series and version 6.01 or later on the DL750 Series.

3 DL750 Series, DL9000 Series, DL7400 Series, DL1700 Series, DL1700E Series, DL1600 Series, and WE7000 are added to
the waveform display window

4 With the DL750 series, even if you load files that were saved with P-P Com ON in the Save As dialog box, the Upper/Lower,
colors, and number of screen divisions are not restored.

5 Only remote control possible

6 DL1700E series: Version 2.11 or later, DL7400 series: version 2.11 or later

7  With the DL1600 series, even if you load files that were saved with Invert ON in the channel settings, the Invert information

is not restored.

8 DL9000 series: Version 1.80 or later

IM 701992-01E
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